Change in ovirt-engine[master]: core: cleanup in RunVmCommand

ofrenkel at redhat.com ofrenkel at redhat.com
Mon Aug 12 08:58:02 UTC 2013


Omer Frenkel has submitted this change and it was merged.

Change subject: core: cleanup in RunVmCommand
......................................................................


core: cleanup in RunVmCommand

1. remove '_' prefix from class fields

2. define a static field that stores "iso://" string

3. use #cdPathWindowsToLinux method instead of calling
ImagesHandler.cdPathWindowsToLinux explicitly in some places.

4. reference RunVmCommand#ISO_PREFIX from the test class, instead of
defining the iso prefix string again in the test class

5. use IsoDomainListSyncronizer#findActiveISODomain to find active iso
domain instead of having duplicated code

6. inline fields in canDoAction method

7. separate network interfaces validations in canDoAction method from
the validator checks to make it more clear

Change-Id: Ia37a78eacd6c415a9bf10920362140736c7d70fc
Signed-off-by: Arik Hadas <ahadas at redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/RunVmCommandTest.java
2 files changed, 45 insertions(+), 60 deletions(-)

Approvals:
  Omer Frenkel: Verified; Looks good to me, approved



-- 
To view, visit http://gerrit.ovirt.org/17577
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: Ia37a78eacd6c415a9bf10920362140736c7d70fc
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas at redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas at redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel at redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan at redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server



More information about the Engine-commits mailing list