Change in ovirt-engine[ovirt-engine-3.6.7]: core: StorageDomainDaoTest cleanups backport

tnisan at redhat.com tnisan at redhat.com
Thu Jun 2 13:48:51 UTC 2016


Tal Nisan has submitted this change and it was merged.

Change subject: core: StorageDomainDaoTest cleanups backport
......................................................................


core: StorageDomainDaoTest cleanups backport

This patch backports a series of cleanups done to StorageDomainDaoTest
in order to facilitate bugfixes in the following patches.

It includes:
- Fixing naming conventions of the class' methods
- Removing a useless member
- Using constants from the FixturesTool
- Fixing the order the assertEquals parameters
- Removing redundant whitespaces that hinder the code's readability
- Removing some pointless assertions

Note this patch should also have a [very slight] performance
improvement, as it uses a pre-created Guids instead of invoking the
constructor several times and removing some useless assertions.

This patch contains the fixes introduced in patches 3158869..15d72f1
from the master branch.

Related-To: https://bugzilla.redhat.com/1337257
Related-To: https://bugzilla.redhat.com/1341661
Change-Id: I8f25dfbd3530b555a0c2aa3ff992990274be6db8
Signed-off-by: Allon Mureinik <amureini at redhat.com>
---
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/StorageDomainDaoTest.java
1 file changed, 42 insertions(+), 106 deletions(-)

Approvals:
  Tal Nisan: Looks good to me, approved
  Jenkins CI: Passed CI tests
  Allon Mureinik: Verified



-- 
To view, visit https://gerrit.ovirt.org/58533
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I8f25dfbd3530b555a0c2aa3ff992990274be6db8
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6.7
Gerrit-Owner: Allon Mureinik <amureini at redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini at redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan at redhat.com>



More information about the Engine-commits mailing list