<html>
<head>
<meta content="text/html; charset=windows-1252"
http-equiv="Content-Type">
</head>
<body text="#000000" bgcolor="#FFFFFF">
Supporting Chandra, I think gingerbase, gingerppc, gingers390x
should be okay even with readability point of view when compared
with other existing python modules like ossaudiodev, sunaudiodev,
gensuitemodule etc..
<meta http-equiv="content-type" content="text/html;
charset=windows-1252">
<br>
<br>
<div class="moz-cite-prefix">On 08/27/2015 04:20 PM, Chandra
Shehkhar Reddy Potula wrote:<br>
</div>
<blockquote cite="mid:55DEEB64.20301@linux.vnet.ibm.com" type="cite">
<meta content="text/html; charset=windows-1252"
http-equiv="Content-Type">
<br>
<div class="moz-cite-prefix">On 08/27/2015 12:40 AM, Chandra
Shehkhar Reddy Potula wrote:<br>
</div>
<blockquote cite="mid:55DE0F17.7090702@linux.vnet.ibm.com"
type="cite">
<meta content="text/html; charset=windows-1252"
http-equiv="Content-Type">
<br>
<div class="moz-cite-prefix">On 08/27/2015 12:33 AM, Paulo
Ricardo Paz Vital wrote:<br>
</div>
<blockquote
cite="mid:CAFe=of7oQJo-ME2C-MQX16eO5QzOV5Uuqca76D7Z+=CDLwYpqg@mail.gmail.com"
type="cite">
<div dir="ltr">Supporting what Kevin mentioned, once PEP8
allows underscores, I think that ginger_base, ginger_ppc,
etc is better than name with no division.</div>
</blockquote>
I know that it improves readability, but on the other hand PEP8
guidelines discouraging usage of under score too in the module
naming convention. <br>
Also think of how the REST API URI should look like.<br>
</blockquote>
<br>
Also I went through some core python module developed and their
naming conventions. Most of them are with out underscore even
though they have multiple words in the name.<br>
<a moz-do-not-send="true" class="moz-txt-link-freetext"
href="https://docs.python.org/2/py-modindex.html">https://docs.python.org/2/py-modindex.html</a><br>
<br>
For example: <a moz-do-not-send="true"
href="https://docs.python.org/2/library/macostools.html#module-findertools"><tt
class="xref">findertools, </tt> </a><a
moz-do-not-send="true"
href="https://docs.python.org/2/library/functools.html#module-functools"><tt
class="xref">functools, </tt></a><a moz-do-not-send="true"
href="https://docs.python.org/2/library/contextlib.html#module-contextlib"><tt
class="xref">contextlib, </tt></a><a moz-do-not-send="true"
href="https://docs.python.org/2/library/compileall.html#module-compileall"><tt
class="xref">compileall, distutils, ensurepip, findertools, </tt></a><a
moz-do-not-send="true"
href="https://docs.python.org/2/library/ftplib.html#module-ftplib"><tt
class="xref">ftplib, </tt></a><a moz-do-not-send="true"
href="https://docs.python.org/2/library/gensuitemodule.html#module-gensuitemodule"><tt
class="xref">gensuitemodule, </tt></a><tt class="xref"><a
moz-do-not-send="true"
href="https://docs.python.org/2/library/gensuitemodule.html#module-gensuitemodule"><tt
class="xref"> </tt></a><tt class="xref"><a
moz-do-not-send="true"
href="https://docs.python.org/2/library/htmllib.html#module-htmlentitydefs"><tt
class="xref">htmlentitydefs</tt></a>, </tt>htplib, </tt><a
moz-do-not-send="true"
href="https://docs.python.org/2/library/gensuitemodule.html#module-gensuitemodule"><tt
class="xref">importlib, </tt></a><a moz-do-not-send="true"
href="https://docs.python.org/2/library/itertools.html#module-itertools"><tt
class="xref">itertools</tt></a>, <tt class="xref"><a
moz-do-not-send="true"
href="https://docs.python.org/2/library/ossaudiodev.html#module-ossaudiodev"><tt
class="xref">ossaudiodev</tt></a>, pickletools, </tt><a
moz-do-not-send="true"
href="https://docs.python.org/2/library/rlcompleter.html#module-rlcompleter"><tt
class="xref">rlcompleter, telentlib, unicodedata, zipimport
etc...</tt></a><br>
<br>
Let me go ahead with gingerbase, gingerppc, gingers390x as plugin
names unless some one has serious objections.<br>
<br>
Will use the same name in the REST API uri as well. <br>
<br>
For example:<br>
<meta http-equiv="content-type" content="text/html;
charset=windows-1252">
<pre style="background-color:#ffffff;color:#000000;font-family:'DejaVu Sans Mono';font-size:9.1pt;"><span style="color:#008000;font-weight:bold;">plugins/gingerbase/host
</span><meta http-equiv="content-type" content="text/html; charset=windows-1252"><span style="color:#008000;font-weight:bold;">plugins/gingerbase/host/stats
so on ...
</span></pre>I totally understand the readability part but I think going with out "-" or "_" in the module name be the better choice.
Let me know !!!
Regards
Chandra
<blockquote cite="mid:55DE0F17.7090702@linux.vnet.ibm.com" type="cite">
<blockquote cite="mid:CAFe=of7oQJo-ME2C-MQX16eO5QzOV5Uuqca76D7Z+=CDLwYpqg@mail.gmail.com" type="cite">
<div class="gmail_quote">
<div dir="ltr">On Wed, Aug 26, 2015 at 3:38 PM Kevin Zander <<a moz-do-not-send="true" class="moz-txt-link-abbreviated" href="mailto:klzander@linux.vnet.ibm.com">klzander@linux.vnet.ibm.com</a>>
wrote:
</div>
<blockquote class="gmail_quote" style="margin:0 0 0
.8ex;border-left:1px #ccc solid;padding-left:1ex">
<div>
<div>On Wed, 2015-08-26 at 23:50 +0530, Chandra Shehkhar
Reddy Potula wrote:</div>
<blockquote type="cite"> Hi all,
Do we need to consider PEP 8 guidelines while naming the
plugin ?
<a moz-do-not-send="true" href="https://www.python.org/dev/peps/pep-0008/#package-and-module-names" target="_blank">https://www.python.org/dev/peps/pep-0008/#package-and-module-names</a>
</blockquote>
<div>
</div>
</div>
<div>
<div>PEP8 allows underscores. This could solve the problem I
think. ginger_base, ginger_ppc, etc.</div>
</div>
<div>
<div>
</div>
<blockquote type="cite">
I see some issue by having "-" in the python plugin naming
convention (ex: ginger-base), as import will not work
directly.
Example: in the consider tests/test_host.py file, which
contains statement
<span>from</span> kimchi.mockmodel <span>import</span>
MockModel
when moved to ginger-base plugin become
<span>from</span> ginger-base.mockmodel <span>import</span>
MockModel
python import will not recognize the module name with "-"
I could overcome that by :
<pre><code><span>import</span><span> importlib
mod </span><span>=</span><span> importlib</span><span>.</span><span>import_module</span><span>(</span><span>"path.to.my-module"</span><span>)
or
</span></code><code><span>module </span><span>=</span><span> __import__</span><span>(</span><span>"</span></code><code><span><code><span>path.to.my-module</span></code>"</span><span>)</span></code>
</pre>
But I feel, It is not adhering PEP 8 guidelines.
So my proposal would be not to have "-" in the module name
? ie. gingerbase, gingerppc, gingers390x etc.. if so even
api has to have the same convention ?
Any better suggestions are welcome.
Thanks and Regards
Chandra
<div>On 08/12/2015 06:39 PM, Chandra Shehkhar Reddy Potula
wrote:
</div>
<blockquote type="cite"> Fine with me !!!
<div>On 08/12/2015 06:13 PM, Daniel Henrique Barboza
wrote:
</div>
<blockquote type="cite">
<div>On 08/12/2015 09:08 AM, Aline Manera wrote:
</div>
<blockquote type="cite">
<div>On 11/08/2015 13:27, Kevin Zander wrote:
</div>
<blockquote type="cite">
<div>On Tue, 2015-08-11 at 11:47 -0300, Aline
Manera wrote:</div>
<blockquote type="cite"> Hi all,
As we have agreed on moving the Kimchi Host tab
to Ginger community and creating a new plugin
(ginger-basic), I want to list step-by-step what
we need to do *on Kimchi side*.
1) Will we call this new plugin as ginger-basic?
Any other suggestion?
</blockquote>
<div>
</div>
<div>I think keeping it as ginger is better.
ginger-basic sounds like there's ginger-advanced
(or similar), when there really isn't anything
like that. What we have is just additional
functionality based on your OS flavor. So
keeping ginger as the plugin name, to me, is the
easiest. Then all it takes is looking up your
flavor: ginger-[ppc|z|pickled].</div>
<div>
</div>
</blockquote>
About the plugin name: does ginger-base sound
better? As it will the base for all the other ginger
plugins which will extend the Host tab.
</blockquote>
'ginger-base' looks OK to me
The other plug-in can be called simply 'ginger' in
this case.
<blockquote type="cite">
<blockquote type="cite">
<blockquote type="cite">
2) Create the new plugin structure into wok
branch, ie, create a directory named
ginger-basic (?) and all it is needed to launch
it as a wok plugin, including building and
packaging details.
In this first moment, the entire Host tab
will be part of the ginger-basic - just to move
the discussion as soon as possible to Ginger
community.
3) Add ginger-basic plugin as a Kimchi
dependency.
Once we have those items done, I will create a
new repository for ginger-basic under
kimchi-project organization in Github.
After that, the discussion *will be moved to
Ginger community*, ie, all patches and
discussion must be sent to the Ginger mailing
list (<a moz-do-not-send="true" href="https://lists.nongnu.org/mailman/listinfo/ginger-dev-list" style="color:rgb(64,120,192);text-decoration:none;font-family:'Helvetica
Neue',Helvetica,'Segoe
UI',Arial,freesans,sans-serif;font-size:16px;font-style:normal;font-variant:normal;font-weight:normal;letter-spacing:normal;line-height:20.4799995422363px;text-align:left;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;background-color:rgb(255,255,255)" target="_blank">https://lists.nongnu.org/mailman/listinfo/ginger-dev-list</a><span><span></span></span>)
I have sent to Ginger community the next steps
to be done there. Please, check:
"[Ginger-dev-list] [RFC] Inheriting Kimchi's
Host tab"
Let me know what you think about that.
Regards,
Aline Manera
<pre>_______________________________________________
Kimchi-devel mailing list
<a moz-do-not-send="true" href="mailto:Kimchi-devel@ovirt.org" target="_blank">Kimchi-devel@ovirt.org</a>
<a moz-do-not-send="true" href="http://lists.ovirt.org/mailman/listinfo/kimchi-devel" target="_blank">http://lists.ovirt.org/mailman/listinfo/kimchi-devel</a>
</pre>
</blockquote>
</blockquote>
<fieldset></fieldset>
<pre>_______________________________________________
Kimchi-devel mailing list
<a moz-do-not-send="true" href="mailto:Kimchi-devel@ovirt.org" target="_blank">Kimchi-devel@ovirt.org</a>
<a moz-do-not-send="true" href="http://lists.ovirt.org/mailman/listinfo/kimchi-devel" target="_blank">http://lists.ovirt.org/mailman/listinfo/kimchi-devel</a>
</pre>
</blockquote>
<fieldset></fieldset>
<pre>_______________________________________________
Kimchi-devel mailing list
<a moz-do-not-send="true" href="mailto:Kimchi-devel@ovirt.org" target="_blank">Kimchi-devel@ovirt.org</a>
<a moz-do-not-send="true" href="http://lists.ovirt.org/mailman/listinfo/kimchi-devel" target="_blank">http://lists.ovirt.org/mailman/listinfo/kimchi-devel</a>
</pre>
</blockquote>
</blockquote>
<pre>_______________________________________________
Kimchi-devel mailing list
<a moz-do-not-send="true" href="mailto:Kimchi-devel@ovirt.org" target="_blank">Kimchi-devel@ovirt.org</a>
<a moz-do-not-send="true" href="http://lists.ovirt.org/mailman/listinfo/kimchi-devel" target="_blank">http://lists.ovirt.org/mailman/listinfo/kimchi-devel</a>
</pre>
</blockquote>
</div>
_______________________________________________
Kimchi-devel mailing list
<a moz-do-not-send="true" href="mailto:Kimchi-devel@ovirt.org" target="_blank">Kimchi-devel@ovirt.org</a>
<a moz-do-not-send="true" href="http://lists.ovirt.org/mailman/listinfo/kimchi-devel" rel="noreferrer" target="_blank">http://lists.ovirt.org/mailman/listinfo/kimchi-devel</a>
</blockquote>
</div>
</blockquote>
<fieldset class="mimeAttachmentHeader"></fieldset>
<pre wrap="">_______________________________________________
Kimchi-devel mailing list
<a moz-do-not-send="true" class="moz-txt-link-abbreviated" href="mailto:Kimchi-devel@ovirt.org">Kimchi-devel@ovirt.org</a>
<a moz-do-not-send="true" class="moz-txt-link-freetext" href="http://lists.ovirt.org/mailman/listinfo/kimchi-devel">http://lists.ovirt.org/mailman/listinfo/kimchi-devel</a>
</pre>
</blockquote>
<fieldset class="mimeAttachmentHeader"></fieldset>
<pre wrap="">_______________________________________________
Kimchi-devel mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Kimchi-devel@ovirt.org">Kimchi-devel@ovirt.org</a>
<a class="moz-txt-link-freetext" href="http://lists.ovirt.org/mailman/listinfo/kimchi-devel">http://lists.ovirt.org/mailman/listinfo/kimchi-devel</a>
</pre>
</blockquote>
</body></html>