<html>
<head>
<meta content="text/html; charset=utf-8" http-equiv="Content-Type">
</head>
<body text="#000000" bgcolor="#FFFFFF">
<br>
<div class="moz-cite-prefix">On 08/27/2015 12:33 AM, Paulo Ricardo
Paz Vital wrote:<br>
</div>
<blockquote
cite="mid:CAFe=of7oQJo-ME2C-MQX16eO5QzOV5Uuqca76D7Z+=CDLwYpqg@mail.gmail.com"
type="cite">
<div dir="ltr">Supporting what Kevin mentioned, once PEP8 allows
underscores, I think that ginger_base, ginger_ppc, etc is better
than name with no division.</div>
</blockquote>
I know that it improves readability, but on the other hand PEP8
guidelines discouraging usage of under score too in the module
naming convention. <br>
Also think of how the REST API URI should look like.<br>
<blockquote
cite="mid:CAFe=of7oQJo-ME2C-MQX16eO5QzOV5Uuqca76D7Z+=CDLwYpqg@mail.gmail.com"
type="cite"><br>
<div class="gmail_quote">
<div dir="ltr">On Wed, Aug 26, 2015 at 3:38 PM Kevin Zander <<a
moz-do-not-send="true"
href="mailto:klzander@linux.vnet.ibm.com"><a class="moz-txt-link-abbreviated" href="mailto:klzander@linux.vnet.ibm.com">klzander@linux.vnet.ibm.com</a></a>>
wrote:<br>
</div>
<blockquote class="gmail_quote" style="margin:0 0 0
.8ex;border-left:1px #ccc solid;padding-left:1ex">
<div>
<div>On Wed, 2015-08-26 at 23:50 +0530, Chandra Shehkhar
Reddy Potula wrote:</div>
<blockquote type="cite"> Hi all,<br>
<br>
Do we need to consider PEP 8 guidelines while naming the
plugin ?<br>
<a moz-do-not-send="true"
href="https://www.python.org/dev/peps/pep-0008/#package-and-module-names"
target="_blank">https://www.python.org/dev/peps/pep-0008/#package-and-module-names</a><br>
</blockquote>
<div><br>
</div>
</div>
<div>
<div>PEP8 allows underscores. This could solve the problem I
think. ginger_base, ginger_ppc, etc.</div>
</div>
<div>
<div><br>
</div>
<blockquote type="cite"> <br>
I see some issue by having "-" in the python plugin naming
convention (ex: ginger-base), as import will not work
directly. <br>
Example: in the consider tests/test_host.py file, which
contains statement <br>
<span>from</span> kimchi.mockmodel <span>import</span>
MockModel<br>
<br>
when moved to ginger-base plugin become<br>
<br>
<span>from</span> ginger-base.mockmodel <span>import</span>
MockModel<br>
python import will not recognize the module name with "-"<br>
<br>
I could overcome that by :<br>
<pre><code><span>import</span><span> importlib
mod </span><span>=</span><span> importlib</span><span>.</span><span>import_module</span><span>(</span><span>"path.to.my-module"</span><span>)
or
</span></code><code><span>module </span><span>=</span><span> __import__</span><span>(</span><span>"</span></code><code><span><code><span>path.to.my-module</span></code>"</span><span>)</span></code>
</pre>
<br>
But I feel, It is not adhering PEP 8 guidelines.<br>
<br>
So my proposal would be not to have "-" in the module name
? ie. gingerbase, gingerppc, gingers390x etc.. if so even
api has to have the same convention ?<br>
<br>
Any better suggestions are welcome.<br>
<br>
Thanks and Regards<br>
Chandra<br>
<br>
<div>On 08/12/2015 06:39 PM, Chandra Shehkhar Reddy Potula
wrote:<br>
</div>
<blockquote type="cite"> Fine with me !!!<br>
<br>
<div>On 08/12/2015 06:13 PM, Daniel Henrique Barboza
wrote:<br>
</div>
<blockquote type="cite"> <br>
<br>
<div>On 08/12/2015 09:08 AM, Aline Manera wrote:<br>
</div>
<blockquote type="cite"> <br>
<br>
<div>On 11/08/2015 13:27, Kevin Zander wrote:<br>
</div>
<blockquote type="cite">
<div>On Tue, 2015-08-11 at 11:47 -0300, Aline
Manera wrote:</div>
<blockquote type="cite"> Hi all,<br>
<br>
As we have agreed on moving the Kimchi Host tab
to Ginger community and creating a new plugin
(ginger-basic), I want to list step-by-step what
we need to do *on Kimchi side*.<br>
<br>
1) Will we call this new plugin as ginger-basic?
Any other suggestion?<br>
</blockquote>
<div><br>
</div>
<div>I think keeping it as ginger is better.
ginger-basic sounds like there's ginger-advanced
(or similar), when there really isn't anything
like that. What we have is just additional
functionality based on your OS flavor. So
keeping ginger as the plugin name, to me, is the
easiest. Then all it takes is looking up your
flavor: ginger-[ppc|z|pickled].</div>
<div><br>
</div>
</blockquote>
<br>
About the plugin name: does ginger-base sound
better? As it will the base for all the other ginger
plugins which will extend the Host tab.<br>
</blockquote>
<br>
'ginger-base' looks OK to me<br>
<br>
The other plug-in can be called simply 'ginger' in
this case. <br>
<br>
<blockquote type="cite"> <br>
<blockquote type="cite">
<blockquote type="cite"> <br>
2) Create the new plugin structure into wok
branch, ie, create a directory named
ginger-basic (?) and all it is needed to launch
it as a wok plugin, including building and
packaging details.<br>
In this first moment, the entire Host tab
will be part of the ginger-basic - just to move
the discussion as soon as possible to Ginger
community.<br>
<br>
3) Add ginger-basic plugin as a Kimchi
dependency.<br>
<br>
Once we have those items done, I will create a
new repository for ginger-basic under
kimchi-project organization in Github.<br>
After that, the discussion *will be moved to
Ginger community*, ie, all patches and
discussion must be sent to the Ginger mailing
list (<a moz-do-not-send="true"
href="https://lists.nongnu.org/mailman/listinfo/ginger-dev-list"
style="color:rgb(64,120,192);text-decoration:none;font-family:'Helvetica
Neue',Helvetica,'Segoe
UI',Arial,freesans,sans-serif;font-size:16px;font-style:normal;font-variant:normal;font-weight:normal;letter-spacing:normal;line-height:20.4799995422363px;text-align:left;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;background-color:rgb(255,255,255)"
target="_blank">https://lists.nongnu.org/mailman/listinfo/ginger-dev-list</a><span><span></span></span>)<br>
<br>
I have sent to Ginger community the next steps
to be done there. Please, check:
"[Ginger-dev-list] [RFC] Inheriting Kimchi's
Host tab"<br>
<br>
Let me know what you think about that.<br>
<br>
Regards,<br>
Aline Manera<br>
<br>
<br>
<pre>_______________________________________________
Kimchi-devel mailing list
<a moz-do-not-send="true" href="mailto:Kimchi-devel@ovirt.org" target="_blank">Kimchi-devel@ovirt.org</a>
<a moz-do-not-send="true" href="http://lists.ovirt.org/mailman/listinfo/kimchi-devel" target="_blank">http://lists.ovirt.org/mailman/listinfo/kimchi-devel</a>
</pre>
</blockquote>
</blockquote>
<br>
<br>
<fieldset></fieldset>
<br>
<pre>_______________________________________________
Kimchi-devel mailing list
<a moz-do-not-send="true" href="mailto:Kimchi-devel@ovirt.org" target="_blank">Kimchi-devel@ovirt.org</a>
<a moz-do-not-send="true" href="http://lists.ovirt.org/mailman/listinfo/kimchi-devel" target="_blank">http://lists.ovirt.org/mailman/listinfo/kimchi-devel</a>
</pre>
</blockquote>
<br>
<br>
<fieldset></fieldset>
<br>
<pre>_______________________________________________
Kimchi-devel mailing list
<a moz-do-not-send="true" href="mailto:Kimchi-devel@ovirt.org" target="_blank">Kimchi-devel@ovirt.org</a>
<a moz-do-not-send="true" href="http://lists.ovirt.org/mailman/listinfo/kimchi-devel" target="_blank">http://lists.ovirt.org/mailman/listinfo/kimchi-devel</a>
</pre>
</blockquote>
<br>
</blockquote>
<br>
<pre>_______________________________________________
Kimchi-devel mailing list
<a moz-do-not-send="true" href="mailto:Kimchi-devel@ovirt.org" target="_blank">Kimchi-devel@ovirt.org</a>
<a moz-do-not-send="true" href="http://lists.ovirt.org/mailman/listinfo/kimchi-devel" target="_blank">http://lists.ovirt.org/mailman/listinfo/kimchi-devel</a>
</pre>
</blockquote>
</div>
_______________________________________________<br>
Kimchi-devel mailing list<br>
<a moz-do-not-send="true" href="mailto:Kimchi-devel@ovirt.org"
target="_blank">Kimchi-devel@ovirt.org</a><br>
<a moz-do-not-send="true"
href="http://lists.ovirt.org/mailman/listinfo/kimchi-devel"
rel="noreferrer" target="_blank">http://lists.ovirt.org/mailman/listinfo/kimchi-devel</a><br>
</blockquote>
</div>
</blockquote>
<br>
</body>
</html>