On Wed, Aug 1, 2018 at 5:11 AM, Yedidyah Bar David <didi@redhat.com> wrote:
On Wed, Aug 1, 2018 at 11:37 AM, Yedidyah Bar David <didi@redhat.com> wrote:
On Wed, Aug 1, 2018 at 9:46 AM, Yedidyah Bar David <didi@redhat.com> wrote:
On Tue, Jul 31, 2018 at 5:04 PM, Greg Sheremeta <gshereme@redhat.com> wrote:
Scott noticed while using my ansible dev env setup role that some packages changed names. Looks like there are py2 and py3 versions. I had assumed that was from this work -- is that correct? Since this work brings much instability for developers, it's important to communicate this stuff before it breaks ;)

Greg I'm PRing your ansible role with the package names that I ended up using that worked on f28 and centos7.

Sorry, you are right.

Now pushed this to revert for now:


Once it's merged, you can use the below workaround (amended) to default to python3,
until we revert above patch, hopefully soon.

Merged now, should land in master snapshot repo soon. Sorry for the noise.

BTW, we only default(ed) to python3 if python3-otopi was installed, which is not
(yet!) required by the engine. So another fix is to not install it.

Or to remove it if it got installed by accident (which was the last bit I needed to fix before engine setup worked on my f28).