On Fri, Dec 29, 2017 at 1:04 PM, Eyal Edri <eedri@redhat.com> wrote:

On Dec 28, 2017 22:01, "Barak Korren" <bkorren@redhat.com> wrote:
If you're on this list you've probably seen the failure emails from the 4.2 CQ.

The reason it is failing is that OST is failing to install engine,
because there is no engine package available to it.

The 4.2 tested repo does not contain an engine package ATM.

ther does not seem to be any other repo configured in reposync for 4.2
ATM that engine could be taken from.

Wern't we supposed to have 4.1 as a fallback repo fore 4.2 OST until
everything branches?

No, 4.1 doesn't work with 4.2.
The fallback is the official 4.2 ga repo, which should have all pkgs and it worked when tested, so not sure why it's failing now.
Maybe we should disable tested repo until engine branches. 

As things stand right now, its is quite likely that a 4,2 tested repo
will not get built because everything needs an engine package to pass
OST and the engine package need a great deal of other things to work,
not to mention vdsm

All should come from ovirt-4.2 repo. 

This is the problem:

2017-12-28 17:21:56,323::ERROR::repoman.common.parser::No artifacts found for source /var/lib/lago/ovirt-4.2-el7:only-missing

We need to find out why repoman can't read RPMs from the official 4.2 repo.

[1] http://jenkins.ovirt.org/view/Change%20queue%20jobs/job/ovirt-4.2_change-queue-tester/179/artifact/exported-artifacts/basic-suit-4.2-el7/lago_logs/lago.log

Barak Korren
RHV DevOps team , RHCE, RHCi
Red Hat EMEA
redhat.com | TRIED. TESTED. TRUSTED. | redhat.com/trusted
Infra mailing list


Eyal edri


RHV DevOps


Red Hat EMEA

phone: +972-9-7692018
irc: eedri (on #tlv #rhev-dev #rhev-integ)