On Wed, Sep 28, 2016 at 4:28 PM, Nicolas Ecarnot <nicolas@ecarnot.net> wrote:
Le 26/09/2016 à 12:04, Yedidyah Bar David a écrit :
On Mon, Sep 26, 2016 at 1:02 PM, Nicolas Ecarnot <nicolas@ecarnot.net> wrote:
Le 26/09/2016 à 12:00, Yedidyah Bar David a écrit :

On Mon, Sep 26, 2016 at 12:36 PM, Nicolas Ecarnot <nicolas@ecarnot.net>

Le 26/09/2016 à 10:55, Yedidyah Bar David a écrit :

So we need engine logs to know more.

If none were generated, it might have failed too early.

Please check system logs - /var/log/messages, journalctl, etc. Thanks.

Just to be sure : are you speaking about the log files on the bare-metal
server, or the virtual hosts (engine)?

I referred to the engine vm. In principle both might be

If this is the engine, I already provided the only file I got (and I also
double-checked its /var/log/message, with no interesting info).

Perhaps journalctl output?

Engine is centos 6, so no systemd at this time...

OK. Can you try starting the service manually and see if you get anything
in any log? You can try getting more debug info using e.g.:



I read this BZ, and I also tried to launch a run using basic_suite_4.0
The results were quite different, as I see no more memory issues.

Actually, it looks like all the 3 VMs are deployed OK (engine, host0 and host1).
Then the tests about the engine are OK.
Then I only have an error in post-001_initialize_engine.py
But I can not find any detail :

@ Collect artifacts:
  # [Thread-1] lago_basic_suite_4_0_host0:
  # [Thread-2] lago_basic_suite_4_0_host1:
  # [Thread-3] lago_basic_suite_4_0_engine:
No handlers could be found for logger "paramiko.transport"
  # [Thread-3] lago_basic_suite_4_0_engine: Success (in 0:01:07)
  # [Thread-1] lago_basic_suite_4_0_host0: ERROR (in 0:02:18)
  # [Thread-2] lago_basic_suite_4_0_host1: ERROR (in 0:02:18)

(nothing more).

The script is not stopping there, and keeps going until 002_bootstrap.py :

  # add_dc:
  # add_dc: Success (in 0:00:03)
  # add_dc_quota:
  # add_dc_quota: Success (in 0:00:02)
  # add_cluster:
  # add_cluster: Success (in 0:00:01)
  # add_hosts:
    * Collect artifacts:
    * Collect artifacts: ERROR (in 0:01:55)
  # add_hosts: ERROR (in 0:17:08)
  # Results located at /data/lago/ovirt-system-tests/deployment-basic_suite_4.0/default/nosetests-002_bootstrap.py.xml
@ Run test: 002_bootstrap.py: ERROR (in 0:17:16)
Error occured, aborting
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ovirtlago/cmd.py", line 258, in do_run
  File "/usr/lib/python2.7/site-packages/lago/plugins/cli.py", line 180, in do_run
  File "/usr/lib/python2.7/site-packages/lago/utils.py", line 488, in wrapper
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/lago/utils.py", line 499, in wrapper
    return func(*args, prefix=prefix, **kwargs)
  File "/usr/lib/python2.7/site-packages/ovirtlago/cmd.py", line 102, in do_ovirt_runtest
    raise RuntimeError('Some tests failed')
RuntimeError: Some tests failed

I'm still having a look at the log files to see what is the issue.

Apart that, by connecting into the engine VM, I saw that the engine process was running, so I tried to access the web GUI, by running an SSH connection to the bare-metal host :
ssh -L 8443: root@serv-hv-dev01.sdis.isere.fr

(BTW, the readthedoc is showing 200.2 but this is irrelevant for basic_test_4.0, where the engine ip is 200.4)

Accessing https://localhost:8443/ is working, but when trying to access the login screen, I'm left with :
"The client is not authorized to request an authorization. It's required to access the system using FQDN."

Add to your /etc/hosts engine

And connect to https://engine

here's my /etc/hosts, as indeed there may be multiple IPs or subnets for engine: 
[ykaul@ykaul ovirt-system-tests]$ cat /etc/hosts localhost.localdomain localhost
::1 localhost6.localdomain6 localhost6
# engine
# engine engine
# hosted-engine hosted-engine.lago.local


Dear Redhat employees and al., I sincerely respect your great patience because I'm witnessing the huge complexity of this project, as I'm trying to find my way out this mess^W wonderful project ;)

Anyway, I'm feeling I made one step further, so this is encouraging (I have modest expectations and a few is making my day).

So about this last issue, please don't answer me that every Lago user is using its own laptop with a graphical layer and running a direct browser access to the web GUI?

lago-devel mailing list