Hello Strahil,

I just set cluster.min-free-disk to 1%:
# gluster volume info data

Volume Name: data
Type: Distribute
Volume ID: 2d3ea533-aca3-41c4-8cb6-239fe4f82bc3
Status: Started
Snapshot Count: 0
Number of Bricks: 1
Transport-type: tcp
Brick1: node2.domain.com:/home/brick1
Options Reconfigured:
cluster.min-free-disk: 1%
cluster.data-self-heal-algorithm: full
performance.low-prio-threads: 32
features.shard-block-size: 512MB
features.shard: on
storage.owner-gid: 36
storage.owner-uid: 36
transport.address-family: inet
nfs.disable: on

But still get the same error: Error while executing action: Cannot move Virtual Disk. Low disk space on Storage Domain
I restarted the glusterfs volume.
But I can not do anything with the VM disk.

I know that filling the bricks is very bad, we lost access to the VM. I think there should be a mechanism to prevent stopping the VM.
we should continue to have access to the VM to free some space.

If you have a VM with a Thin Provision disk, if the VM fills the entire disk, we got the same problem.

Any idea?



De: "Strahil Nikolov" <hunter86_bg@yahoo.com>
Para: "users" <users@ovirt.org>, suporte@logicworks.pt
Enviadas: Segunda-feira, 21 De Setembro de 2020 21:28:10
Assunto: Re: [ovirt-users] Gluster Domain Storage full

Usually gluster has a 10% reserver defined in 'cluster.min-free-disk' volume option.
You can power off the VM , then set cluster.min-free-disk
to 1% and immediately move any of the VM's disks to another storage domain.

Keep in mind that filling your bricks is bad and if you eat that reserve , the only option would be to try to export the VM as OVA and then wipe from current storage and import in a bigger storage domain.

Of course it would be more sensible to just expand the gluster volume (either scale-up the bricks -> add more disks, or scale-out -> adding more servers with disks on them), but I guess that is not an option - right ?

Best Regards,
Strahil Nikolov

В понеделник, 21 септември 2020 г., 15:58:01 Гринуич+3, suporte@logicworks.pt <suporte@logicworks.pt> написа:


I'm running oVirt Version
I have a small GlusterFS Domain storage brick on a dedicated filesystem serving only one VM.
The VM filled all the Domain storage.
The Linux filesystem has 4.1G available and 100% used, the mounted brick has 0GB available and 100% used

I can not do anything with this disk, for example, if I try to move it to another Gluster Domain Storage get the message:

Error while executing action: Cannot move Virtual Disk. Low disk space on Storage Domain

Any idea?


Jose Ferradeira
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-leave@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: https://www.ovirt.org/community/about/community-guidelines/
List Archives: https://lists.ovirt.org/archives/list/users@ovirt.org/message/WFN2VOQZPPVCGXAIFEYVIDEVJEUCSWY7/