The real image is defined within the XML stanza in the vdsm.log when the VM was last started .
So if you remember when the last time the HostedEngine was rebooted, you can check the vdsm.log on the host.

From there - check the cluster for the file.

If it's missing deploy the HostedEngine again (on the previous HostedEngine cluster volume or on a completely new).
Then try to import all Storages and then you will be able to import existing VMs.

Best Regards,
Strahil Nikolov

On Apr 11, 2019 20:12, Sakhi Hadebe <> wrote:
What happened is the engine's root filesystem had filled up. My colleague tried to resize the root lvm. The engine then did not come back. In trying to resolve that he cleaned up the engine and tried to re-install it, no luck in doing that.

That brought down all the VMs. All VMs are down. we trying to move them into one of the standalone kvm host. We have been trying to locate the VM disk images, with no luck.

According to the of the VM xml configuration file.the disk file is  /rhev/data-center/mnt/glusterSD/glustermount.goku:_vmstore/9f8ef3f6-53f2-4b02-8a6b-e171b000b420/images/b2b872cd-b468-4f14-ae20-555ed823e84b/76ed4113-51b6-44fd-a3cd-3bd64bf93685

Unfortunately we can find it and the solution on teh forum states that we can only find in the associated logical volume, but i think only when teh vm is running.

The disk images we have been trying to boot up from are the one's we got from the gluster bricks, but the are far small that real images and can't boot

On Thu, Apr 11, 2019 at 6:13 PM Simone Tiraboschi <> wrote:

On Thu, Apr 11, 2019 at 9:46 AM Sakhi Hadebe <> wrote:

We have a situation where the HostedEngine was cleaned up and the VMs are no longer running. Looking at the logs we can see the drive files as:

Do you have any guess on what really happened?
Are you sure that the disks really disappeared?

Please notice that the symlinks under rhev/data-center/mnt/glusterSD/glustermount... are created on the fly only when needed.

Are you sure that your host is correctly connecting the gluster storage domain?

2019-03-26T07:42:46.915838Z qemu-kvm: -drive file=/rhev/data-center/mnt/glusterSD/glustermount.goku:_vmstore/9f8ef3f6-53f2-4b02-8a6b-e171b000b420/images/b2b872cd-b468-4f14-ae20-555ed823e84b/76ed4113-51b6-44fd-a3cd-3bd64bf93685,format=qcow2,if=none,id=drive-ua-b2b872cd-b468-4f14-ae20-555ed823e84b,serial=b2b872cd-b468-4f14-ae20-555ed823e84b,werror=stop,rerror=stop,cache=none,aio=native: 'serial' is deprecated, please use the corresponding option of '-device' instead

I assume this is the disk was writing to before it went down