Here's what I found in engine.log

On Thu, Apr 5, 2012 at 11:32 AM, Itamar Heim <> wrote:
On 04/05/2012 01:16 PM, Alex Drahon wrote:
Thanks for your help.

I tried the import with a minimal OVF file as described by Shahar and it
worked, but failed on activate.

This time I have a constraint violation on pk_vm_static, which means
that ovirt-engine doesn't create a vm_guid if it isn't here. I guess
it's the same for a lot of parameters.

that's sounds like a new bug.
please send stack trace (which will also help telling where to look).

To move forward, I'm going to create "shadow" VMs on ovirt-engine,
export them and import my "real" libvirt/KVM VMs with the exported OVF
files. Makes sense?

Where should I look in the source tree if I want to (try to) actually
help with the restore code for imported VMs?


On Thu, Apr 5, 2012 at 5:59 AM, Shahar Havivi <
<>> wrote:

   On 05.04.12 07:35, Itamar Heim wrote:
    > On 04/04/2012 01:13 PM, Alex Drahon wrote:
    > >Hello all,
    > >
    > >I'm trying to import VMs from a Centos5/KVM host to ovirt using
    > >virt-v2v. I used this command:
    > >virt-v2v -ic qemu+ssh://root@virthost1.mydomain.local/system -o
   rhev -os
    > >virthost3.mydomain.local:/exports/exp --network ovirtmgmt
    > >test.mydomain.local
    > >
    > >It works, but the resulting OVF file cannot be read by ovirt-engine
    > >("Failed to read VM '[Unknown name]' OVF, it may be corrupted").
    > >
    > >I had to edit the OVF file, removing the NIC Item worked, but
    > >the imported VM fails. Looking at logs, I found a PostgreSQL
    > >violation on an insert (sorry it's in French)
    > >"Caused by: org.postgresql.util.PSQLException: ERREUR: la valeur
   d une
    > >clé dupliquée rompt la contrainte unique « pk_vm_device »
    > >   Where: instruction SQL « INSERT INTO vm_device( device_id,
   vm_id ,
    > >device , type, address , boot_order , spec_params, is_managed,
    > >is_plugged, is_readonly) VALUES(  $1  ,  $2  ,  $3  ,  $4  ,  $5
     ,  $6
    > >,  $7 ,  $8 ,  $9 ,  $10 ) »"
    > >
    > >Looks like there's a primary key violation (duplicate) on insert.
    > cc-ing mbooth from v2v to have a look from ovf generation, but there
    > could be some bug in engine as well as the vm_device code was added
    > recently.
    > >
    > >I have two questions:
    > >  - what's the minimal OVF file that can successfully import a VM?
   you will need the header: the <Reference> tag the <Content> tag with the
   <Section> items: <System> and <item>s cpu and memory, all other
   devices can be
    > shahar?
    > >  - are 'default devices' created if they are not in the OVF file?
    > >(would explain PK violations)
    > eli?
    > >
    > >oVirt is very impressive and stable, deploying was a breeze, but
    > >difficult to understand why it is so hard to move VMs from a
    > >host (which is basically the same architecture). Am I missing