I meant update the password in grafana's Web UI.

You can find it by going to the Monitoring Portal -> Gear Icon on the left hand side -> Data Sources -> oVirt DWH -> PostgreSQL Connection.
There you can change the parameters used by grafana to connect to the engine database. (You'll have to hit the reset button to allow updating the password.)

*Note: The gear icon will only show up if the logged in user has administrative permissions within grafana. Only the built in oVirt admin user (admin@internal-authz) has this permission by default. But you can delegate those permissions within grafana.

- Patrick Hibbs

On Mon, 2022-06-13 at 08:34 +0100, Maton, Brett wrote:
  I've not restored from a backup or changed the grafana databse user password, no idea why this has 'just' stopped working (or when as I don't look at grafana that often).

I tried updating the grafana db user password, but still no joy...

I grabbed the password from /etc/ovirt-engine-dwh/ovirt-engine-dwhd.conf.d/10-setup-grafana-database.conf - GRAFANA_DB_PASSWD

and then updated the database user:

su - postgres
psql -d ovirt_engine_history
ALTER ROLE ovirt_engine_history_grafana WITH PASSWORD 'password from config file';

On Fri, 10 Jun 2022 at 17:32, Patrick Hibbs <hibbsncc1701@gmail.com> wrote:
That can happen if the builtin password for the engine database's grafana user changes, or if you manually restore the grafana database from a backup.

You could try resetting the password by copying it back into the data source config in grafana's UI. (You'll need admin privlieges for grafana to do so.)
The password for the engine database's grafana user should be located in /etc/ovirt-engine-dwh/ovirt-engine-dwhd.conf.d/10-setup-grafana-database.conf on the engine host.

-Patrick Hibbs

On Thu, 2022-06-09 at 09:32 +0100, Maton, Brett wrote:

I tried to connect to grafana via the monitoring portal link from the dash and all panels are failing to display any data with varying error messages, but all include 'Origin Not Allowed'

I navigated to Data Sources and ran a test on the PostgreSQL connection (localhost) which threw the same Origin Not Allowed error message.

Any suggestions?
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-leave@ovirt.org

Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-leave@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: https://www.ovirt.org/community/about/community-guidelines/
List Archives: https://lists.ovirt.org/archives/list/users@ovirt.org/message/KDPMJGJ22DJH4FZW2Y2UVDBZD3KBJN37/