[ovirt-devel] upgrade ovirt-node 2.6 error

Fabian Deutsch fdeutsch at redhat.com
Mon Dec 8 07:07:33 UTC 2014

----- Original Message -----
> hi all:
>         When I install ovirt-node, after two days I found this version by the
>         question and I have some local storage of data on the inside, I want
>         to upgrade ovirt-node, but I found the following error.
>      all Hacker, please help me out a good idea...
>  [Errno 30] Read-only file system:
>  'liveos/grub'
>  Traceback(most recent call lash):
>  File
>   "/usr/libexex/ovirt-config-installer". line 1087  in start
>      self.upgrade_node()
>   File
>   "/usr/libexex/ovirt-config-installer". line 886, in upgrade_node()
>      boot_setup = install.ovirt_boot_setup()
>  File
>  "/usr/lib/python2.6/site-paceages/ovirtnode/install.py", line 391, in
>  ovirt_boot_setup
>  File
>   "/usr/lib64/python2.6/os.py", line 157 in makedirs
>  OSError:[Error 30] Read-only file system:
>  '/liveos/grub'
>   I at least tried mounting the LABEL=Root partition to /liveos, I was told
>   it is busy, but I couldn't find out why it was busy, because I ran into
>   the squashfs errors, which appeared indmesg as soon as I used tools like
>   findmnt etc.


we've actually also seen this a couple of times. The problem with this bug is,
that it's not easy to reproduce, and probably related to a udev/device-mapper
race condition.

Is this bug happening allways for you, or just sometimes?

- fabian

More information about the Devel mailing list