Change in ovirt-engine[master]: core: minor refactoring in stop vm related commands

ofrenkel at redhat.com ofrenkel at redhat.com
Thu Aug 1 16:06:21 UTC 2013


Omer Frenkel has submitted this change and it was merged.

Change subject: core: minor refactoring in stop vm related commands
......................................................................


core: minor refactoring in stop vm related commands

1. replace canDoAction methods in ShutdownVmCommand and StopVmCommand
that were not doing anything besides setting the VAR__ACTION and
VAR__TYPE with setActionMessageParameters methods

2. rename StopVmCommandBase#privateSuspendedVm to suspendedVm

3. reorganize StopVmCommandBase#canDoAction method to be more readable

4. extract the checks that determine whether the VM can be shutdown from
the Perform method to an external method.

Change-Id: I8af061d2805a85dadd84efa1cd2a0a290dbddbd1
Signed-off-by: Arik Hadas <ahadas at redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ShutdownVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/StopVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/StopVmCommandBase.java
3 files changed, 42 insertions(+), 59 deletions(-)

Approvals:
  Omer Frenkel: Verified; Looks good to me, approved


-- 
To view, visit http://gerrit.ovirt.org/17472
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I8af061d2805a85dadd84efa1cd2a0a290dbddbd1
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas at redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas at redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel at redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server



More information about the Engine-commits mailing list