[Engine-devel] ovirt-engine repo up in gerrit.ovirt.org!

Livnat Peer lpeer at redhat.com
Sun Oct 30 05:09:15 UTC 2011

On 10/30/2011 01:36 AM, Dennis Jacobfeuerborn wrote:
> On 10/29/2011 10:39 PM, Livnat Peer wrote:
>> On 10/29/2011 10:08 PM, Dennis Jacobfeuerborn wrote:
>>> On 10/29/2011 07:15 PM, Livnat Peer wrote:
>>>> On 10/29/2011 05:48 PM, Dennis Jacobfeuerborn wrote:
>>>>> On 10/28/2011 02:09 AM, Livnat Peer wrote:
>>>>>> On 10/27/2011 11:51 PM, Itamar Heim wrote:
>>>>>>> Here we go...
>>>>>>> - gerrit is up.
>>>>>>> - ovirt-engine git repo is there.
>>>>>>> - will upload the other repositories soon.
>>>>>>> below you can find the steps on how to get the code (yes, coming to
>>>>>>> you
>>>>>>> in wiki soon).
>>>>>>> a link to the wiki on how to build oVirt will be sent soon by
>>>>>>> Livnat.
>>>>>>> It's exciting to see everyone coming together to build a community,
>>>>>>> and
>>>>>>> I'm looking forward to working together on oVirt.
>>>>>>> Welcome everyone,
>>>>>>>       Itamar
>>>>>> Welcome indeed,
>>>>>> A link to a wiki with info for setting development environment -
>>>>>> http://www.ovirt.org/wiki/Building_Ovirt_Engine
>>>>> I tried building with these instructions but get "9 required artifacts
>>>>> are missing." Also I get a *lot* of "unable to fine resource"
>>>>> info/warning messages. I've attached the output of the maven run.
>>>>> Regards,
>>>>>     Dennis
>>>> Hi Dennis,
>>>> Maven tries to download dependencies that are required by your project,
>>>> in this case oVirt.
>>>> For each dependency maven iterates over all the repositories defined in
>>>> the pom.xml and stops when it finds the required dependency, if it does
>>>> not find the Jar in a repository it issues info message and looks in
>>>> the
>>>> next repsitory. The info message looks like "[INFO] Unable to find
>>>> resource  XXX in repository YYY" and does not indicate on a problem.
>>>> For the errors you get -
>>>> I looked into the first missing jar commons-httpclient-2.0.2, it can be
>>>> found in -
>>>> http://repository.jboss.org/maven2/apache-httpclient/commons-httpclient/2.0.2/
>>>> but it looks like you get -
>>>> Authorization failed: Access denied to:
>>>> http://repository.jboss.org/maven2/apache-httpclient/commons-httpclient/2.0.2/commons-httpclient-2.0.2.jar
>>>> Any idea why you got authorization error? I can access it locally.
>>>> Can you try again? maybe a temporary problem.
>>> When I access that URL in a browser I still get a 403 Forbidden
>>> response.
>>> I can access http://repository.jboss.org/ but not
>>> http://repository.jboss.org/maven2/.
>>> In fact the maven2 directory doesn't show up in the directory listing
>>> when requesting http://repository.jboss.org/ which could potentially be
>>> an SELinux issue on the server. Has this directory perhaps been manually
>>> copied to the server without the correct SELinux labels?
>>> Regards,
>>>    Dennis
>> Can you access this -
>> https://repository.jboss.org/nexus/content/repositories/central/commons-httpclient/commons-httpclient/2.0.2/
> Yes, this URL works fine.
> Regards,
>   Dennis

Hi Dennis,
It looks like repo - http://repository.jboss.org/maven2/ is deprecated
and can only be accessed within RedHat Network, probably for JBoss

I have attached a temporary patch with another URL for this repo.
The new URL is accessible from outside of RedHat but we should replace
it with the new repositories in Nexus.

As i have to catch a flight in a few hours i have no time to test it so
i hope it will do the work.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: 0001-Changing-the-jboss-repo-URL-as-it-is-deprecated-and-.patch
URL: <http://lists.ovirt.org/pipermail/engine-devel/attachments/20111030/6e174824/attachment.ksh>

More information about the Engine-devel mailing list