[node-patches] Change in ovirt-node[master]: disable continue button if Free space was negative

fabiand at redhat.com fabiand at redhat.com
Wed Jul 23 20:36:13 UTC 2014


Fabian Deutsch has posted comments on this change.

Change subject: disable continue button if Free space was negative
......................................................................


Patch Set 5: Code-Review-1

(1 comment)

See the inline ocmment

http://gerrit.ovirt.org/#/c/27955/5/src/ovirt/node/installer/core/storage_vol_page.py
File src/ovirt/node/installer/core/storage_vol_page.py:

Line 109:                                                    _("Continue"),
Line 110:                                                    enabled=False)])
Line 111:             else:
Line 112:                 page.buttons.extend([ui.SaveButton("button.next",
Line 113:                                                    _("Continue"))])
please remove some duplicated code, and rather do it along the lines of:

    can_continue = self.model() and self.__calculate_free_space() >= 0
    page.buttons.extend([ui.SaveButton("button.next",
			_("Continue"),
			enabled=can_continue)])
Line 114: 
Line 115:         return page
Line 116: 
Line 117:     def on_change(self, changes):


-- 
To view, visit http://gerrit.ovirt.org/27955
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I7f8dcfa7b980b5b272fc5845b3f228af7fe4f21e
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-node
Gerrit-Branch: master
Gerrit-Owner: hadong <hadong0720 at gmail.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland at redhat.com>
Gerrit-Reviewer: Fabian Deutsch <fabiand at redhat.com>
Gerrit-Reviewer: Ryan Barry <rbarry at redhat.com>
Gerrit-Reviewer: automation at ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes



More information about the node-patches mailing list