Allon Mureinik has submitted this change and it was merged.
Change subject: core: Inline MoveOrCopyTemplateCommand#isImagesAlreadyOnTarget
......................................................................
core: Inline MoveOrCopyTemplateCommand#isImagesAlreadyOnTarget
MoveOrCopyTemplateCommand#isImagesAlreadyOnTarget does nothing but
delegate to a method of the same name in the parameter class. It does
nothing to improve the code's readability, and in fact hinders it, as
the reader may suspect this method actually performs some check.
This patch removes the aforementioned method in order to reduce the
code's complexity and improve its readability.
Change-Id: Ic580c5c28f85ca91ccd2f7d47b9b57b5156e058f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateCommand.java
M
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateFromConfigurationCommand.java
M
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/ExportVmTemplateCommand.java
M
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
4 files changed, 13 insertions(+), 15 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit
https://gerrit.ovirt.org/55104
To unsubscribe, visit
https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic580c5c28f85ca91ccd2f7d47b9b57b5156e058f
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>