Arik Hadas has submitted this change and it was merged.
Change subject: core: refactor CommonVmPoolWithVmsCommand
......................................................................
core: refactor CommonVmPoolWithVmsCommand
- Extract the code that add VMs to the pool to separate method
- Rename addVmsSucceded to addVmsSucceeded
- Remove the variable that reflected whether at least one VM creation
failed as we can know that according to the addVmsSucceeded field
- Rename getAddVmsSucceeded to isAddVmsSucceeded
Change-Id: If9cc7214071e0b92aaa65480f0c5c801538d2c50
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVmPoolWithVmsCommand.java
M
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CommonVmPoolWithVmsCommand.java
M
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/UpdateVmPoolWithVmsCommand.java
3 files changed, 16 insertions(+), 14 deletions(-)
Approvals:
Omer Frenkel: Looks good to me, approved
Arik Hadas: Verified
--
To view, visit
http://gerrit.ovirt.org/28325
To unsubscribe, visit
http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If9cc7214071e0b92aaa65480f0c5c801538d2c50
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server