
From Allon Mureinik <amureini@redhat.com>:
Allon Mureinik has submitted this change and it was merged. Change subject: core: GlusterServiceSyncJob maps ...................................................................... core: GlusterServiceSyncJob maps Anonymously implementing a HashMap just to place values in it is a bad practice which both "spams" up the classloader with useless anonymous classes and produces code that's hard to read. This patch removes the instances of that practice and replaces them with the better performing Collections.singletonMap where possible or with an old fashioned HashMap with a series of put calls where it isn't. Change-Id: Iae6a537076ab389888debe47fc7ed5313fc712b8 Signed-off-by: Allon Mureinik <amureini@redhat.com> --- M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterServiceSyncJob.java 1 file changed, 16 insertions(+), 25 deletions(-) Approvals: Tal Nisan: Looks good to me, approved Allon Mureinik: Verified; Passed CI tests -- To view, visit https://gerrit.ovirt.org/73090 To unsubscribe, visit https://gerrit.ovirt.org/settings Gerrit-MessageType: merged Gerrit-Change-Id: Iae6a537076ab389888debe47fc7ed5313fc712b8 Gerrit-PatchSet: 7 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Allon Mureinik <amureini@redhat.com> Gerrit-Reviewer: Ala Hino <ahino@redhat.com> Gerrit-Reviewer: Allon Mureinik <amureini@redhat.com> Gerrit-Reviewer: Denis Chaplygin <dchaplyg@redhat.com> Gerrit-Reviewer: Jenkins CI Gerrit-Reviewer: Sahina Bose <sabose@redhat.com> Gerrit-Reviewer: Tal Nisan <tnisan@redhat.com> Gerrit-Reviewer: gerrit-hooks <automation@ovirt.org>