From Arik Hadas <ahadas(a)redhat.com>:
Arik Hadas has submitted this change and it was merged.
Change subject: core: cleanup in run vm flow
......................................................................
core: cleanup in run vm flow
1. remove redundant setting of initialization type to None, this is its
default value
2. remove duplicate check for: getVm().getVmInit() != null
3. combine two consecutive if-statements into one
4. inline local variable
5. inline RunVmOnceCommand#earlyUpdateVmDynamicRunOnce
6. rename RunVmCommand#createVmStatelessImages to 'createStatelessSnapshot'
7. rename RunVmCommand#removeVmStatelessImages to 'removeStatelessSnapshot'
Change-Id: Iec88b26772e1ef3f1b9e0b1174c3c2f9c91e679f
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommand.java
M
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmOnceCommand.java
2 files changed, 74 insertions(+), 74 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Jenkins CI: Passed CI tests
Arik Hadas: Verified
--
To view, visit
https://gerrit.ovirt.org/72646
To unsubscribe, visit
https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iec88b26772e1ef3f1b9e0b1174c3c2f9c91e679f
Gerrit-PatchSet: 10
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>