
Arik Hadas has submitted this change and it was merged. Change subject: core: cleanup in vms monitoring ...................................................................... core: cleanup in vms monitoring 1. Rename timeToUpdateStatistics to updateStatistics 2. Use early return when the monitored VMs are empty 3. Use dbFacade and resourceManager members directly 4. Use early return in tryLockVmForUpdate 5. Simplify refreshVmStats with simpler forEach syntax 6. Improve indentation in saveVmGuestAgentNetworkDevices Change-Id: Ic1843227ca60546424a4df30c4655a8967e2efb2 Signed-off-by: Arik Hadas <ahadas@redhat.com> --- M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VmsMonitoring.java 1 file changed, 66 insertions(+), 74 deletions(-) Approvals: Shahar Havivi: Looks good to me, approved Jenkins CI: Passed CI tests Arik Hadas: Verified -- To view, visit https://gerrit.ovirt.org/52818 To unsubscribe, visit https://gerrit.ovirt.org/settings Gerrit-MessageType: merged Gerrit-Change-Id: Ic1843227ca60546424a4df30c4655a8967e2efb2 Gerrit-PatchSet: 14 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Arik Hadas <ahadas@redhat.com> Gerrit-Reviewer: Arik Hadas <ahadas@redhat.com> Gerrit-Reviewer: Jenkins CI Gerrit-Reviewer: Shahar Havivi <shavivi@redhat.com> Gerrit-Reviewer: gerrit-hooks <automation@ovirt.org>