Omer Frenkel has submitted this change and it was merged.
Change subject: core: ObjectIdentityChecker cleanup
......................................................................
core: ObjectIdentityChecker cleanup
- Change the type of mPermitted from List to Set and of mDictionary from
Map<Enum<?>, List<String>> to Map<Enum<?>,
Set<String>> which are
more appropriate because each value in those lists should appear at
most once (instead of verifying when adding something, that it's not
in the list already)
- Rename ObjectIdentityChecker's members such that they'll conform the
standard naming convention in java (instead of starting with 'm')
- Replace statements of the following structure:
<type> <field_name> = null;
if ((<field_name = <value> ==/!= null ...)
with statements of the following strcture which is more readable:
<type> <field_name> = <value>;
if (<field_name> ==/!= null ...)
Change-Id: I7845cb876f0edcfd1a9c58a06ff443175295c554
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M
backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ObjectIdentityChecker.java
1 file changed, 31 insertions(+), 37 deletions(-)
Approvals:
Omer Frenkel: Looks good to me, approved
Arik Hadas: Verified
Yair Zaslavsky: Looks good to me, but someone else must approve
--
To view, visit
http://gerrit.ovirt.org/10737
To unsubscribe, visit
http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7845cb876f0edcfd1a9c58a06ff443175295c554
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>