Change in ovirt-engine[master]: engine: Simplify canDoAction

Mike Kolesnik has submitted this change and it was merged. Change subject: engine: Simplify canDoAction ...................................................................... engine: Simplify canDoAction Simplify canDoAction to fast-fail so that the code becomes easier to read (less nested conditionals). Change-Id: I7fa092ce8f568b11ae14ac1c943107a10cffa068 Bug-Url: https://bugzilla.redhat.com/907155 Signed-off-by: Mike Kolesnik <mkolesni@redhat.com> --- M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/vm/ActivateDeactivateVmNicCommand.java 1 file changed, 17 insertions(+), 21 deletions(-) Approvals: Mike Kolesnik: Verified; Looks good to me, approved -- To view, visit http://gerrit.ovirt.org/11696 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: merged Gerrit-Change-Id: I7fa092ce8f568b11ae14ac1c943107a10cffa068 Gerrit-PatchSet: 3 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Mike Kolesnik <mkolesni@redhat.com> Gerrit-Reviewer: Mike Kolesnik <mkolesni@redhat.com> Gerrit-Reviewer: Moti Asayag <masayag@redhat.com>
participants (1)
-
mkolesni@redhat.com