Change in ovirt-engine[master]: core: GlusterHookSyncJob map

From Allon Mureinik <amureini@redhat.com>:
Allon Mureinik has submitted this change and it was merged. Change subject: core: GlusterHookSyncJob map ...................................................................... core: GlusterHookSyncJob map Anonymously implementing a HashMap just to place values in it is a bad practice which both "spams" up the classloader with useless anonymous classes and produces code that's hard to read. This patch removes the instance of that practice and replaces it with the better performing Collections.singletonMap. Change-Id: If14b680da7ce1cabb212e823b941efd96588856a Signed-off-by: Allon Mureinik <amureini@redhat.com> --- M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterHookSyncJob.java 1 file changed, 2 insertions(+), 2 deletions(-) Approvals: Tal Nisan: Looks good to me, approved Allon Mureinik: Verified; Passed CI tests -- To view, visit https://gerrit.ovirt.org/73089 To unsubscribe, visit https://gerrit.ovirt.org/settings Gerrit-MessageType: merged Gerrit-Change-Id: If14b680da7ce1cabb212e823b941efd96588856a Gerrit-PatchSet: 7 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Allon Mureinik <amureini@redhat.com> Gerrit-Reviewer: Ala Hino <ahino@redhat.com> Gerrit-Reviewer: Allon Mureinik <amureini@redhat.com> Gerrit-Reviewer: Denis Chaplygin <dchaplyg@redhat.com> Gerrit-Reviewer: Jenkins CI Gerrit-Reviewer: Sahina Bose <sabose@redhat.com> Gerrit-Reviewer: Tal Nisan <tnisan@redhat.com> Gerrit-Reviewer: gerrit-hooks <automation@ovirt.org>
participants (1)
-
Code Review