Change in ovirt-engine[master]: core: differentiate command test utils

Allon Mureinik has submitted this change and it was merged. Change subject: core: differentiate command test utils ...................................................................... core: differentiate command test utils CommandAssertUtils and CanDoActionTestUtils contained duplicated logic as both were used to test canDoAction() methods. This patch moves all the (remaining) canDoAction() tests to use CanDoActionTestUtils and removes the redundant methods from CommandAssertUtils, leaving it as a utility to test execute() methods only. Change-Id: Iadce121f4cf3d04e4eab8200c679230e4b4adf8b Signed-off-by: Allon Mureinik <amureini@redhat.com> --- M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/CommandAssertUtils.java M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/ForceSelectSPMCommandTest.java 2 files changed, 19 insertions(+), 45 deletions(-) Approvals: Allon Mureinik: Verified; Looks good to me, approved -- To view, visit http://gerrit.ovirt.org/20685 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: merged Gerrit-Change-Id: Iadce121f4cf3d04e4eab8200c679230e4b4adf8b Gerrit-PatchSet: 4 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Allon Mureinik <amureini@redhat.com> Gerrit-Reviewer: Alissa Bonas <abonas@redhat.com> Gerrit-Reviewer: Allon Mureinik <amureini@redhat.com> Gerrit-Reviewer: Daniel Erez <derez@redhat.com> Gerrit-Reviewer: Tal Nisan <tnisan@redhat.com> Gerrit-Reviewer: Vered Volansky <vvolansk@redhat.com> Gerrit-Reviewer: oVirt Jenkins CI Server
participants (1)
-
amureini@redhat.com