[ovirt-devel] VM start fails due to missing disk

Viktor Mihajlovski mihajlov at linux.vnet.ibm.com
Wed Nov 8 17:07:44 UTC 2017

On 08.11.2017 16:13, Viktor Mihajlovski wrote:
> Hi,
> I ran into a problem after building ovirt-engine from current master to
> verify my last outstanding patch: but now I can't start my VM anymore,
> because the <disk> element is omitted from the final libvirt XML created
> by vdsm.
> The xml argument sent by the engine for the VM.create call contains a
> valid disk definition, but it disappears from the final libvirt XML.
> The preceding prepareImage call returns a seemingly valid path info...
> I am currently at loss and would appreciate any hints.
nevermind, I needed to upgrade from vdsm 4.20.3 to 4.20.6, now it works ...


Mit freundlichen Grüßen/Kind Regards
   Viktor Mihajlovski

IBM Deutschland Research & Development GmbH
Vorsitzender des Aufsichtsrats: Martina Köderitz
Geschäftsführung: Dirk Wittkopp
Sitz der Gesellschaft: Böblingen
Registergericht: Amtsgericht Stuttgart, HRB 243294

More information about the Devel mailing list