Change in ovirt-engine[master]: core: organize AddVmCommand#canDoAction
ofrenkel at redhat.com
ofrenkel at redhat.com
Thu Jun 27 07:08:51 UTC 2013
Omer Frenkel has submitted this change and it was merged.
Change subject: core: organize AddVmCommand#canDoAction
......................................................................
core: organize AddVmCommand#canDoAction
Refactoring AddVmCommand#canDoAction method, such that it won't use the
local variable returnValue to store the result - instead, we return
false as soon as we detect a required condition that is false. those
changes make the code more readable and compact.
Change-Id: Ie4eda8868b50fd4a99462c0a649bba58e52f9bc0
Signed-off-by: Arik Hadas <ahadas at redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVmCommand.java
1 file changed, 42 insertions(+), 38 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/15841
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie4eda8868b50fd4a99462c0a649bba58e52f9bc0
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas at redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas at redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel at redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan at redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
More information about the Engine-commits
mailing list