Change in ovirt-engine[master]: core: Use explicit collection expressions

amureini at redhat.com amureini at redhat.com
Wed Jul 15 09:47:52 UTC 2015


Allon Mureinik has submitted this change and it was merged.

Change subject: core: Use explicit collection expressions
......................................................................


core: Use explicit collection expressions

Removed the confusing usage of ArrayLists and instead used
Collections.singletonList(Object) and Collections.emptyList().

This both makes the test more explicit and easier to read and prevents
mistakes in the future where someone may add something to these
collections by mistake.

Change-Id: I295d834307456a786e45880462bc6e3ce7974be7
Signed-off-by: Allon Mureinik <amureini at redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/validator/storage/StorageDomainToPoolRelationValidatorTest.java
1 file changed, 3 insertions(+), 9 deletions(-)

Approvals:
  Tal Nisan: Looks good to me, approved
  Jenkins CI: Passed CI tests
  Amit Aviram: Looks good to me, but someone else must approve
  Allon Mureinik: Verified



-- 
To view, visit https://gerrit.ovirt.org/43607
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I295d834307456a786e45880462bc6e3ce7974be7
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini at redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini at redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram at redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan at redhat.com>
Gerrit-Reviewer: automation at ovirt.org



More information about the Engine-commits mailing list