Change in ovirt-engine[master]: core: GlusterSyncJob maps

Code Review gerrit at ovirt.org
Wed Mar 1 10:07:24 UTC 2017


>From Allon Mureinik <amureini at redhat.com>:

Allon Mureinik has submitted this change and it was merged.

Change subject: core: GlusterSyncJob maps
......................................................................


core: GlusterSyncJob maps

Anonymously implementing a HashMap just to place values in it is a bad
practice which both "spams" up the classloader with useless anonymous
classes and produces code that's hard to read.

This patch removes the instances of that practice and replaces them with
the better performing Collections.singletonMap where possible or with
an old fashioned HashMap with a series of put calls where it isn't.

Change-Id: Iaf12e31554f2891458c1f39d729c177216502eb2
Signed-off-by: Allon Mureinik <amureini at redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterSyncJob.java
1 file changed, 22 insertions(+), 50 deletions(-)

Approvals:
  Denis Chaplygin: Looks good to me, but someone else must approve
  Tal Nisan: Looks good to me, approved
  Allon Mureinik: Verified; Passed CI tests



-- 
To view, visit https://gerrit.ovirt.org/72570
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: Iaf12e31554f2891458c1f39d729c177216502eb2
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini at redhat.com>
Gerrit-Reviewer: Ala Hino <ahino at redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini at redhat.com>
Gerrit-Reviewer: Denis Chaplygin <dchaplyg at redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose at redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan at redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation at ovirt.org>


More information about the Engine-commits mailing list