On Mon, Sep 30, 2013 at 04:11:56AM -0400, Eyal Edri wrote:
as part of adding more verification jobs on vdsm, infra recently added a new job  that
currently that job is working only on f19 and fails on f18 and centos64:
Are there any plans to fix this soon? how users are supposed to install vdsm if those pkg
Error: Package: vdsm-4.12.0-149.git44993c6.el6.x86_64
Requires: selinux-policy-targeted >= 3.7.19-213
Installed: selinux-policy-targeted-3.7.19-195.el6_4.12.noarch (@updates)
Thanks for reporting this issue. We must revert this part of
("One shot prepare")
The selinux requirement came since that patch moves the storage
reprository to a new location (/var/run/vdsm/storage) instead of the
trademark-offensive non-standard /rhev/data-center.
EL6.4 would not be able to use the new location with selinux enabled.
We have a much bigger issue with this change, as it breaks migration to
and from ovirt-3.3; solving this is in the works.
--> Running transaction check
---> Package dracut.x86_64 0:024-18.git20130102.fc18 will be updated
---> Package dracut.x86_64 0:024-25.git20130205.fc18 will be an update
---> Package vdsm.x86_64 0:4.12.0-149.git44993c6.fc18 will be installed
--> Processing Dependency: libvirt-daemon >= 1.0.2-1 for package:
--> Finished Dependency Resolution
Error: Package: vdsm-4.12.0-149.git44993c6.fc18.x86_64
Requires: libvirt-daemon >= 1.0.2-1
Installed: libvirt-daemon-0.10.2.7-1.fc18.x86_64 (@updates)
libvirt-daemon = 0.10.2.7-1.fc18
Available: libvirt-daemon-0.10.2.2-3.fc18.x86_64 (fedora)
libvirt-daemon = 0.10.2.2-3.fc18
This is a known and unavoidable issue (since
of Mar 28 2013). oVirt users on F18 would
have to obtain libvirt from virt-preview or compile it themselves.