Change in ovirt-engine[ovirt-engine-3.3]: webadmin: Introducing AddRemoveRowWidget
by iheim@redhat.com
Itamar Heim has submitted this change and it was merged.
Change subject: webadmin: Introducing AddRemoveRowWidget
......................................................................
webadmin: Introducing AddRemoveRowWidget
This is a reusable widget used to display a list of other widgets,
backed by a ListModel of values. Entries may be removed or added using
minus/plus buttons. A new entry is added by activating a semi-disabled
"ghost" entry.
Change-Id: I15958e4b7c1fcf0ec08ea35eb32c690964f2a366
Bug-Url: https://bugzilla.redhat.com/1003779
Signed-off-by: Lior Vernia <lvernia(a)redhat.com>
---
A frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/AddRemoveRowWidget.java
1 file changed, 242 insertions(+), 0 deletions(-)
Approvals:
Lior Vernia: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19834
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I15958e4b7c1fcf0ec08ea35eb32c690964f2a366
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.3
Gerrit-Owner: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Itamar Heim <iheim(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 1 month
Change in ovirt-engine[ovirt-engine-3.3]: webadmin: Unified VNIC update logic on VM creation
by iheim@redhat.com
Itamar Heim has submitted this change and it was merged.
Change subject: webadmin: Unified VNIC update logic on VM creation
......................................................................
webadmin: Unified VNIC update logic on VM creation
Towards adding the ability to add and remove VNICs in the add/edit VM
dialogs, the VNIC logic is unified so it is the same for all kinds of
VM creation flows (e.g. from scratch, from template...); VNICs may
always be added, edited or removed.
Change-Id: Ifbd61031572a3462af46f24c64fb5bb80343f086
Bug-Url: https://bugzilla.redhat.com/1003779
Signed-off-by: Lior Vernia <lvernia(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/userportal/UserPortalListModel.java
A frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/UnitVmModelNetworkAsyncCallback.java
D frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/UnitVmModelNetworkAsyncCallbacks.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmInterfaceCreatingManager.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmListModel.java
5 files changed, 129 insertions(+), 241 deletions(-)
Approvals:
Lior Vernia: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19833
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifbd61031572a3462af46f24c64fb5bb80343f086
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.3
Gerrit-Owner: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Itamar Heim <iheim(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 1 month
Change in ovirt-engine[ovirt-engine-3.3]: webadmin: Replaced null profile with empty profile
by iheim@redhat.com
Itamar Heim has submitted this change and it was merged.
Change subject: webadmin: Replaced null profile with empty profile
......................................................................
webadmin: Replaced null profile with empty profile
Added a special value to represent an empty profile, and changed empty
profile instances to that instead of null. This is needed by a
soon-to-be-implemented Add/Remove VNIC widget in the Add/Edit VM
dialog, in order to discriminate between the case where a profile
hasn't yet been assigned (null) and the case where the empty profile
has been assigned (VnicProfileView.EMPTY).
Change-Id: I06962e43084ff4fd469e0025527cdd85a47f5ea7
Bug-Url: https://bugzilla.redhat.com/1003779
Signed-off-by: Lior Vernia <lvernia(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/network/VnicProfileView.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/CommonApplicationMessages.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/profile/ProfileEditor.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/Linq.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/EditProfileBehavior.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/ProfileBehavior.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmInterfaceModel.java
7 files changed, 31 insertions(+), 18 deletions(-)
Approvals:
Itamar Heim: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19832
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I06962e43084ff4fd469e0025527cdd85a47f5ea7
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.3
Gerrit-Owner: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Itamar Heim <iheim(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 1 month
Change in ovirt-engine[ovirt-engine-3.3]: webadmin: Enabled column resizing in Manage Cluster Networks
by iheim@redhat.com
Itamar Heim has submitted this change and it was merged.
Change subject: webadmin: Enabled column resizing in Manage Cluster Networks
......................................................................
webadmin: Enabled column resizing in Manage Cluster Networks
In certain locales columns would get wider, to the point where a
horizontal scroll bar appeared. This fixes it. Also adjusted some
preset widths to look better in English.
Change-Id: If7bac93b4de9400996a07ffc98fed3a6343fef34
Bug-Url: https://bugzilla.redhat.com/1009745
Signed-off-by: Lior Vernia <lvernia(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/cluster/ClusterManageNetworkPopupView.java
1 file changed, 6 insertions(+), 4 deletions(-)
Approvals:
Itamar Heim: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19768
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If7bac93b4de9400996a07ffc98fed3a6343fef34
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.3
Gerrit-Owner: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Itamar Heim <iheim(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 1 month
Change in ovirt-engine[ovirt-engine-3.3]: webadmin: Fixed table layout upon enableColumnResizing()
by iheim@redhat.com
Itamar Heim has submitted this change and it was merged.
Change subject: webadmin: Fixed table layout upon enableColumnResizing()
......................................................................
webadmin: Fixed table layout upon enableColumnResizing()
This makes sure that column resizing behaves consistently for the
tables in which it's enabled (without it some default browser
rearranging occurs).
Change-Id: Ia36d2d4f1cae395fe9f12d55a05799445d0eca11
Bug-Url: https://bugzilla.redhat.com/1009745
Signed-off-by: Lior Vernia <lvernia(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/table/resize/ColumnResizeCellTable.java
1 file changed, 3 insertions(+), 0 deletions(-)
Approvals:
Itamar Heim: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19767
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia36d2d4f1cae395fe9f12d55a05799445d0eca11
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.3
Gerrit-Owner: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Itamar Heim <iheim(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 1 month
Change in ovirt-engine[master]: engine: Block multicast MAC addresses for vNICs
by masayag@redhat.com
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Block multicast MAC addresses for vNICs
......................................................................
engine: Block multicast MAC addresses for vNICs
The patch blocks the possibility to provide a non-
unicast mac address to the vnic: neither broadcast
or multicast mac addresses aren't allowed for a vnic.
Change-Id: Ida4082be249391494053b56540d5458fecec65da
Bug-Url: https://bugzilla.redhat.com/1011912
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MoveOrCopyTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/MacPoolManager.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/vm/AbstractVmInterfaceCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/vm/AddVmInterfaceCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/vm/UpdateVmInterfaceCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/network/VmNic.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/VdcBllMessages.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/utils/ValidationUtils.java
M backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/businessentities/network/VmNetworkInterfaceValidationTest.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M backend/manager/tools/src/main/java/org/ovirt/engine/core/config/entity/helper/MacAddressPoolRangesValueHelper.java
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/validation/MacAddressValidation.java
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
15 files changed, 45 insertions(+), 43 deletions(-)
Approvals:
Moti Asayag: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19805
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ida4082be249391494053b56540d5458fecec65da
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 1 month
Change in ovirt-engine[master]: webadmin: removed storage from pools general sub-tab
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: webadmin: removed storage from pools general sub-tab
......................................................................
webadmin: removed storage from pools general sub-tab
Since a pool can contain disks from multiple storage domains,
'Resides on Storage Domain' is no longer relevant.
Hence,
* removed from pools general sub-tab.
* removed redundant method PoolGeneralModel -> updateStorageDomain.
Change-Id: I26a1ec85ef404954767aa81042679e3120efad2a
Signed-off-by: Daniel Erez <derez(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/CommonApplicationConstants.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/pools/PoolGeneralModel.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/tab/pool/SubTabPoolGeneralView.java
3 files changed, 0 insertions(+), 100 deletions(-)
Approvals:
Daniel Erez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19669
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I26a1ec85ef404954767aa81042679e3120efad2a
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 1 month
Change in ovirt-engine[master]: webadmin: removed dead code from VmGeneralModel
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: webadmin: removed dead code from VmGeneralModel
......................................................................
webadmin: removed dead code from VmGeneralModel
VmGeneralModel -> updateStorageDomain method has been
used for displaying in which domain the VM resides on.
Since a VM can contain disks from multiple storage domains
this method is no longer relevant.
Change-Id: Ida307e9bf7d8a89d6466569f16ae0596c648d636
Signed-off-by: Daniel Erez <derez(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmGeneralModel.java
1 file changed, 0 insertions(+), 72 deletions(-)
Approvals:
Daniel Erez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19668
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ida307e9bf7d8a89d6466569f16ae0596c648d636
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 1 month
Change in ovirt-hosted-engine-setup[ovirt-hosted-engine-setup-1.0]: UX: more readable error message checking space
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: UX: more readable error message checking space
......................................................................
UX: more readable error message checking space
Changed the error message when there's not enough space
for the self hosted engine VM to be more readable.
Change-Id: I56d5e011377f6f5bd43b4c86fceb57b6e622ff9d
Bug-Url: https://bugzilla.redhat.com/1013662
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
M src/ovirt_hosted_engine_setup/domains.py
M src/plugins/ovirt-hosted-engine-setup/storage/storage.py
M src/plugins/ovirt-hosted-engine-setup/vm/boot_disk.py
3 files changed, 31 insertions(+), 5 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19868
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I56d5e011377f6f5bd43b4c86fceb57b6e622ff9d
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-setup
Gerrit-Branch: ovirt-hosted-engine-setup-1.0
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
11 years, 1 month
Change in ovirt-engine[ovirt-engine-3.3]: webadmin: Added vertical scrolling to BaseListModelSuggestBox
by iheim@redhat.com
Itamar Heim has submitted this change and it was merged.
Change subject: webadmin: Added vertical scrolling to BaseListModelSuggestBox
......................................................................
webadmin: Added vertical scrolling to BaseListModelSuggestBox
All suggest boxes in the system could probably use a height limitation
for their suggestion list, with a vertical scrollbar when the content
is too big.
Also took the chance to move the logic fitting the height of the
suggestion list to that of the content from ListModelTypeAheadListBox
to BaseListModelSuggestBox, as ListModelSuggestBox could also use it.
Change-Id: I9c662e3e8d1062e654f10ce275019c28b62f2666
Bug-Url: https://bugzilla.redhat.com/1008523
Signed-off-by: Lior Vernia <lvernia(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/editor/BaseListModelSuggestBox.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/editor/ListModelTypeAheadListBox.ui.xml
2 files changed, 15 insertions(+), 8 deletions(-)
Approvals:
Itamar Heim: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19831
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9c662e3e8d1062e654f10ce275019c28b62f2666
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.3
Gerrit-Owner: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Itamar Heim <iheim(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 1 month