Change in ovirt-engine[master]: packaging: services: ovirt-engine: opt-in defaults
by oschreib@redhat.com
Ofer Schreiber has submitted this change and it was merged.
Change subject: packaging: services: ovirt-engine: opt-in defaults
......................................................................
packaging: services: ovirt-engine: opt-in defaults
by now all developers should use the new development environment, there
is no need to keep opt-out defaults.
Change-Id: I954491b1e5f557dba38b2a6d6b3c47266c750fe9
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M packaging/services/ovirt-engine/ovirt-engine.conf.in
M packaging/setup/plugins/ovirt-engine-setup/config/protocols.py
2 files changed, 12 insertions(+), 23 deletions(-)
Approvals:
Ofer Schreiber: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/17337
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I954491b1e5f557dba38b2a6d6b3c47266c750fe9
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Ofer Schreiber <oschreib(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
11 years, 4 months
Change in ovirt-engine[master]: core: Fix GWT RPC serialization issue in RepoImage
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Fix GWT RPC serialization issue in RepoImage
......................................................................
core: Fix GWT RPC serialization issue in RepoImage
Since no UI code references RepoImage constructor, both
constructor (RepoImage method) and instance initializer
($init method) are marked as dead code by GWT compiler.
In consequence, instance initializer which is responsible
for adding fields such as "private X field = Y;" won't be
part of resulting JavaScript and corresponding GWT RPC
serialization policy.
In other words, if UI code doesn't reference business
entity constructor and we still want to use this entity
in UI code, the entity must not contain fields such as:
private X field = Y;
instead, the entity must contain fields such as:
private X field;
and do "field = Y;" assignment within its constructor.
Even though constructor won't execute in UI code, all
fields will still be part of resulting JavaScript.
Change-Id: I7085762877afc8f76090cf18f38bd303c5db2864
Signed-off-by: Vojtech Szocs <vszocs(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/RepoImage.java
1 file changed, 8 insertions(+), 4 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/17352
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7085762877afc8f76090cf18f38bd303c5db2864
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Einav Cohen <ecohen(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-engine[master]: packaging: spec: all-in-one: do not allow disabling NetworkM...
by oschreib@redhat.com
Ofer Schreiber has submitted this change and it was merged.
Change subject: packaging: spec: all-in-one: do not allow disabling NetworkManager
......................................................................
packaging: spec: all-in-one: do not allow disabling NetworkManager
because of various reasons, vdsm requires disabling NetworkManager,
however in all-in-one configuration, it may do much more harm than good.
so for all-in-one configuration we leave NetworkManager up, under the
assumption that there won't be significant network changes via the
engine->vdsm communication.
Change-Id: I6be399e070ede11a10f0f7636d71acc45b942872
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M ovirt-engine.spec.in
1 file changed, 6 insertions(+), 0 deletions(-)
Approvals:
Ofer Schreiber: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/17309
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6be399e070ede11a10f0f7636d71acc45b942872
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Antoni Segura Puimedon <asegurap(a)redhat.com>
Gerrit-Reviewer: Ofer Schreiber <oschreib(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
11 years, 4 months
Change in ovirt-engine[master]: core: extract memory images removal on remove vm out of tran...
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: extract memory images removal on remove vm out of transaction
......................................................................
core: extract memory images removal on remove vm out of transaction
On remove vm command, the data we remove from the DB is being removed
inside a transaction. The memory images removal, which is a vdsm
operation, is also made inside this trasaction and this is wrong -
vdsm operations should be executed out of transactions.
So this patch extract the call to vdsm for removing the memory images
which is taking place as part of remove vm command to be executed out
of transaction.
Change-Id: I908f8e9fe4e276063aa88357c3cbfe9ae56be501
Bug-Url: https://bugzilla.redhat.com/985410
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveVmFromImportExportCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VmCommand.java
4 files changed, 73 insertions(+), 72 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/17308
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I908f8e9fe4e276063aa88357c3cbfe9ae56be501
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-engine[master]: core: cleanup related to memory state removal
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: cleanup related to memory state removal
......................................................................
core: cleanup related to memory state removal
1. changed MemoryImageRemover#isMemoryStateRemovable method not to be
abstract, but to have a default check that checks that the memory state
representation is not empty
2. Reduce the visibility of MemoryImageRemover#removeMemoryVolumes to
'protected' as it shouldn't be invoked by external classes. subclasses
expose API that use it behind the scenes
3. Snapshot manager now uses MemoryUtils#getMemoryVolumesFromSnapshots
instead of having duplicated logic
Change-Id: I30f400400eb8233a61c4a9cef54c7a8844255b38
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveVmFromImportExportCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/memory/MemoryImageRemover.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/memory/MemoryImageRemoverFromExportDomain.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/memory/MemoryImageRemoverOnDataDomain.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/SnapshotsManager.java
6 files changed, 33 insertions(+), 28 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/17307
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I30f400400eb8233a61c4a9cef54c7a8844255b38
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-engine[master]: core: fix memory state removal on import vm rollback
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: fix memory state removal on import vm rollback
......................................................................
core: fix memory state removal on import vm rollback
In case import vm operation fails, we rollback the changes and in
particular we remove the memory states of the imported vm from the
data domain.
This patch fix a problem that the memory state images were not removed
by modify the condition that determines if the memory state should be
removed in that case.
The memory states removal was also improved:
if there are no memory states in the snapshots of the imported vm,
the creation of MemoryImageRemover will be skipped.
Change-Id: I98b9908c5332ed66494cc56d826f95314f4f0fee
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/memory/MemoryImageRemoverOnDataDomain.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/SnapshotsManager.java
3 files changed, 6 insertions(+), 7 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/17057
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I98b9908c5332ed66494cc56d826f95314f4f0fee
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-engine[master]: core: minor cleanups in MemoryImageRemover class
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: minor cleanups in MemoryImageRemover class
......................................................................
core: minor cleanups in MemoryImageRemover class
1. Define constant instead of using '6' explicitly in the code
2. Rename shouldRemoveMemorySnapshotVolumes method to
isMemoryStateRemovable
3. Add log printing when the given memory state representation is not in
the expected format (doesn't have 6 UUIDs separated by comma)
4. Rename local fields
5. Remove 'vm' and 'cachedPostZero' since they are not used by this
class (so they are moved to the subclasses)
6. Add a boolean class field which indicates whether to start polling
the created tasks or not, instead of indicating that by setting a
parameter of the removeMemoryVolumes method
Change-Id: I14cb0bb13d0d103bbc170abcf0348a6909051f2c
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/memory/MemoryImageRemover.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/memory/MemoryImageRemoverFromExportDomain.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/memory/MemoryImageRemoverOnDataDomain.java
3 files changed, 51 insertions(+), 38 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/16828
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I14cb0bb13d0d103bbc170abcf0348a6909051f2c
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-engine[master]: core: ignore image does not exists error on remove memory st...
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: ignore image does not exists error on remove memory state
......................................................................
core: ignore image does not exists error on remove memory state
If we are trying to remove the memory state images, and we find that the
images don't exist, we treat this as if the operation was successful
(because the images are not there anymore) instead of treat this as an
error.
Change-Id: Ic5dce38bed0675306d647b3830fe2d208e19d0d1
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/memory/MemoryImageRemover.java
1 file changed, 38 insertions(+), 12 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/17056
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic5dce38bed0675306d647b3830fe2d208e19d0d1
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-engine[master]: core: simplified memory states removal code
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: simplified memory states removal code
......................................................................
core: simplified memory states removal code
This patch simplifies the
MemoryImageRemover#removeMemoryVolumes(String, boolean) method:
1. split the long method into several methods
2. reorganize the tasks polling related code
Change-Id: Ib0b5b9d77458db7c2a7e97fe0d36fd2b8679d20d
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/memory/MemoryImageRemover.java
1 file changed, 38 insertions(+), 40 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/16827
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib0b5b9d77458db7c2a7e97fe0d36fd2b8679d20d
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-dwh[master]: packaging: setup: fixed pg_hba handling
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: packaging: setup: fixed pg_hba handling
......................................................................
packaging: setup: fixed pg_hba handling
Change-Id: Ia07c00c871c51e1cbf46084621f11fa47b42c90c
Bug-Url: https://bugzilla.redhat.com/988045
Signed-off-by: Alex Lourie <alourie(a)redhat.com>
---
M packaging/common_utils.py
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Yaniv Dary: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/17289
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia07c00c871c51e1cbf46084621f11fa47b42c90c
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-dwh
Gerrit-Branch: master
Gerrit-Owner: Alex Lourie <alourie(a)redhat.com>
Gerrit-Reviewer: Alex Lourie <alourie(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
11 years, 4 months