Change in ovirt-engine[master]: core: Removing an outdated comment from RestoreFromSnapshot.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Removing an outdated comment from RestoreFromSnapshot.
......................................................................
core: Removing an outdated comment from RestoreFromSnapshot.
Adding image to _imageToDelete is already being done when calling
removeSnapshot.
Change-Id: Ibbc56ae1e40d8ce4f2496d816ca847200ec72b26
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RestoreFromSnapshotCommand.java
1 file changed, 0 insertions(+), 7 deletions(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/16416
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibbc56ae1e40d8ce4f2496d816ca847200ec72b26
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-engine[master]: core: Rename parameter class connectStorageServer.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Rename parameter class connectStorageServer.
......................................................................
core: Rename parameter class connectStorageServer.
ConnectStorageServerVDSCommandParameter is used as a parameter class to
connect and disconnect
storage server.
This is quite confusing especially in the ISCSIStorageHelper which calls
a command reflected by a variable (could be connect or disconnect) but
use a parameter class of connectStorageServer.
To make the code looks more readable, the parameter class name
has been changed to StorageServerConnectionManagementVDSParameters.
Change-Id: I84f280bf9abe97fe5c7a4b7514aecf0d29621c3a
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/ConnectHostToStoragePoolServersCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/ConnectStorageToVdsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/DisconnectHostFromStoragePoolServersCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/DisconnectStorageServerConnectionCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/ISCSIStorageHelper.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/UpdateStorageServerConnectionCommand.java
R backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/vdscommands/StorageServerConnectionManagementVDSParameters.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/ConnectStorageServerVDSCommand.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/DisconnectStorageServerVDSCommand.java
9 files changed, 25 insertions(+), 25 deletions(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/16409
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I84f280bf9abe97fe5c7a4b7514aecf0d29621c3a
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-engine-sdk-java[master]: sdk: implement host CA certificate validation
by mpastern@redhat.com
Michael Pasternak has submitted this change and it was merged.
Change subject: sdk: implement host CA certificate validation
......................................................................
sdk: implement host CA certificate validation
oVirt Java-SDK provides now full support for HTTP over Secure Sockets Layer (SSL)
or IETF Transport Layer Security (TLS) protocols by leveraging the Java Secure Socket
Extension (JSSE). JSSE has been integrated into the Java 2 platform as of version 1.4
and works with Java-SDK out of the box. On older Java 2 versions JSSE needs to be manually
installed and configured.
Once you have JSSE correctly installed, secure HTTP communication over SSL should be as
simple as plain HTTP communication, however SDK need to be supplied with KeyStore containing
host CA certeficate in order to validate the destination host identity, more details can be
found at [1]
[1] http://www.ovirt.org/Java-sdk#Working_with_SSL_.28Secure_Socket_Layer.29
Change-Id: Ibb8bb422a21e1f2c1263835e7d650e1e1a3633d2
Signed-off-by: Michael pasternak <mpastern(a)redhat.com>
---
M ovirt-engine-sdk-java-codegen/src/main/java/org/ovirt/engine/sdk/codegen/templates/ApiTemplate
M ovirt-engine-sdk-java/src/main/java/org/ovirt/engine/sdk/Api.java
A ovirt-engine-sdk-java/src/main/java/org/ovirt/engine/sdk/exceptions/ProtocolException.java
A ovirt-engine-sdk-java/src/main/java/org/ovirt/engine/sdk/exceptions/SocketFactoryException.java
M ovirt-engine-sdk-java/src/main/java/org/ovirt/engine/sdk/web/ConnectionsPoolBuilder.java
5 files changed, 445 insertions(+), 16 deletions(-)
Approvals:
Michael Pasternak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/16538
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibb8bb422a21e1f2c1263835e7d650e1e1a3633d2
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine-sdk-java
Gerrit-Branch: master
Gerrit-Owner: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
11 years, 4 months
Change in ovirt-engine[master]: core: check no running VMs use storage conn
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: check no running VMs use storage conn
......................................................................
core: check no running VMs use storage conn
Check during update connection that if the updated
connection is for block storage, if it's used by lun disks,
that the plugged VMs are down.
Also, failing connect to storage or getting domain stats
is no longer failing the entire command, so updating the
storage connection will not depend on them.
Change-Id: I11fe22760952e1319654647eed661a7814675f64
Signed-off-by: Alissa Bonas <abonas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/AddStorageServerConnectionCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/RemoveStorageServerConnectionCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/StorageServerConnectionCommandBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/UpdateStorageServerConnectionCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/UpdateStorageServerConnectionCommandTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/VdcBllMessages.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
10 files changed, 549 insertions(+), 236 deletions(-)
Approvals:
Allon Mureinik: Looks good to me, approved
Alissa Bonas: Verified
--
To view, visit http://gerrit.ovirt.org/16203
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I11fe22760952e1319654647eed661a7814675f64
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-engine[master]: ui: ISO domain refresh button is missing
by shavivi@redhat.com
Shahar Havivi has submitted this change and it was merged.
Change subject: ui: ISO domain refresh button is missing
......................................................................
ui: ISO domain refresh button is missing
In Run-Once or Add/Edit Vm there is no refresh button.
Bug-Url: https://bugzilla.redhat.com/729577
Change-Id: I9d487dd839efccb69940c7cc6ada68b668f8fa2d
Signed-off-by: Shahar Havivi <shavivi(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/AbstractVmPopupWidget.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/AbstractVmPopupWidget.ui.xml
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/vm/VmRunOncePopupWidget.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/vm/VmRunOncePopupWidget.ui.xml
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/dataprovider/AsyncDataProvider.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/RunOnceModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmModelBehaviorBase.java
7 files changed, 92 insertions(+), 9 deletions(-)
Approvals:
Shahar Havivi: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/16311
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9d487dd839efccb69940c7cc6ada68b668f8fa2d
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Michal Skrivanek <michal.skrivanek(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-engine[master]: engine: wrong logging on stateless snapshot
by shavivi@redhat.com
Shahar Havivi has submitted this change and it was merged.
Change subject: engine: wrong logging on stateless snapshot
......................................................................
engine: wrong logging on stateless snapshot
Change-Id: I43a368e9298544e280afcc755f74bbfc645b77e1
Bug-Url: https://bugzilla.redhat.com/976205
Signed-off-by: Shahar Havivi <shavivi(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommand.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Shahar Havivi: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/16427
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I43a368e9298544e280afcc755f74bbfc645b77e1
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: humble devassy <hchiramm(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-engine[master]: core: Remove unreadable comment
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Remove unreadable comment
......................................................................
core: Remove unreadable comment
Removing a Vitaly comment.
doesn't seems that the comment can help some how.
Change-Id: I7825c0dbee96361f5cba63f6dfbce63366ea5801
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/IVdsEventListener.java
1 file changed, 0 insertions(+), 5 deletions(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/16415
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7825c0dbee96361f5cba63f6dfbce63366ea5801
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-engine[master]: core: Remove irrelevant comment
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Remove irrelevant comment
......................................................................
core: Remove irrelevant comment
Removing Vitaly comment
Change-Id: I6acbc83c9c4128ff7186a53368ed2ae1a866d547
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M packaging/dbscripts/vds_sp.sql
1 file changed, 0 insertions(+), 1 deletion(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/16414
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6acbc83c9c4128ff7186a53368ed2ae1a866d547
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
11 years, 4 months
Change in ovirt-engine[master]: core: Fix NPE when committing a snapshot.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Fix NPE when committing a snapshot.
......................................................................
core: Fix NPE when committing a snapshot.
A regression caused by commit 268152abf19fbd64fd867bc5e5e40a57996aedc7
made the commit snapshot to throw NPE when commiting a snapshot, since
the new snapshot id has been created twice, once for the snapshots table
and once for the vm_snapshot_id of the image.
The fix set the parameter only once.
Change-Id: If423dd90739cd14a66a7a62399f56465a2e30021
Bug-Url: https://bugzilla.redhat.com/981367
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CreateAllSnapshotsFromVmCommand.java
1 file changed, 6 insertions(+), 8 deletions(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/16457
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If423dd90739cd14a66a7a62399f56465a2e30021
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 4 months
Change in ovirt-engine[master]: fix path in README.developers
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: fix path in README.developers
......................................................................
fix path in README.developers
Change-Id: I0b4f9d0666539383ea83a533214fef5221ac841b
Signed-off-by: Yaniv Bronhaim <ybronhei(a)redhat.com>
---
M README.developer
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Yair Zaslavsky: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/16321
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0b4f9d0666539383ea83a533214fef5221ac841b
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Yaniv Bronhaim <ybronhei(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
11 years, 4 months