Change in ovirt-engine[master]: core: mapParams performance improvement
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: core: mapParams performance improvement
......................................................................
core: mapParams performance improvement
When going through jprofiler snapshots from scale env I noticed that
getDataTimeInstance is taking a lot of time. DateFormat objects is not
used but we create it every time we run mapParams so we can remove it
without any harm.
Change-Id: Ib914112be17442e13148def922a486ccf9c0f63f
Signed-off-by: pkliczewski <piotr.kliczewski(a)gmail.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/BatchProcedureExecutionConnectionCallback.java
1 file changed, 0 insertions(+), 3 deletions(-)
Approvals:
Piotr Kliczewski: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/35126
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib914112be17442e13148def922a486ccf9c0f63f
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Liran Zelkha <lzelkha(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years
Change in ovirt-engine[master]: setup: Changing task cleaner utility to also handle removal ...
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: setup: Changing task cleaner utility to also handle removal of commands
......................................................................
setup: Changing task cleaner utility to also handle removal of commands
The task cleaner utility now has the ability to present all commands
or commands with running tasks, and to erase commands (or commands with
running tasks)
Bug-Url: https://bugzilla.redhat.com/1161012
Change-Id: I1d8f83cb7fc1f7fecb4ea68dff5cf0f3c63eeb6b
Signed-off-by: Yair Zaslavsky <yzaslavs(a)redhat.com>
---
M packaging/setup/dbutils/taskcleaner.sh
M packaging/setup/dbutils/taskcleaner_sp.sql
2 files changed, 88 insertions(+), 5 deletions(-)
Approvals:
oVirt Jenkins CI Server: Looks good to me, but someone else must approve
Yair Zaslavsky: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/34927
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1d8f83cb7fc1f7fecb4ea68dff5cf0f3c63eeb6b
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years
Change in ovirt-engine[master]: jsonrpc: wrong response key name
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: jsonrpc: wrong response key name
......................................................................
jsonrpc: wrong response key name
Change-Id: I2c0cd541a0ea0d43a8599a5f55a184cf6e7f78b7
Signed-off-by: pkliczewski <piotr.kliczewski(a)gmail.com>
Bug-Url: https://bugzilla.redhat.com/1159637
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/jsonrpc/JsonRpcVdsServer.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Oved Ourfali: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/35135
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2c0cd541a0ea0d43a8599a5f55a184cf6e7f78b7
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years
Change in ovirt-engine[ovirt-engine-3.5]: core:fix handling of admin user while login
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: core:fix handling of admin user while login
......................................................................
core:fix handling of admin user while login
GetAllRolesByUserIdAndGroupIds was called whenever a user was logged in
in order to find out if the user is an admin or not.
In original code, all roles were retrieved and the check for the admin
role type was done in a loop inside the
MultiLevelAdministrationHandler::isAdminUser() code.
Since the required functionality is only to find if any admin role is
attached to the logging user, I had changed the SP code to return only
one role (if exists) and have the role_type checked in the SP level.
SP name and DAO method names were changed to match the real
functionality.
Change-Id: I6aa489199c904008e46a650f11877091931ee5de
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1156465
Signed-off-by: Eli Mesika <emesika(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MultiLevelAdministrationHandler.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/RoleDAO.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/RoleDAODbFacadeImpl.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/RoleDAOTest.java
M packaging/dbscripts/multi_level_administration_sp.sql
5 files changed, 30 insertions(+), 36 deletions(-)
Approvals:
Eli Mesika: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/35216
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6aa489199c904008e46a650f11877091931ee5de
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years
Change in ovirt-engine[master]: core: fix VmTemplate copy ctor
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: fix VmTemplate copy ctor
......................................................................
core: fix VmTemplate copy ctor
remove code duplication by calling VmBase(VmBase vmBase) ctor that
already copies all the field from that class, and leave in VmTemplate
only the template fields.
Change-Id: Ie585d00ee6c4232b09e1a2396ad335348b8122be
Signed-off-by: Omer Frenkel <ofrenkel(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VmTemplate.java
1 file changed, 6 insertions(+), 50 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/35204
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie585d00ee6c4232b09e1a2396ad335348b8122be
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years
Change in ovirt-engine[master]: packaging: remove legacy osinfo.py file
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: packaging: remove legacy osinfo.py file
......................................................................
packaging: remove legacy osinfo.py file
Change-Id: I388e687c29e0faa6f7e6a6c5763ab66b95d25a86
Signed-off-by: Martin Betak <mbetak(a)redhat.com>
---
M packaging/setup/ovirt_engine_setup/constants.py
D packaging/setup/plugins/ovirt-engine-setup/ovirt-engine/legacy/__init__.py
D packaging/setup/plugins/ovirt-engine-setup/ovirt-engine/legacy/osinfo.py
3 files changed, 0 insertions(+), 217 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, approved
Simone Tiraboschi: Looks good to me, but someone else must approve
oVirt Jenkins CI Server: Looks good to me, but someone else must approve
Martin Betak: Verified
Yedidyah Bar David: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/35142
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I388e687c29e0faa6f7e6a6c5763ab66b95d25a86
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years
Change in ovirt-engine[ovirt-engine-3.5]: Parsing http body return on error and improve output
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: Parsing http body return on error and improve output
......................................................................
Parsing http body return on error and improve output
Instead of generalizing the error by using PROVIDER_FAILURE, foreman
starts to provide full description of the failure reason, such as:
Body: {
"error": {"id":17,"errors":{"root_pass":["should be 8 characters or more"]},
"full_messages":["Root password should be 8 characters or more"]}
}
In this patch we add the "full_messages" to engine.log
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1124891
Change-Id: I1a5717baa06665e475e64a8f91e23ffcb01e17b4
Signed-off-by: Yaniv Bronhaim <ybronhei(a)redhat.com>
---
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/host/provider/foreman/ForemanError.java
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/host/provider/foreman/ForemanErrorWrapper.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/host/provider/foreman/ForemanHostProviderProxy.java
3 files changed, 35 insertions(+), 1 deletion(-)
Approvals:
Yaniv Bronhaim: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/35201
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1a5717baa06665e475e64a8f91e23ffcb01e17b4
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Yaniv Bronhaim <ybronhei(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Yaniv Bronhaim <ybronhei(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years
Change in ovirt-engine[ovirt-engine-3.5]: db: add a common function for index creation
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: db: add a common function for index creation
......................................................................
db: add a common function for index creation
This patch adds a common function that drop the index if exists and
creates it after that.
This is done in order to prevent scripts failures when the index is not
dropped and an attempt to re-create it is done
Bug-Url: https://bugzilla.redhat.com/1155153
Change-Id: I6e6e2577ceac435e25030dfde6ff6c4c3f8a7278
Signed-off-by: Eli Mesika <emesika(a)redhat.com>
(cherry picked from commit d65b5293b48d552d90cc4dbf44d2c09769548906)
---
M packaging/dbscripts/common_sp.sql
1 file changed, 19 insertions(+), 0 deletions(-)
Approvals:
Oved Ourfali: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/35195
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6e6e2577ceac435e25030dfde6ff6c4c3f8a7278
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years
Change in ovirt-engine[ovirt-engine-3.5]: core: Set storage type as set in the paramteres.
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Set storage type as set in the paramteres.
......................................................................
core: Set storage type as set in the paramteres.
1) Set the storage type of the storage after it was fetched from VDSM in
GetExistingStorageDomainListQuery
2) use getStorageDomainsList to be fetched without Storage Domains type.
Change-Id: I9a6f2f22b09de9daffde5e003528324237d6835f
Bug-Url: https://bugzilla.redhat.com/1157240
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/GetExistingStorageDomainListQuery.java
1 file changed, 8 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Maor Lipchuk: Verified
--
To view, visit http://gerrit.ovirt.org/35110
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9a6f2f22b09de9daffde5e003528324237d6835f
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years
Change in ovirt-engine[ovirt-engine-3.5]: webadmin: Fixed description in edit affinity group
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Fixed description in edit affinity group
......................................................................
webadmin: Fixed description in edit affinity group
In the "Edit" popup of the "Affinity Group" subtab for the VM
The description field wasn't retrieved(It was left empty even after
being set). This error was fixed and now description field that was set
will be shown in the edit popup.
Change-Id: Ib0e88bc052844a5cfca30b0f1c53bf1b118c2ae3
Bug-Url: https://bugzilla.redhat.com/1142233
Signed-off-by: Tomer Saban <tsaban(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/configure/scheduling/affinity_groups/model/EditAffinityGroupModel.java
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Gilad Chaplik: Looks good to me, approved
Tomer Saban: Verified
Roy Golan: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/34830
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib0e88bc052844a5cfca30b0f1c53bf1b118c2ae3
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Tomer Saban <tsaban(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomer Saban <tsaban(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years