Change in ovirt-engine[master]: iso: Enable ISO on gluster
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: iso: Enable ISO on gluster
......................................................................
iso: Enable ISO on gluster
Enable GlusterFS storage type when domain function is ISO.
Change-Id: I2d855da9e2fbfc7232ff165c2e8b20ac01b2a57f
Bug-Url: https://bugzilla.redhat.com/1243860
Signed-off-by: Ala Hino <ahino(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/dataprovider/AsyncDataProvider.java
1 file changed, 3 insertions(+), 0 deletions(-)
Approvals:
Daniel Erez: Looks good to me, approved
Jenkins CI: Passed CI tests
Ala Hino: Verified
--
To view, visit https://gerrit.ovirt.org/50374
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2d855da9e2fbfc7232ff165c2e8b20ac01b2a57f
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: engine: Validate AuditLogMessages.properties
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: engine: Validate AuditLogMessages.properties
......................................................................
engine: Validate AuditLogMessages.properties
This patch adds AuditLogMessagesTest, an AbstractPropertiesTestBase
to validate the contents of AuditLogMessages.properties against the
AuditLogType enum, and cleans up all the violations:
1. Where keys have duplicate translations, the one with less information
is removed.
2. Keys missing from AuditLogType were removed
3. Keys corresponding to those in (2) in LocalizedEnums.java and
LocalizedEnums.properties were also removed.
Change-Id: I5c016997d9f4229ddd11488a700898d1ecad8d57
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/dal/src/main/resources/bundles/AuditLogMessages.properties
A backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/AuditLogMessagesTest.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/LocalizedEnums.java
M frontend/webadmin/modules/uicompat/src/main/resources/org/ovirt/engine/ui/uicompat/LocalizedEnums.properties
4 files changed, 10 insertions(+), 25 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/50245
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5c016997d9f4229ddd11488a700898d1ecad8d57
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: webadmin: Clean up LocalizedEnums.properties
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: Clean up LocalizedEnums.properties
......................................................................
webadmin: Clean up LocalizedEnums.properties
Removed messages from LocalizedEnums.properties for enum constants that
no longer exist in the project.
Change-Id: Ic6dbdf11b27b0ffb92ba4f47077711d839dedb76
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicompat/src/main/resources/org/ovirt/engine/ui/uicompat/LocalizedEnums.properties
1 file changed, 0 insertions(+), 13 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/50244
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic6dbdf11b27b0ffb92ba4f47077711d839dedb76
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: Remove ListUtils.getAddedElements
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Remove ListUtils.getAddedElements
......................................................................
core: Remove ListUtils.getAddedElements
ListUtils.getAddedElements has the same functionality as the standard
org.apache.commons.collections.CollectionUtils.subtract, and thus can
easily be removed for sake of reducing the size of the codebase and
focusing on oVirt's business logic.
In the only place it was used, it was used to subtract between two sets
with a maximal size of 2, so performance is hardly an issue here.
Change-Id: Ia7a0bf9c1f897fca7eafeb279bc41776c794526f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterSyncJob.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/utils/ListUtils.java
M backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/utils/ListUtilsTest.java
3 files changed, 3 insertions(+), 54 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/49964
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia7a0bf9c1f897fca7eafeb279bc41776c794526f
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: anmolbabu <anbabu(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: GlusterSyncJob redundant optimization
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GlusterSyncJob redundant optimization
......................................................................
core: GlusterSyncJob redundant optimization
Removed the redundant call to ListUtils.listsEqual - the same logic is
covered by the following conditions anyway.
Change-Id: I7334b8e667a19265509b3323ba2c19cdd214d39c
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterSyncJob.java
1 file changed, 0 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/49963
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7334b8e667a19265509b3323ba2c19cdd214d39c
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: anmolbabu <anbabu(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: webadmin: Fix uppercase parameter name
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Fix uppercase parameter name
......................................................................
webadmin: Fix uppercase parameter name
Changed the name of parameter from ReturnValue to returnValue.
Change-Id: Ic72ae07220c8a03b4800748e0f675d3f11ad624f
Signed-off-by: Fred Rolland <frolland(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageGeneralModel.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved; Passed CI tests
Freddy Rolland: Verified
--
To view, visit https://gerrit.ovirt.org/50230
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic72ae07220c8a03b4800748e0f675d3f11ad624f
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Fred Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: webadmin: Prevent NPE in StorageGeneralModel
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Prevent NPE in StorageGeneralModel
......................................................................
webadmin: Prevent NPE in StorageGeneralModel
Potential NPE discovered by coverity (CID:1201871).
The connection is checked for null, then is directly referenced
a few lines after.
Change-Id: I699ec5f85d0dbb9e449e29e9476aa5a24aeb538f
Signed-off-by: Fred Rolland <frolland(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageGeneralModel.java
1 file changed, 13 insertions(+), 10 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, but someone else must approve
Freddy Rolland: Verified
--
To view, visit https://gerrit.ovirt.org/50165
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I699ec5f85d0dbb9e449e29e9476aa5a24aeb538f
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Fred Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: webadmin: Fix generics in NewDiskModel
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Fix generics in NewDiskModel
......................................................................
webadmin: Fix generics in NewDiskModel
Unchecked casting discovered by coverity (CID:1269329).
Fix generic in eventlistener definition.
Change-Id: Iec70214cdfba810130060dad6d5f29efaa4c7134
Signed-off-by: Fred Rolland <frolland(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/NewDiskModel.java
1 file changed, 5 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, but someone else must approve
Freddy Rolland: Verified
--
To view, visit https://gerrit.ovirt.org/50177
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iec70214cdfba810130060dad6d5f29efaa4c7134
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Fred Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: Remove ListUtils#filter
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Remove ListUtils#filter
......................................................................
core: Remove ListUtils#filter
Removed the unused ListUtils#filter method, its related inner classes
and its test.
Change-Id: I1e6f9ffec0ada90e5fff23ef024f4638c3846ce6
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/utils/ListUtils.java
M backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/utils/ListUtilsTest.java
2 files changed, 0 insertions(+), 93 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/50369
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1e6f9ffec0ada90e5fff23ef024f4638c3846ce6
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: SearchQueryTest#testGetAll[Multi]VdsSearch
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: SearchQueryTest#testGetAll[Multi]VdsSearch
......................................................................
core: SearchQueryTest#testGetAll[Multi]VdsSearch
Enhance the tests to not only test that the correct result is passed back
by the DAO, but also test the filtering the code performs.
Change-Id: Ib6495129b896ff0cab141d56f29e78973af4e21e
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/SearchQuery.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/SearchQueryTest.java
2 files changed, 21 insertions(+), 1 deletion(-)
Approvals:
Martin Peřina: Looks good to me, but someone else must approve
Allon Mureinik: Verified; Passed CI tests
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49400
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib6495129b896ff0cab141d56f29e78973af4e21e
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months