Change in ovirt-engine[master]: restapi: Don't use "TransportType" and "TransportTypes"
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Don't use "TransportType" and "TransportTypes"
......................................................................
restapi: Don't use "TransportType" and "TransportTypes"
These two complex types are used to represent s list of strings. This
isn't worth the creation of two named complex types. This patch changes
the XML schema so it doesn't use them. The types are preserved because
they are still used by the capabilities resource, but will be removed in
the future.
Change-Id: I9f88984ec93bed0e86f6c418d7b519e84b8427b6
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/interface/definition/src/main/schema/api.xsd
M backend/manager/modules/restapi/types/src/main/java/org/ovirt/engine/api/restapi/types/GlusterVolumeMapper.java
2 files changed, 19 insertions(+), 3 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/46837
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9f88984ec93bed0e86f6c418d7b519e84b8427b6
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 6 months
Change in ovirt-engine[master]: restapi: Remove "DnsServers" and "DnsServer" complex types
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Remove "DnsServers" and "DnsServer" complex types
......................................................................
restapi: Remove "DnsServers" and "DnsServer" complex types
These types are used to represent a simple list of string, and that
doesn't deserve two named complex types.
Change-Id: I5be6b07b8fac8bf9a976221b6c1a5046b2aceb75
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/interface/definition/src/main/schema/api.xsd
M backend/manager/modules/restapi/types/src/main/java/org/ovirt/engine/api/restapi/types/openstack/OpenStackSubnetMapper.java
2 files changed, 19 insertions(+), 17 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/46836
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5be6b07b8fac8bf9a976221b6c1a5046b2aceb75
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 6 months
Change in ovirt-engine[master]: restapi: Rename "GuestNicConfiguration" to "NicConfiguration"
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Rename "GuestNicConfiguration" to "NicConfiguration"
......................................................................
restapi: Rename "GuestNicConfiguration" to "NicConfiguration"
This is to increase the consistency between the names of the complex
types and the names of the elements. In this case the name of the
element is "nic_configuration", and it is better for backwards
compatibility to change the name of the type than to change the name of
the element.
Change-Id: I4d6d2759bf2c9e6a585d8e7542fb1bf80c21fbb1
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/README.md
M backend/manager/modules/restapi/interface/definition/src/main/schema/api.xsd
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/validation/GuestNicConfigurationValidator.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/validation/VmValidator.java
M backend/manager/modules/restapi/types/src/main/java/org/ovirt/engine/api/restapi/types/InitializationMapper.java
M backend/manager/modules/restapi/types/src/test/java/org/ovirt/engine/api/restapi/types/VmMapperTest.java
6 files changed, 23 insertions(+), 21 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/46834
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4d6d2759bf2c9e6a585d8e7542fb1bf80c21fbb1
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 6 months
Change in ovirt-engine[ovirt-engine-3.6.0]: core: Don't replace JAXB provided by application server
by piotr.kliczewski@gmail.com
Piotr Kliczewski has submitted this change and it was merged.
Change subject: core: Don't replace JAXB provided by application server
......................................................................
core: Don't replace JAXB provided by application server
The following patch replaced the version of JAXB provided by the
application server (2.2.4) with a newer one:
restapi: Replace JAXB version provided by JBoss
https://gerrit.ovirt.org/30713
That was needed to avoid the following JAXB bug:
https://java.net/jira/browse/JAXB-860
This is no longer needed because both WildFly 8.2 and EAP 6.1 provide
version 2.2.5 of JAXB, which includes the fix for that bug.
Change-Id: I17370356dbf1bd614c96ff5fe4bf0af8486929c0
Bug-Url: https://bugzilla.redhat.com/1266544
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/dependencies/common/pom.xml
D backend/manager/dependencies/common/src/main/modules/com/sun/xml/bind/main/module.xml
2 files changed, 0 insertions(+), 70 deletions(-)
Approvals:
Piotr Kliczewski: Passed CI tests
Sandro Bonazzola: Looks good to me, but someone else must approve
Martin Peřina: Looks good to me, approved
Juan Hernandez: Verified; Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/46828
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I17370356dbf1bd614c96ff5fe4bf0af8486929c0
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6.0
Gerrit-Owner: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 6 months
Change in ovirt-engine[ovirt-engine-3.6.0]: core: Don't replace Jackson provided by application server
by piotr.kliczewski@gmail.com
Piotr Kliczewski has submitted this change and it was merged.
Change subject: core: Don't replace Jackson provided by application server
......................................................................
core: Don't replace Jackson provided by application server
The following patch replaced the version of Jackson provided by the
application server (1.9.2) with the one needed by the OpenStack client
(1.9.9):
core: Use Jackson 1.9.9
https://gerrit.ovirt.org/33959
That is no longer needed because WildFly 8.2 includes version 1.9.13 (in
addition to version 2.x, in a different Java package).
JBoss EAP includes version 1.9.9 since version 6.1.
Change-Id: I4f003f68e74dadb7ae22a3ba2cd0d561a4f5eedd
Bug-Url: https://bugzilla.redhat.com/1266544
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/dependencies/common/pom.xml
D backend/manager/dependencies/common/src/main/modules/org/codehaus/jackson/jackson-core-asl/main/module.xml
D backend/manager/dependencies/common/src/main/modules/org/codehaus/jackson/jackson-jaxrs/main/module.xml
D backend/manager/dependencies/common/src/main/modules/org/codehaus/jackson/jackson-mapper-asl/main/module.xml
D backend/manager/dependencies/common/src/main/modules/org/codehaus/jackson/jackson-xc/main/module.xml
5 files changed, 0 insertions(+), 134 deletions(-)
Approvals:
Piotr Kliczewski: Passed CI tests
Sandro Bonazzola: Looks good to me, but someone else must approve
Martin Peřina: Looks good to me, approved
Juan Hernandez: Verified; Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/46827
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4f003f68e74dadb7ae22a3ba2cd0d561a4f5eedd
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6.0
Gerrit-Owner: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 6 months
Change in ovirt-hosted-engine-ha[master]: Make sure VDSM had enough time to start before failing
by msivak@redhat.com
Martin Sivák has submitted this change and it was merged.
Change subject: Make sure VDSM had enough time to start before failing
......................................................................
Make sure VDSM had enough time to start before failing
This improves things on two fronts:
- Using After in the systemd unit instructs the init system to
make sure the hosted engine service is started after the vdsm
process, eliminating one race condition.
- Moving the initial ServiceNotUp handling to the _run_agent method
allows us to try multiple times before we fail.
Change-Id: Ie23b110b3018c88656b2119dbeb24d431e922bdf
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1267511
Signed-off-by: Martin Sivak <msivak(a)redhat.com>
---
M initscripts/ovirt-ha-agent.service
M ovirt_hosted_engine_ha/agent/agent.py
M ovirt_hosted_engine_ha/agent/hosted_engine.py
3 files changed, 11 insertions(+), 11 deletions(-)
Approvals:
Martin Sivák: Verified; Looks good to me, approved; Passed CI tests
Simone Tiraboschi: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/46831
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie23b110b3018c88656b2119dbeb24d431e922bdf
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: master
Gerrit-Owner: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 6 months
Change in ovirt-engine[ovirt-engine-3.6.0]: restapi: Fix condition in "IconHelper"
by piotr.kliczewski@gmail.com
Piotr Kliczewski has submitted this change and it was merged.
Change subject: restapi: Fix condition in "IconHelper"
......................................................................
restapi: Fix condition in "IconHelper"
This is needed in order to avoid the following findbugs warning, but it
also looks like a real bug:
Repeated conditional tests
The code contains a conditional test is performed twice, one right
after the other (e.g., x == 0 || x == 0). Perhaps the second
occurrence is intended to be something else (e.g., x == 0 || y == 0).
Bug kind and pattern: RpC - RpC_REPEATED_CONDITIONAL_TEST
Change-Id: I329dc96c77cd91c175fea8cb70580605dc062782
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
Bug-Url: https://bugzilla.redhat.com/1265716
(cherry picked from commit 044b9a131d22496468cbc5e07909d6fbda1bed74)
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/util/IconHelper.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/46830
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I329dc96c77cd91c175fea8cb70580605dc062782
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6.0
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 6 months
Change in ovirt-engine[master]: restapi: Rename "SkipIfSDActive" to "SkipIfSdActive"
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Rename "SkipIfSDActive" to "SkipIfSdActive"
......................................................................
restapi: Rename "SkipIfSDActive" to "SkipIfSdActive"
This is required to make sure that there is only one rule for the names
of complex types: all words, including acronyms, start with one upper
case character and all the rest are lower case.
Change-Id: I28603033528e9e97f4f8e3bff599c2355af2d299
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/README.md
M backend/manager/modules/restapi/interface/definition/src/main/schema/api.xsd
M backend/manager/modules/restapi/types/src/main/java/org/ovirt/engine/api/restapi/types/FencingPolicyMapper.java
3 files changed, 5 insertions(+), 4 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/46822
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I28603033528e9e97f4f8e3bff599c2355af2d299
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 6 months
Change in ovirt-engine[ovirt-engine-3.6.0]: restapi: not possible to edit blank template using REST API
by piotr.kliczewski@gmail.com
Piotr Kliczewski has submitted this change and it was merged.
Change subject: restapi: not possible to edit blank template using REST API
......................................................................
restapi: not possible to edit blank template using REST API
The problem was that when editing the template the cluster version needed
to be loaded. It is not possible to do it in case of Blank template since it is
not attached to the cluster and it's version is always the latest.
Change-Id: I78cd46d8949dfe9eb3d7de207cc8646b7f1060ee
Bug-Url: https://bugzilla.redhat.com/1262287
Signed-off-by: Tomas Jelinek <tjelinek(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/UpdateVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/UpdateVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VmHandler.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendInstanceTypeResource.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendTemplateResource.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendTemplatesResource.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendVmResource.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendVmsResource.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendTemplateResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendTemplatesResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendVmResourceTest.java
M backend/manager/modules/restapi/types/src/main/java/org/ovirt/engine/api/restapi/types/VmMapper.java
M backend/manager/modules/restapi/types/src/test/java/org/ovirt/engine/api/restapi/types/VmMapperTest.java
15 files changed, 48 insertions(+), 225 deletions(-)
Approvals:
Tomas Jelinek: Verified
Martin Peřina: Looks good to me, approved
Juan Hernandez: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/46803
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I78cd46d8949dfe9eb3d7de207cc8646b7f1060ee
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6.0
Gerrit-Owner: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 6 months
Change in ovirt-engine[master]: automation: reducing GWT workers
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: automation: reducing GWT workers
......................................................................
automation: reducing GWT workers
Reducing GWT workers to 1 in order to reduce memory
requirements for building.
Change-Id: I396a357b49194d70349870b62fd56f5f0b2f3b41
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
M automation/build-artifacts.sh
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/46791
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I396a357b49194d70349870b62fd56f5f0b2f3b41
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: David Caro <dcaroest(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Max Kovgan <mvk(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 6 months