Change in ovirt-engine[master]: core: Standardize ConfigureConsoleOptionsQueryTest
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Standardize ConfigureConsoleOptionsQueryTest
......................................................................
core: Standardize ConfigureConsoleOptionsQueryTest
Standardize the test to extend AbstractQueryTest and use its built-in
mocking facilities.
Change-Id: I35f9825a505d50900f6188ce3893e7b3b5549bf0
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/ConfigureConsoleOptionsQueryTest.java
1 file changed, 43 insertions(+), 51 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/66936
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I35f9825a505d50900f6188ce3893e7b3b5549bf0
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 5 months
Change in ovirt-engine[master]: core: rm QueriesCommandBase#getVdsBroker
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: rm QueriesCommandBase#getVdsBroker
......................................................................
core: rm QueriesCommandBase#getVdsBroker
SinceVdsBroker in QueriesCommandBase is injected anyway, and the
getVdsBroker() method is only really used for spying it and returning a
mock object. Since the mocks are now injected by the AbstractQueryTest,
this method is redundant, and should be removed.
Change-Id: I1693d2c210f5378e7bd9b4419915508bbb9f9d0a
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/QueriesCommandBase.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GetAddedGlusterServersQueryTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/domain/GetBlockStorageDomainsWithAttachedStoragePoolGuidQueryTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/domain/GetFileStorageDomainsWithAttachedStoragePoolGuidQueryTest.java
4 files changed, 5 insertions(+), 32 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/66934
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1693d2c210f5378e7bd9b4419915508bbb9f9d0a
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 5 months
Change in ovirt-engine[master]: core: ConfigureConsoleOptionsQueryTest arguments
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ConfigureConsoleOptionsQueryTest arguments
......................................................................
core: ConfigureConsoleOptionsQueryTest arguments
Remove unused arguments from helper methods.
Change-Id: I2c47762fea72c6144e78bfe3c7de55235841c832
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/ConfigureConsoleOptionsQueryTest.java
1 file changed, 7 insertions(+), 7 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/66938
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2c47762fea72c6144e78bfe3c7de55235841c832
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 5 months
Change in ovirt-engine[master]: core: ConfigureConsoleOptionsQueryTest#mockEngineLocalConfig...
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ConfigureConsoleOptionsQueryTest#mockEngineLocalConfigRule
......................................................................
core: ConfigureConsoleOptionsQueryTest#mockEngineLocalConfigRule
Inline the initialization to make the code easier to read and to
maintain.
Change-Id: I15433017426b53864afb5be52d0e825c944f40bd
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/ConfigureConsoleOptionsQueryTest.java
1 file changed, 14 insertions(+), 29 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/66935
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I15433017426b53864afb5be52d0e825c944f40bd
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 5 months
Change in ovirt-engine[master]: core: Standardize IsDisplayAddressConsistentInClusterQueryTest
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Standardize IsDisplayAddressConsistentInClusterQueryTest
......................................................................
core: Standardize IsDisplayAddressConsistentInClusterQueryTest
Standardized the test to use the AbstractUserQueryTest framework.
Change-Id: I312b7ae6f1d0e763fe9b048283ec7b9914c568e4
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/IsDisplayAddressConsistentInClusterQueryTest.java
1 file changed, 7 insertions(+), 17 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/66926
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I312b7ae6f1d0e763fe9b048283ec7b9914c568e4
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 5 months
Change in ovirt-engine[master]: core: IsDisplayAddressConsistentInClusterQuery as a user query
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: IsDisplayAddressConsistentInClusterQuery as a user query
......................................................................
core: IsDisplayAddressConsistentInClusterQuery as a user query
IsDisplayAddressConsistentInClusterQuery's code relies on the
isFiltered() and getUserId() properties of the query parameters. It
seems to be intended as a user query, but is not marked as such.
This patch rectifies that mistake.
Change-Id: Id298f0ccdb17ce3f326c33338cd26d678dcae038
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/queries/VdcQueryType.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/66925
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id298f0ccdb17ce3f326c33338cd26d678dcae038
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 5 months
Change in ovirt-engine[master]: core: IsBalloonEnabledQuery dao accessors
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: IsBalloonEnabledQuery dao accessors
......................................................................
core: IsBalloonEnabledQuery dao accessors
Clean up the redundant DAO accessors and use dependency injection to
inject the relevant DAO to the tested query.
Change-Id: If09d026d233a466fbd8c22d4e51981306ebacab1
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/IsBalloonEnabledQuery.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/IsBalloonEnabledQueryTest.java
2 files changed, 2 insertions(+), 18 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/66924
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If09d026d233a466fbd8c22d4e51981306ebacab1
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 5 months
Change in ovirt-engine[master]: core: @Inject IsClusterEmptyQuery Daos
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: @Inject IsClusterEmptyQuery Daos
......................................................................
core: @Inject IsClusterEmptyQuery Daos
@Inject the DAOs instead of explicitly getting them from DbFacade.
Change-Id: Ib94fd1e4cb69636e26de67e77415c0895f8e3026
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/IsClusterEmptyQuery.java
1 file changed, 6 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/66923
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib94fd1e4cb69636e26de67e77415c0895f8e3026
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 5 months
Change in ovirt-engine[master]: core: @Inject HasAdElementReconnectPermissionQuery Daos
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: @Inject HasAdElementReconnectPermissionQuery Daos
......................................................................
core: @Inject HasAdElementReconnectPermissionQuery Daos
@Inject the DAOs instead of explicitly getting them from DbFacade.
Change-Id: I5351a4e0df9fd56988eb95cf550318b4f5d96d8c
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/HasAdElementReconnectPermissionQuery.java
1 file changed, 7 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/66922
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5351a4e0df9fd56988eb95cf550318b4f5d96d8c
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 5 months
Change in ovirt-engine[master]: core: @Inject GetWatchdogQuery Daos
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: @Inject GetWatchdogQuery Daos
......................................................................
core: @Inject GetWatchdogQuery Daos
@Inject the DAOs instead of explicitly getting them from DbFacade.
Change-Id: I9b78d290360c50291b13c3c89434ed71ac93ae46
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetWatchdogQuery.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/GetWatchdogQueryTest.java
2 files changed, 5 insertions(+), 7 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/66921
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9b78d290360c50291b13c3c89434ed71ac93ae46
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 5 months