Change in ovirt-engine[master]: engine: Test host connectivity after upgrade
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Test host connectivity after upgrade
......................................................................
engine: Test host connectivity after upgrade
After host upgrade, the VDSM service is restarted. The engine should
attempt to connect to the host before passing the responsibilty back
to the host monitoring to prevent unwanted monitoring connectivity
errors which might result in moving the host to non-reponsive state.
Change-Id: I30e81a0d338201de01d4a58dd0168ff6a2633119
Bug-Url: https://bugzilla.redhat.com/1382691
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/host/HostConnectivityChecker.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/hostdeploy/UpgradeHostInternalCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/NetworkConfigurator.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/PollVDSCommand.java
4 files changed, 52 insertions(+), 18 deletions(-)
Approvals:
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/67432
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I30e81a0d338201de01d4a58dd0168ff6a2633119
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: engine: Add support for arbiter gluster volumes
by Code Review
>From Sahina Bose <sabose(a)redhat.com>:
Sahina Bose has submitted this change and it was merged.
Change subject: engine: Add support for arbiter gluster volumes
......................................................................
engine: Add support for arbiter gluster volumes
Add Arbiter support for gluster volumes in BLL
and VDS Commands. Arbiter count will be specified while
creating the volume. Arbiter volume should be a replica 3
volume and every thrid brick in the brick list will be
used as an arbiter brick.
Change-Id: I00313364e4254dae94608e9e3617a357cbb19438
Signed-off-by: Ramesh Nachimuthu <rnachimu(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/CreateGlusterVolumeCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/CreateGlusterVolumeCommandTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/config/ConfigValues.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/EngineMessage.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/gluster/GlusterFeatureSupported.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/gluster/CreateGlusterVolumeVDSCommand.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/gluster/GlusterVolumesListReturnForXmlRpc.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/jsonrpc/JsonRpcVdsServer.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/IVdsServer.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsServerConnector.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsServerWrapper.java
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/frontend/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M packaging/dbscripts/upgrade/pre_upgrade/0000_config.sql
17 files changed, 127 insertions(+), 19 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Sahina Bose: Looks good to me, approved
Moti Asayag: Looks good to me, but someone else must approve
Ramesh N: Verified
--
To view, visit https://gerrit.ovirt.org/52539
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I00313364e4254dae94608e9e3617a357cbb19438
Gerrit-PatchSet: 12
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ramesh N <rnachimu(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Jenkins CI RO
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Ramesh N <rnachimu(a)redhat.com>
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[ovirt-engine-4.0]: engine: Report upgrade packages list only when relevant
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: engine: Report upgrade packages list only when relevant
......................................................................
engine: Report upgrade packages list only when relevant
There are cases in which the reported list of packages available for
updates is differ than the queried list of packages.
Since the user is interested the preconfigured packages for query, the
reported list should include the list of packages only when available
and log a general message without the packages otherwise.
Change-Id: I54f3bcd68abc0d9356f0e330a10978d629c7662c
Bug-Url: https://bugzilla.redhat.com/1381419
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/host/HostUpgradeManager.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/host/OvirtNodeUpgradeManager.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/AuditLogType.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/VdcEventNotificationUtils.java
M backend/manager/modules/dal/src/main/resources/bundles/AuditLogMessages.properties
5 files changed, 13 insertions(+), 8 deletions(-)
Approvals:
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/67408
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I54f3bcd68abc0d9356f0e330a10978d629c7662c
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.0
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[ovirt-engine-4.0.6]: restapi: Fix typo in disk attachments link
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: restapi: Fix typo in disk attachments link
......................................................................
restapi: Fix typo in disk attachments link
This patch fixes a typo in the link of the storage domain VM disk
attachments link.
Change-Id: I8b4cde77067d8bc89fb354440a316234b5f6ba08
Bug-Url: https://bugzilla.redhat.com/1383264
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendStorageDomainVmsResource.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/67431
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8b4cde77067d8bc89fb354440a316234b5f6ba08
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.0.6
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: core: Implement equals for PermissionSubject
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Implement equals for PermissionSubject
......................................................................
core: Implement equals for PermissionSubject
Change-Id: Ib86525a9320843723bb9c28d83fd0135e334fb1b
Signed-off-by: Amit Aviram <aaviram(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/utils/PermissionSubject.java
1 file changed, 21 insertions(+), 0 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Amit Aviram: Verified
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/67226
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib86525a9320843723bb9c28d83fd0135e334fb1b
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: imagetransfer: Expand permission checks for transfers.
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: imagetransfer: Expand permission checks for transfers.
......................................................................
imagetransfer: Expand permission checks for transfers.
Currently, a permission check is being made only on the related storage domain.
This patch adds a permission check for the specific disk, in case it was
provided.
Change-Id: Ibf28a9887dc2c01810490fd1b81f45930094a7fb
Signed-off-by: Amit Aviram <aaviram(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/image/TransferDiskImageCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/disk/image/TransferDiskImageCommandTest.java
2 files changed, 29 insertions(+), 2 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Amit Aviram: Verified
Allon Mureinik: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/67176
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibf28a9887dc2c01810490fd1b81f45930094a7fb
Gerrit-PatchSet: 13
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: imagetransfer: isImageProvided() method addition.
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: imagetransfer: isImageProvided() method addition.
......................................................................
imagetransfer: isImageProvided() method addition.
Add isImageProvided() to improve readability, making the code easier to
understand and maintain.
Change-Id: I1ef7263da324b0a5f84948c73ebc8ac7f0342df1
Signed-off-by: Amit Aviram <aaviram(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/image/TransferImageCommand.java
1 file changed, 8 insertions(+), 5 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Amit Aviram: Verified
Allon Mureinik: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/67175
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1ef7263da324b0a5f84948c73ebc8ac7f0342df1
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in gerrit-admin[master]: Fix Bug Url match
by Code Review
>From Shlomo Ben David <sbendavi(a)redhat.com>:
Shlomo Ben David has submitted this change and it was merged.
Change subject: Fix Bug Url match
......................................................................
Fix Bug Url match
Currently the check_bug_url checks only urls in the following format:
http://bugzilla.redhat.com/<bug-id>
This patch is fixing that and allows to catch urls with this format as well:
http://bugzilla.redhat.com/show_bug.cgi?id=<bug-id>
Change-Id: I9ca005de77c30e8860a5d7fd52fdd932ddac9afe
Fixes: OVIRT-843
Signed-off-by: Shlomi Ben-David <sbendavi(a)redhat.com>
---
M hooks/custom_hooks/check_bug_url
M hooks/lib/bz.py
2 files changed, 3 insertions(+), 2 deletions(-)
Approvals:
Shlomo Ben David: Verified; Looks good to me, approved
Gil Shinar: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/67127
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9ca005de77c30e8860a5d7fd52fdd932ddac9afe
Gerrit-PatchSet: 1
Gerrit-Project: gerrit-admin
Gerrit-Branch: master
Gerrit-Owner: Shlomo Ben David <sbendavi(a)redhat.com>
Gerrit-Reviewer: Eyal Edri <eedri(a)redhat.com>
Gerrit-Reviewer: Gil Shinar <gshinar(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shlomo Ben David <sbendavi(a)redhat.com>
8 years, 4 months
Change in ovirt-hosted-engine-setup[master]: rollback: correctly evaluate the space on the VM disk
by Code Review
>From Simone Tiraboschi <stirabos(a)redhat.com>:
Simone Tiraboschi has submitted this change and it was merged.
Change subject: rollback: correctly evaluate the space on the VM disk
......................................................................
rollback: correctly evaluate the space on the VM disk
Evaluate the real maximum space on the VM disk using the capacity
attribute instead of the apparentsize one.
Change-Id: Ie33d7d29790011077e485904949917a04763558c
Bug-Url: https://bugzilla.redhat.com/1397810
Signed-off-by: Simone Tiraboschi <stirabos(a)redhat.com>
---
M src/plugins/gr-he-rollbackupgrade/core/misc.py
1 file changed, 3 insertions(+), 3 deletions(-)
Approvals:
Simone Tiraboschi: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
Rafael Martins: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/67220
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie33d7d29790011077e485904949917a04763558c
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-hosted-engine-setup
Gerrit-Branch: master
Gerrit-Owner: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Rafael Martins <rmartins(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: restapi: Add ticket action to vm graphics console
by Code Review
>From Juan Hernandez <juan.hernandez(a)redhat.com>:
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Add ticket action to vm graphics console
......................................................................
restapi: Add ticket action to vm graphics console
Previously it was only possible to request console ticket at the VM level which
in cases of SPICE+VNC automatically preferred SPICE thereby preventing the user
from requesting a VNC ticket.
Now also the per-graphics-console
/vms/{vm_id}/graphicsconsoles/{console_id}/ticket action is supported when user
wants to explicitly decide which console to use.
The logic in BackendVmResource was moved to BackendVmGraphicsConsoleResource
and the vm resource now (based on the same logic as before) delegates to the
appropriate graphics console subresource.
Change-Id: I5999171cf4f9d0609f258d329efd1240974aa815
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1383342
Signed-off-by: Martin Betak <mbetak(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendGraphicsConsoleHelper.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendVmGraphicsConsoleResource.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendVmResource.java
A backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendGraphicsConsoleHelperTest.java
4 files changed, 106 insertions(+), 51 deletions(-)
Approvals:
Tomas Jelinek: Looks good to me, but someone else must approve
Ondra Machacek: Looks good to me, but someone else must approve
Juan Hernandez: Looks good to me, approved
Jenkins CI: Passed CI tests
Martin Betak: Verified
--
To view, visit https://gerrit.ovirt.org/67174
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5999171cf4f9d0609f258d329efd1240974aa815
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Jakub Niedermertl <jniederm(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Ondra Machacek <omachace(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months