Change in ovirt-engine[master]: core: Fix formatting in JsonRpcUtils
by mperina@redhat.com
Martin Peřina has submitted this change and it was merged.
Change subject: core: Fix formatting in JsonRpcUtils
......................................................................
core: Fix formatting in JsonRpcUtils
Fixes formatting issues introduced in patch
Ic423322de3f1e0d1862d147a3b529f5c047d8b02.
Change-Id: I11bb03986dc94fc5e5a9b4df01d7699e49cd4532
Bug-Url: https://bugzilla.redhat.com/1317248
Signed-off-by: Martin Perina <mperina(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/jsonrpc/JsonRpcUtils.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Piotr Kliczewski: Looks good to me, but someone else must approve
Martin Peřina: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
Eldad Marciano: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/55521
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I11bb03986dc94fc5e5a9b4df01d7699e49cd4532
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Eldad Marciano <emarcian(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-engine[master]: webadmin: AsyncDataProvider#isCommandCompatible default
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: AsyncDataProvider#isCommandCompatible default
......................................................................
webadmin: AsyncDataProvider#isCommandCompatible default
If a command is not present in the action version map, it's assumed to
be supported for any DC/cluster level, and thus shouldn't even be
checked by this method.
However, as an infrastructure, this method cannot assume it will be used
correctly, and needs to return the proper default (true) if used
improperly in this way.
Change-Id: Ifdf1d75f59f2eec353c4a7f879994ca2fddba42e
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/dataprovider/AsyncDataProvider.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, but someone else must approve
Daniel Erez: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55368
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifdf1d75f59f2eec353c4a7f879994ca2fddba42e
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[ovirt-engine-3.6]: packaging: spec: remove %license call
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: packaging: spec: remove %license call
......................................................................
packaging: spec: remove %license call
Change-Id: If543c9f32371d8da62d5f0a3a0be09ffdce2df4a
Signed-off-by: Rafael Martins <rmartins(a)redhat.com>
---
M ovirt-engine.spec.in
1 file changed, 0 insertions(+), 1 deletion(-)
Approvals:
Sandro Bonazzola: Looks good to me, approved
Anton Marchukov: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55539
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If543c9f32371d8da62d5f0a3a0be09ffdce2df4a
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Rafael Martins <rmartins(a)redhat.com>
Gerrit-Reviewer: Anton Marchukov <amarchuk(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
8 years, 9 months
Change in ovirt-engine[ovirt-engine-3.6]: construct jsonrpc with identifier name.
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: construct jsonrpc with identifier name.
......................................................................
construct jsonrpc with identifier name.
this patch help to identifiy host by http connect header,
in order to support multiple access for same ip address,
specially for vdsmfake.
moving to use setter and getter instead of constrctors.
adding ConfigValue in order to control this.
deafualt is false.
update db configuratoin.
this patch depndes on https://gerrit.ovirt.org/#/c/39835/
Bug-Url: https://bugzilla.redhat.com/1317248
Change-Id: Ic423322de3f1e0d1862d147a3b529f5c047d8b02
Signed-off-by: emarcian <emarcian(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/config/ConfigValues.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/jsonrpc/JsonRpcUtils.java
M packaging/dbscripts/upgrade/pre_upgrade/0000_config.sql
3 files changed, 24 insertions(+), 0 deletions(-)
Approvals:
Piotr Kliczewski: Looks good to me, but someone else must approve
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
Eldad Marciano: Verified
--
To view, visit https://gerrit.ovirt.org/55502
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic423322de3f1e0d1862d147a3b529f5c047d8b02
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Eldad Marciano <emarcian(a)redhat.com>
Gerrit-Reviewer: Eldad Marciano <emarcian(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: webadmin: VmSnaphotListModel: Cloning supported
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: VmSnaphotListModel: Cloning supported
......................................................................
webadmin: VmSnaphotListModel: Cloning supported
Since the engine only supports DCs of compatibility version of 3.5 and
above, cloning a VM from a sanpshot should always be supported, and
there's no need to check it.
Change-Id: I3033a797bd0690f484162c81536b1f851792b958
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/CommonApplicationMessages.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/vm/VmSnapshotListModelTable.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmSnapshotListModel.java
3 files changed, 1 insertion(+), 73 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55367
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3033a797bd0690f484162c81536b1f851792b958
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: frontend: Fix Run Once Boot Menu checkbox on Firefox
by mbetak@redhat.com
Martin Betak has submitted this change and it was merged.
Change subject: frontend: Fix Run Once Boot Menu checkbox on Firefox
......................................................................
frontend: Fix Run Once Boot Menu checkbox on Firefox
Fixed checkbox style caused by longer label.
Change-Id: I00f214b74137edba4125e33cb969c7f821f76bd3
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1054070
Signed-off-by: Martin Betak <mbetak(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/vm/VmRunOncePopupWidget.ui.xml
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Jakub Niedermertl: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Martin Betak: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/55532
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I00f214b74137edba4125e33cb969c7f821f76bd3
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Jakub Niedermertl <jniederm(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: fix updateVmRunTimeInfo
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: fix updateVmRunTimeInfo
......................................................................
core: fix updateVmRunTimeInfo
1. Rename VmAnalyzer#updateVmRunTimeInfo to updateVmDynamicData
as it updates the runtime information in VmDynamic part of the VM.
2. Extract the code that fetches the VM from the DB (it might be
that the VM is not running on the monitored host but exists in
the DB) as it should not be part of this method.
3. Set the dynamic data to save in this method as it should be
part of its responsibility and change the method to be void.
Change-Id: I792b1467c011abade985fce6ba1d618903ef5804
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/monitoring/VmAnalyzer.java
1 file changed, 17 insertions(+), 22 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Jenkins CI: Passed CI tests
Arik Hadas: Verified
--
To view, visit https://gerrit.ovirt.org/55498
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I792b1467c011abade985fce6ba1d618903ef5804
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: restapi: Adding external network import
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Adding external network import
......................................................................
restapi: Adding external network import
Adding the ability to import external networks from a provider
This patch is related to the ovirt-engine-api-models patch:
https://gerrit.ovirt.org/54782
Change-Id: I0212b809b988a1b49837415fbe4d4776ca9a945e
Signed-off-by: mirecki <mmirecki(a)redhat.com>
Bug-Url: https://bugzilla.redhat.com/1317581
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/openstack/BackendOpenStackNetworkResource.java
1 file changed, 87 insertions(+), 32 deletions(-)
Approvals:
Juan Hernandez: Looks good to me, approved
Marcin Mirecki: Verified
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/54784
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0212b809b988a1b49837415fbe4d4776ca9a945e
Gerrit-PatchSet: 10
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Marcin Mirecki <mmirecki(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Marcin Mirecki <mmirecki(a)redhat.com>
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Revert "core: removing ChildCommandsCallbackBase"
by laravot@redhat.com
Liron Aravot has submitted this change and it was merged.
Change subject: core: Revert "core: removing ChildCommandsCallbackBase"
......................................................................
core: Revert "core: removing ChildCommandsCallbackBase"
This reverts commit 53306594d2ec4b2a64a816df198bacd195fcb94b.
The reverted commit added a bug in SerialChildCommandsExecutionCallback, the command
end status is set even if more commands are executed in performNextOperation() which
is wrong.
This patch reverts the change, if we'll want it can be pushed again with applied fix.
Change-Id: I996a7cd8c9cbad2fc8608779db73bb6ca30271b3
Signed-off-by: Liron Aravot <laravot(a)redhat.com>
---
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ChildCommandsCallbackBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ConcurrentChildCommandsExecutionCallback.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/SerialChildCommandsExecutionCallback.java
3 files changed, 164 insertions(+), 142 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Liron Aravot: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/55475
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I996a7cd8c9cbad2fc8608779db73bb6ca30271b3
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[ovirt-engine-3.6.5]: core: adding support for ilo_ssh fence agent
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: adding support for ilo_ssh fence agent
......................................................................
core: adding support for ilo_ssh fence agent
This patch adds support for ilo_ssh fence agent.
Change-Id: I110a444f1f25fbbac0ca9a1d13aa80db376506bf
Bug-Url: https://bugzilla.redhat.com/1316583
Signed-off-by: emesika <emesika(a)redhat.com>
Signed-off-by: Martin Perina <mperina(a)redhat.com>
---
M packaging/dbscripts/upgrade/pre_upgrade/0000_config.sql
1 file changed, 5 insertions(+), 4 deletions(-)
Approvals:
Martin Peřina: Verified
Eli Mesika: Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55481
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I110a444f1f25fbbac0ca9a1d13aa80db376506bf
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6.5
Gerrit-Owner: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months