Change in ovirt-engine[master]: core: Unify VM lease validation in update and add VM commands
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: Unify VM lease validation in update and add VM commands
......................................................................
core: Unify VM lease validation in update and add VM commands
Change-Id: Iff190d39b2b5916ff618f70024e1e08c7b4737ed
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
Bug-Url: https://bugzilla.redhat.com/1453163
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/UpdateVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VmManagementCommandBase.java
3 files changed, 14 insertions(+), 20 deletions(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/78015
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iff190d39b2b5916ff618f70024e1e08c7b4737ed
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Benny Zlotnik <bzlotnik(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shani Leviim <sleviim(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-engine[ovirt-engine-4.1]: branding: Rename ovirt-web-ui to "VM Portal"
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: branding: Rename ovirt-web-ui to "VM Portal"
......................................................................
branding: Rename ovirt-web-ui to "VM Portal"
Change-Id: I07ab5939b3e2f73066ff99bb662a58017f0d9236
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1456568
Signed-off-by: Marek Libra <mlibra(a)redhat.com>
---
M packaging/branding/ovirt.brand/messages.properties
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tomas Jelinek: Looks good to me, approved
Jenkins CI: Passed CI tests
Marek Libra: Verified
Michal Skrivanek: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/78315
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I07ab5939b3e2f73066ff99bb662a58017f0d9236
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Marek Libra <mlibra(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Marek Libra <mlibra(a)redhat.com>
Gerrit-Reviewer: Michal Skrivanek <michal.skrivanek(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-engine[master]: core: monitoring vm devices using the domain xml
by Code Review
>From Arik Hadas <ahadas(a)redhat.com>:
Arik Hadas has submitted this change and it was merged.
Change subject: core: monitoring vm devices using the domain xml
......................................................................
core: monitoring vm devices using the domain xml
The monitoring of vm devices can now be done according to libvirt's
domain xml rather than the dictionary we used to get from VDSM.
However, in order to minimize the changes in vm devices monitoring,
we convert the devices in the domain xml into VDSM-like maps that
contain the relevant data, but this is done on the engine side.
Note that the DomainXML config value still defaults to false, so
we still call FullList by default (this is going to be changed
separately, once the monitoring of host devices is added).
Change-Id: I04e03e1137567ff8a14c2b07b1e8f02d1a832b8c
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
A backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/libvirt/VmDevicesConverter.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/monitoring/VmDevicesMonitoring.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/DumpXmlsVDSCommand.java
M backend/manager/modules/vdsbroker/src/test/java/org/ovirt/engine/core/vdsbroker/monitoring/VmDevicesMonitoringTest.java
4 files changed, 540 insertions(+), 10 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Shmuel Leib Melamud: Looks good to me, but someone else must approve
Arik Hadas: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/70018
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I04e03e1137567ff8a14c2b07b1e8f02d1a832b8c
Gerrit-PatchSet: 33
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Francesco Romani <fromani(a)redhat.com>
Gerrit-Reviewer: Jakub Niedermertl <jniederm(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Milan Zamazal <mzamazal(a)redhat.com>
Gerrit-Reviewer: Sharon Gratch <sgratch(a)redhat.com>
Gerrit-Reviewer: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-engine-sdk-ruby[sdk_4.1]: Changing 'bundler' executable instead of 'bundle'.
by Code Review
>From Juan Hernandez <juan.hernandez(a)redhat.com>:
Juan Hernandez has submitted this change and it was merged.
Change subject: Changing 'bundler' executable instead of 'bundle'.
......................................................................
Changing 'bundler' executable instead of 'bundle'.
Because if you have go bundle installed and have it in your PATH,
running 'mvn package' will fail.
Change-Id: Iebd6446b5f3117d6812a7d259736abdf8afd354e
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1462664
Signed-off-by: Aleksei Slaikovskii <aslaikov(a)redhat.com>
(cherry picked from commit d2aaad22495a34e173b1f4145a4b43c456b496d3)
---
M sdk/pom.xml
1 file changed, 4 insertions(+), 4 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/78317
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iebd6446b5f3117d6812a7d259736abdf8afd354e
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine-sdk-ruby
Gerrit-Branch: sdk_4.1
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Aleksei Slaikovskii <aslaikov(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-engine-sdk-ruby[master]: Changing 'bundler' executable instead of 'bundle'.
by Code Review
>From Juan Hernandez <juan.hernandez(a)redhat.com>:
Juan Hernandez has submitted this change and it was merged.
Change subject: Changing 'bundler' executable instead of 'bundle'.
......................................................................
Changing 'bundler' executable instead of 'bundle'.
Because if you have go bundle installed and have it in your PATH,
running 'mvn package' will fail.
Change-Id: Iebd6446b5f3117d6812a7d259736abdf8afd354e
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1462664
Signed-off-by: Aleksei Slaikovskii <aslaikov(a)redhat.com>
---
M sdk/pom.xml
1 file changed, 4 insertions(+), 4 deletions(-)
Approvals:
Juan Hernandez: Looks good to me, approved
Aleksei Slaikovskii: Verified
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/78286
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iebd6446b5f3117d6812a7d259736abdf8afd354e
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine-sdk-ruby
Gerrit-Branch: master
Gerrit-Owner: Aleksei Slaikovskii <aslaikov(a)redhat.com>
Gerrit-Reviewer: Aleksei Slaikovskii <aslaikov(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in jenkins[master]: ovirt-engine-metrics: add build-on-demand job
by Code Review
>From Gil Shinar <gshinar(a)redhat.com>:
Gil Shinar has submitted this change and it was merged.
Change subject: ovirt-engine-metrics: add build-on-demand job
......................................................................
ovirt-engine-metrics: add build-on-demand job
Change-Id: Ic1a48ce2a163c96da246ff6884abb5c658b0187e
Signed-off-by: Shirly Radco <sradco(a)redhat.com>
---
M jobs/confs/projects/ovirt-engine-metrics/ovirt-engine-metrics_build-artifacts.yaml
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Gil Shinar: Verified; Looks good to me, approved; Passed CI tests; Ready for merge
--
To view, visit https://gerrit.ovirt.org/78310
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic1a48ce2a163c96da246ff6884abb5c658b0187e
Gerrit-PatchSet: 2
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Eyal Edri <eedri(a)redhat.com>
Gerrit-Reviewer: Gil Shinar <gshinar(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
7 years, 5 months
Change in ovirt-hosted-engine-setup[master]: packaging: setup: require ovirt-host
by Code Review
>From Sandro Bonazzola <sbonazzo(a)redhat.com>:
Sandro Bonazzola has submitted this change and it was merged.
Change subject: packaging: setup: require ovirt-host
......................................................................
packaging: setup: require ovirt-host
Require ovirt-host instead of single dependencies
already required by ovirt-host.
Bug-Url: https://bugzilla.redhat.com/1461083
Change-Id: I578393fef8e95d9c3aa9c50f6e1965431c3ed65a
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
M ovirt-hosted-engine-setup.spec.in
1 file changed, 4 insertions(+), 28 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/78302
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I578393fef8e95d9c3aa9c50f6e1965431c3ed65a
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-setup
Gerrit-Branch: master
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Ido Rosenzwig <irosenzw(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Rafael Martins <rafael(a)rafaelmartins.eng.br>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-engine[master]: webadmin: Include ActionUtils in common.gwt.xml
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Include ActionUtils in common.gwt.xml
......................................................................
webadmin: Include ActionUtils in common.gwt.xml
The class VdcActionUtils name was changed to ActionUtils and this should
be reflected in common.gwt.xml
Change-Id: I76b778b1fa06edea672fd17485cdea2036adb87b
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/resources/org/ovirt/engine/core/Common.gwt.xml
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved; Passed CI tests
Freddy Rolland: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/78301
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I76b778b1fa06edea672fd17485cdea2036adb87b
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-log-collector[master]: inventory: specify it's async tasks in Engine
by Code Review
>From Douglas Schilling Landgraf <dougsland(a)redhat.com>:
Douglas Schilling Landgraf has submitted this change and it was merged.
Change subject: inventory: specify it's async tasks in Engine
......................................................................
inventory: specify it's async tasks in Engine
Change-Id: I4745d509770698ff5b1efc27fa5ac3b3fa79f508
Signed-off-by: Douglas Schilling Landgraf <dougsland(a)redhat.com>
---
M src/inventory_report/produceReport/pre-upgrade-checks
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Douglas Schilling Landgraf: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/78299
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4745d509770698ff5b1efc27fa5ac3b3fa79f508
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-log-collector
Gerrit-Branch: master
Gerrit-Owner: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-log-collector[master]: inventory: Check for running commands
by Code Review
>From Douglas Schilling Landgraf <dougsland(a)redhat.com>:
Douglas Schilling Landgraf has submitted this change and it was merged.
Change subject: inventory: Check for running commands
......................................................................
inventory: Check for running commands
Before upgrade engine let's check if there are commands
still running.
Change-Id: I38456cde17d5606d5ea55ccf0859600424f09f76
Signed-off-by: Douglas Schilling Landgraf <dougsland(a)redhat.com>
---
M src/inventory_report/Makefile.am
M src/inventory_report/produceReport/pre-upgrade-checks
M src/inventory_report/produceReport/produceReport.sh
A src/inventory_report/produceReport/sqls/command_entities_query_get_running_commands.sql
4 files changed, 44 insertions(+), 0 deletions(-)
Approvals:
Douglas Schilling Landgraf: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/78258
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I38456cde17d5606d5ea55ccf0859600424f09f76
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-log-collector
Gerrit-Branch: master
Gerrit-Owner: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months