Change in ovirt-engine[master]: core: Remove failure reasons from EngineLock#toString
by Code Review
>From Martin Peřina <mperina(a)redhat.com>:
Martin Peřina has submitted this change and it was merged.
Change subject: core: Remove failure reasons from EngineLock#toString
......................................................................
core: Remove failure reasons from EngineLock#toString
EngineLock#toString prints the validation failure that should be used
if the lock cannot be acquired. This leads to INFO messages about
successful lock acquisitions to seem, at first glance, as error
messages, which is confusing (see, e.g., the attached bug).
This patch suggests improving the logs by NOT printing the validation
messages, which will only be printed (and only be useful) if the
engine fails to acquire the lock.
Change-Id: I6ffc9107f67ffe5896e1a61b5a4511b83168c26e
Bug-Url: https://bugzilla.redhat.com/1454843
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/lock/EngineLock.java
1 file changed, 13 insertions(+), 2 deletions(-)
Approvals:
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/78054
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6ffc9107f67ffe5896e1a61b5a4511b83168c26e
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-engine[master]: core: avoid log flood on pause image upload
by Code Review
>From Daniel Erez <derez(a)redhat.com>:
Daniel Erez has submitted this change and it was merged.
Change subject: core: avoid log flood on pause image upload
......................................................................
core: avoid log flood on pause image upload
When pausing image upload, the upload command is left running
for supporting upload resume. I.e. the command is being constantly
polled by CoCo. To avoid a redundant operation and log [1] on each poll,
ensured 'stopImageTransferSession' method invocation only once.
[1] WARN org.ovirt.engine.core.bll.storage.disk.image.UploadDiskImageCommand
Failed to stop image transfer session. Ticket does not exist for image ...
Change-Id: I28c8fff263278bc0ae6c6bd222685ca1a750fee6
Bug-Url: https://bugzilla.redhat.com/1402048
Signed-off-by: Daniel Erez <derez(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/image/TransferImageCommand.java
1 file changed, 3 insertions(+), 1 deletion(-)
Approvals:
Jenkins CI: Passed CI tests
Daniel Erez: Verified
Allon Mureinik: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/78084
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I28c8fff263278bc0ae6c6bd222685ca1a750fee6
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in jenkins[master]: ovirt-host: add automation
by Code Review
>From Sandro Bonazzola <sbonazzo(a)redhat.com>:
Sandro Bonazzola has submitted this change and it was merged.
Change subject: ovirt-host: add automation
......................................................................
ovirt-host: add automation
Change-Id: I3afbb8e02e5814ab7d6d185f45e6a6a5169b5c2d
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
A jobs/confs/projects/ovirt-host/ovirt-host_standard.yaml
A jobs/confs/yaml/scms/ovirt-host.yaml
2 files changed, 52 insertions(+), 0 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved; Ready for merge
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/78091
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3afbb8e02e5814ab7d6d185f45e6a6a5169b5c2d
Gerrit-PatchSet: 1
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Anton Marchukov <amarchuk(a)redhat.com>
Gerrit-Reviewer: Barak Korren <bkorren(a)redhat.com>
Gerrit-Reviewer: Daniel Belenky <dbelenky(a)redhat.com>
Gerrit-Reviewer: Evgheni Dereveanchin <ederevea(a)redhat.com>
Gerrit-Reviewer: Eyal Edri <eedri(a)redhat.com>
Gerrit-Reviewer: Gil Shinar <gshinar(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Nadav Goldin <ngoldin(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Shlomo Ben David <sbendavi(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
7 years, 5 months
Change in ovirt-engine[master]: rpc: trigger soft fencing when we fail to run commands
by Code Review
>From Martin Peřina <mperina(a)redhat.com>:
Martin Peřina has submitted this change and it was merged.
Change subject: rpc: trigger soft fencing when we fail to run commands
......................................................................
rpc: trigger soft fencing when we fail to run commands
When we fail to run commands due to thread pool being full we want to
throw network exception which would trigger soft fencing.
Bug-Url: https://bugzilla.redhat.com/1433380
Change-Id: I766dc8be3a3e11e50515bcb1792c3b3ca7864516
Signed-off-by: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/EngineError.java
M backend/manager/modules/dal/src/main/resources/bundles/VdsmErrors.properties
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/BrokerCommandBase.java
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/VdsmErrors.java
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/VdsmErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/VdsmErrors.properties
6 files changed, 9 insertions(+), 0 deletions(-)
Approvals:
Piotr Kliczewski: Verified
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/74006
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I766dc8be3a3e11e50515bcb1792c3b3ca7864516
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Nir Soffer <nsoffer(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-engine[master]: webadmin: Call UpdateOvfStoreForStorageDomain from webadmin
by Code Review
>From Maor Lipchuk <mlipchuk(a)redhat.com>:
Maor Lipchuk has submitted this change and it was merged.
Change subject: webadmin: Call UpdateOvfStoreForStorageDomain from webadmin
......................................................................
webadmin: Call UpdateOvfStoreForStorageDomain from webadmin
Once OVF_STORE is being updated manually from the REST the proper
command that should be called is UpdateOvfStoreForStorageDomain.
That way ProcessOvfUpdateForStoragePool will be called also and
vm_ovf_generations will be synced with the OVF data of the entities
before the OVF_STORE disk will be updated.
Change-Id: Ic05a4b75b0b07637dc2e64f198e4ad320efb4f2f
Bug-Url: https://bugzilla.redhat.com/1403581
Bug-Url: https://bugzilla.redhat.com/1404607
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageListModel.java
1 file changed, 2 insertions(+), 5 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Daniel Erez: Looks good to me, approved
Allon Mureinik: Looks good to me, but someone else must approve
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/76907
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic05a4b75b0b07637dc2e64f198e4ad320efb4f2f
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-engine[master]: core: Print success audit log when action ends with success
by Code Review
>From Maor Lipchuk <mlipchuk(a)redhat.com>:
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Print success audit log when action ends with success
......................................................................
core: Print success audit log when action ends with success
An event indicating that the OVF STORE was updated successfully
should be printed only when command finishes with success.
Change-Id: Iedeb8479dc93d5fa7abe9f2652fa8ef660e8aa58
Bug-Url: https://bugzilla.redhat.com/1403581
Bug-Url: https://bugzilla.redhat.com/1404607
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/ovfstore/ProcessOvfUpdateForStorageDomainCommand.java
1 file changed, 3 insertions(+), 5 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Daniel Erez: Looks good to me, approved
Allon Mureinik: Looks good to me, but someone else must approve
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/75608
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iedeb8479dc93d5fa7abe9f2652fa8ef660e8aa58
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-engine[master]: core: refactor OVF_STORE update on deactivate
by Code Review
>From Maor Lipchuk <mlipchuk(a)redhat.com>:
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: refactor OVF_STORE update on deactivate
......................................................................
core: refactor OVF_STORE update on deactivate
Move the logic which updates the OVF_STORE of a deactivated storage
domain to a new command.
The new command is UpdateOvfStoreForStorageDomainCommand which
responsible to update the OVF_STORE disk for a storage domain.
Change-Id: I1858b60b2247f347dc80c8120d5318f147da1192
Bug-Url: https://bugzilla.redhat.com/1403581
Bug-Url: https://bugzilla.redhat.com/1404607
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/DeactivateStorageDomainWithOvfUpdateCommand.java
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/UpdateOvfStoreForStorageDomainCommand.java
A backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/domain/UpdateOvfStoreForStorageDomainCommandTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/VdcActionType.java
4 files changed, 144 insertions(+), 13 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Daniel Erez: Looks good to me, approved
Allon Mureinik: Looks good to me, but someone else must approve
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/76906
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1858b60b2247f347dc80c8120d5318f147da1192
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-engine[master]: core:Remove redundant parameter class.
by Code Review
>From Maor Lipchuk <mlipchuk(a)redhat.com>:
Maor Lipchuk has submitted this change and it was merged.
Change subject: core:Remove redundant parameter class.
......................................................................
core:Remove redundant parameter class.
There is no use with updateStorage boolean flag in
ProcessOvfUpdateForStoragePoolParameters therefore there is no
reason to keep it as a parameter class so removing it
and instead use StoragePoolParametersBase.
Change-Id: Ifc2ec1c7a24c8d7aa61bda84b346c16bc83c1da7
Bug-Url: https://bugzilla.redhat.com/1403581
Bug-Url: https://bugzilla.redhat.com/1404607
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/DeactivateStorageDomainWithOvfUpdateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/ovfstore/OvfDataUpdater.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/ovfstore/ProcessOvfUpdateForStoragePoolCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/ovfstore/ProcessOvfUpdateForStoragePoolCommandTest.java
D backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/ProcessOvfUpdateForStoragePoolParameters.java
5 files changed, 9 insertions(+), 35 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, approved
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/78053
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifc2ec1c7a24c8d7aa61bda84b346c16bc83c1da7
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-engine[master]: restapi: Call UpdateOvfStoreForStorageDomain from REST
by Code Review
>From Maor Lipchuk <mlipchuk(a)redhat.com>:
Maor Lipchuk has submitted this change and it was merged.
Change subject: restapi: Call UpdateOvfStoreForStorageDomain from REST
......................................................................
restapi: Call UpdateOvfStoreForStorageDomain from REST
Once OVF_STORE is being updated manually from the REST the proper
command that should be called is UpdateOvfStoreForStorageDomain.
That way ProcessOvfUpdateForStoragePool will be called also and
vm_ovf_generations will be synced with the OVF data of the entities
before the OVF_STORE disk will be updated.
Change-Id: I0166b65494c78a5559f9c7b701d0742d8e58148d
Bug-Url: https://bugzilla.redhat.com/1403581
Bug-Url: https://bugzilla.redhat.com/1404607
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendStorageDomainResource.java
1 file changed, 2 insertions(+), 4 deletions(-)
Approvals:
Juan Hernandez: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, but someone else must approve
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/76908
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0166b65494c78a5559f9c7b701d0742d8e58148d
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months
Change in ovirt-engine[master]: core: CommandBase#getActionReturnValue return type
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: CommandBase#getActionReturnValue return type
......................................................................
core: CommandBase#getActionReturnValue return type
VdcReturnValueBase#getActionReturnValue returns a generic type T,
which Java 8 allows us to infer.
CommandBase#getActionReturnValue just calls that method, but returns
an Object, forcing the callers to downcast it.
This patch fixes CommandBase#getActionReturnValue return type so it
can also be inferred in order to clean up the code a bit.
Change-Id: I0cf884a78732bf465d90f4e42a1e4d68f762da02
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CommandBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/ConnectAllHostsToLunCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/ovfstore/CreateOvfVolumeForStorageDomainCommand.java
3 files changed, 4 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/78068
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0cf884a78732bf465d90f4e42a1e4d68f762da02
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 5 months