Change in ovirt-engine[ovirt-engine-3.4]: core: db fix event renaming upgrade script.
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: core: db fix event renaming upgrade script.
......................................................................
core: db fix event renaming upgrade script.
db upgrade fails if there's a subscription to VDS_HIGH_NETWORK_USE event
Original upgrade script renamed an event without taking in account that
it may be used by subscribers. This patch updates both event_map and
event_sunscriber tables with the renamed event, in order to do that we
need to remove the FK before the update and adding it back again after
the update is finished.
Change-Id: I3ac7f33fad30aba5cc459ec05dc990a60bbc65e0
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1093283
Signed-off-by: Eli Mesika <emesika(a)redhat.com>
---
M packaging/dbscripts/upgrade/03_04_0720_add_host_interface_high_network_use_event.sql
1 file changed, 3 insertions(+), 0 deletions(-)
Approvals:
Oved Ourfali: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/27292
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3ac7f33fad30aba5cc459ec05dc990a60bbc65e0
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.4
Gerrit-Owner: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 7 months
Change in ovirt-engine[master]: coverity: Fix INVALIDATE_ITERATOR warning in SessionDataCont...
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: coverity: Fix INVALIDATE_ITERATOR warning in SessionDataContainer
......................................................................
coverity: Fix INVALIDATE_ITERATOR warning in SessionDataContainer
Altering a collection while iterating over it with a for loop will most
likely cause ConcurrentModificationException, using an iterator instead
Change-Id: I223c41e0ad0c091532e598f281f0679306f1164c
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/session/SessionDataContainer.java
1 file changed, 5 insertions(+), 6 deletions(-)
Approvals:
Allon Mureinik: Looks good to me, but someone else must approve
Yair Zaslavsky: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/27275
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I223c41e0ad0c091532e598f281f0679306f1164c
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 7 months
Change in ovirt-engine[master]: core: db fix event renaming upgrade script.
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: core: db fix event renaming upgrade script.
......................................................................
core: db fix event renaming upgrade script.
db upgrade fails if there's a subscription to VDS_HIGH_NETWORK_USE event
Original upgrade script renamed an event without taking in account that
it may be used by subscribers.
This patch updates both event_map and event_sunscriber tables with the
renamed event, in order to do that we need to remove the FK before the
update and adding it back again after the update is finished.
Change-Id: I3ac7f33fad30aba5cc459ec05dc990a60bbc65e0
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1093283
Signed-off-by: Eli Mesika <emesika(a)redhat.com>
---
M packaging/dbscripts/upgrade/03_05_0160_add_host_interface_high_network_use_event.sql
1 file changed, 3 insertions(+), 0 deletions(-)
Approvals:
Eli Mesika: Verified
Ohad Basan: Looks good to me, but someone else must approve
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/27287
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3ac7f33fad30aba5cc459ec05dc990a60bbc65e0
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Ohad Basan <obasan(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 7 months
Change in ovirt-engine[ovirt-engine-3.4.1]: core: Activate host doesn't set return value
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: core: Activate host doesn't set return value
......................................................................
core: Activate host doesn't set return value
ActivateVds defacto works but doesn't set the return value to true,
which result REST calls to believe it failed.
Change-Id: Id6802431ebc4239e46ab7df30355e18ebf368e86
Bug-Url: https://bugzilla.redhat.com/1077300
Signed-off-by: Roy Golan <rgolan(a)redhat.com>
(cherry picked from commit 977a612194013378bc4868f44f9b1ab5170a2453)
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ActivateVdsCommand.java
1 file changed, 4 insertions(+), 4 deletions(-)
Approvals:
Roy Golan: Verified
Omer Frenkel: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/27259
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id6802431ebc4239e46ab7df30355e18ebf368e86
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.4.1
Gerrit-Owner: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Eyal Edri <eedri(a)redhat.com>
Gerrit-Reviewer: Ohad Basan <obasan(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 7 months
Change in ovirt-reports[master]: reports: br2c report - added comments to queries
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: reports: br2c report - added comments to queries
......................................................................
reports: br2c report - added comments to queries
Changed the code structure so it will be more readable
and added commets.
Change-Id: I82104ef88054a831cdac46ab9f67c200fb499956
Signed-off-by: Shirly Radco <sradco(a)redhat.com>
---
M packaging/ovirt-reports/resources/Reports/Trend/Hosts/single_host_resource_usage_hour_of_day_br2c_files/br2 full details.jrxml.data
M packaging/ovirt-reports/resources/Reports/Trend/Hosts/single_host_resource_usage_hour_of_day_br2c_files/single_host_resource_usage_hour_of_day_br2c_jrxml.data
2 files changed, 1,297 insertions(+), 933 deletions(-)
Approvals:
Shirly Radco: Verified
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26486
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I82104ef88054a831cdac46ab9f67c200fb499956
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 7 months
Change in ovirt-reports[master]: reports: br2b report - added comments to queries
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: reports: br2b report - added comments to queries
......................................................................
reports: br2b report - added comments to queries
Changed the code structure so it will be more readable
and added commets.
Change-Id: Ibccaba25b0ffefd7d24fd8b446bb1f74caff9296
Signed-off-by: Shirly Radco <sradco(a)redhat.com>
---
M packaging/ovirt-reports/resources/Reports/Trend/Hosts/single_host_resource_usage_dow_br2b_files/br2 full details.jrxml.data
M packaging/ovirt-reports/resources/Reports/Trend/Hosts/single_host_resource_usage_dow_br2b_files/single_host_resource_usage_dow_br2b.data
2 files changed, 1,258 insertions(+), 928 deletions(-)
Approvals:
Shirly Radco: Verified
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26450
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibccaba25b0ffefd7d24fd8b446bb1f74caff9296
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 7 months
Change in ovirt-reports[master]: reports: br2a report - added comments to queries
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: reports: br2a report - added comments to queries
......................................................................
reports: br2a report - added comments to queries
Changed the code structure so it will be more readable
and added commets.
Change-Id: I19031f7037833deae9a232f054d887ba5e946410
Signed-off-by: Shirly Radco <sradco(a)redhat.com>
---
M packaging/ovirt-reports/resources/Reports/Trend/Hosts/single_host_resource_br2a_files/br2 full details.jrxml.data
M packaging/ovirt-reports/resources/Reports/Trend/Hosts/single_host_resource_br2a_files/single_host_resource_br2a_jrxml.data
2 files changed, 1,276 insertions(+), 939 deletions(-)
Approvals:
Shirly Radco: Verified
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26490
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I19031f7037833deae9a232f054d887ba5e946410
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 7 months
Change in ovirt-engine[master]: aaa: extension-manager: prepare to multiple binding support
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: aaa: extension-manager: prepare to multiple binding support
......................................................................
aaa: extension-manager: prepare to multiple binding support
Change-Id: Iab0b2efa0ac95c05a3e682bdf51e528a32b3f84a
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/InitBackendServicesOnStartupBean.java
M backend/manager/modules/extensions-api-root/extensions-api/src/main/java/org/ovirt/engine/api/extensions/Base.java
M backend/manager/modules/extensions-manager/src/main/java/org/ovirt/engine/core/extensions/mgr/ExtensionsManager.java
3 files changed, 150 insertions(+), 56 deletions(-)
Approvals:
Alon Bar-Lev: Verified
Yair Zaslavsky: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/27280
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iab0b2efa0ac95c05a3e682bdf51e528a32b3f84a
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 7 months
Change in ovirt-engine[ovirt-engine-3.4]: core: Disallow RO disks resize in CDA
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: core: Disallow RO disks resize in CDA
......................................................................
core: Disallow RO disks resize in CDA
Resizing RO disks is now disallowed in
UpdateVmDiskCommad.validateCanResizeDisk(), which is called by CDA.
Added VdcBllMessages.ACTION_TYPE_FAILED_CANNOT_RESIZE_READ_ONLY_DISK and
relevant test.
Change-Id: Ibd1b9ec592cacab0156bdede6081b375b7dae935
Bug-Url: https://bugzilla.redhat.com/1092087
Bug-Url: https://bugzilla.redhat.com/1092371
Signed-off-by: Vered Volansky <vvolansk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/UpdateVmDiskCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/UpdateVmDiskCommandTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/VdcBllMessages.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
7 files changed, 35 insertions(+), 0 deletions(-)
Approvals:
Allon Mureinik: Looks good to me, approved
Vered Volansky: Verified
--
To view, visit http://gerrit.ovirt.org/27264
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibd1b9ec592cacab0156bdede6081b375b7dae935
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.4
Gerrit-Owner: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 7 months
Change in ovirt-engine[ovirt-engine-3.4]: core: Fix UpdateVmDiskCommand resize validation
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: core: Fix UpdateVmDiskCommand resize validation
......................................................................
core: Fix UpdateVmDiskCommand resize validation
validateCanResizeDisk() is called from UpdateVmDiskCommand CDA and is
faulty. In it the first two verifications were called whether there was an
attempt to resize the image or not. These two verifications now take
place only if there is indeed an attempt to resize the image.
Need to add a mock in the test.
Change-Id: I760bb3b72d872a1ba5c7af2a9607c7249583652a
Bug-Url: https://bugzilla.redhat.com/1092087
Bug-Url: https://bugzilla.redhat.com/1092371
Signed-off-by: Vered Volansky <vvolansk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/UpdateVmDiskCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/UpdateVmDiskCommandTest.java
2 files changed, 18 insertions(+), 16 deletions(-)
Approvals:
Allon Mureinik: Looks good to me, approved
Vered Volansky: Verified
--
To view, visit http://gerrit.ovirt.org/27271
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I760bb3b72d872a1ba5c7af2a9607c7249583652a
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.4
Gerrit-Owner: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 7 months