Change in ovirt-engine[master]: core: change return value of copyImageVDSCommand for better ...
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: change return value of copyImageVDSCommand for better logging
......................................................................
core: change return value of copyImageVDSCommand for better logging
currently the return value of copyImageVDSCommand is not initialized,
and is defaulted with emtpy guid.
this empty guid appears in the engine.log as the result of the command,
which is useless and confusing.
Changed the return value to have the vdsm task id,
which is a better guid to log there.
note that the returnVaule of this command is not in use at all,
only the createInfo, so this affect only the log.
Change-Id: I80d830dcdcdfa38a76b08e5399b2f916349b9b8e
Signed-off-by: Omer Frenkel <ofrenkel(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/CopyImageVDSCommand.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Omer Frenkel: Verified
Maor Lipchuk: Looks good to me, but someone else must approve
Arik Hadas: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/29609
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I80d830dcdcdfa38a76b08e5399b2f916349b9b8e
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: core: UpdateStorageDomainCommand's DAOs
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: UpdateStorageDomainCommand's DAOs
......................................................................
core: UpdateStorageDomainCommand's DAOs
Replaced calls to DbFacade.getInstance().getStorageDomainStaticDao()
with getStorageDomainStaticDAO(), as per the backend's convention.
This change is done in order to facilitate writing unit tests for this
class.
Change-Id: I716a662d13512331b4e68ca31a13b6fb559227cd
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/UpdateStorageDomainCommand.java
1 file changed, 2 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified
--
To view, visit http://gerrit.ovirt.org/29805
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I716a662d13512331b4e68ca31a13b6fb559227cd
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: core: UpdateStorageDomain's CDA early return
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: UpdateStorageDomain's CDA early return
......................................................................
core: UpdateStorageDomain's CDA early return
Changed UpdateStorageDomainCommand.canDoAction() to use the early return
pattern in order to solve several NullPointerExceptions and enhance
readability.
Tests were added to all the canDoAction() flows to make sure these
changes did not break any functionality.
Change-Id: Iea10984090a759ef07da1fe572c4fdc323ede0e5
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/UpdateStorageDomainCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/UpdateStorageDomainCommandTest.java
2 files changed, 97 insertions(+), 18 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified
--
To view, visit http://gerrit.ovirt.org/29809
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iea10984090a759ef07da1fe572c4fdc323ede0e5
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: core: update SD's setActionMessageParameters
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: update SD's setActionMessageParameters
......................................................................
core: update SD's setActionMessageParameters
Moved the inclusion of VAR__ACTION__UPDATE in UpdateStorageDomainCommand
from canDoAction() to it's rightful place, setActionMessageParameters().
This patch also includes a basic test case that verifies the above
change was done correctly.
Change-Id: I98d9959cb79e3786e5fb51d50e1e1961e85bf629
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/UpdateStorageDomainCommand.java
A backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/UpdateStorageDomainCommandTest.java
2 files changed, 97 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified
--
To view, visit http://gerrit.ovirt.org/29808
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I98d9959cb79e3786e5fb51d50e1e1961e85bf629
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: core: Check messages when CDA succeeds
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Check messages when CDA succeeds
......................................................................
core: Check messages when CDA succeeds
Improved CanDoActionTestUtils.runAndAssertCanDoActionSuccess to check
not only that canDoAction() returned true, but also that it did not add
any messages to the return value.
Change-Id: I72d4ee52679db995aba9155c71954c13be613fa4
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/CanDoActionTestUtils.java
1 file changed, 4 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified
Moti Asayag: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/29807
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I72d4ee52679db995aba9155c71954c13be613fa4
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: core: StorageDomainManagementCommandBase's DAOs
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: StorageDomainManagementCommandBase's DAOs
......................................................................
core: StorageDomainManagementCommandBase's DAOs
Replaced call to DbFacade.getInstance().getStorageDomainStaticDao() with
getStorageDomainStaticDAO() as per the backend's convention.
This change is done in order to facilitate writing unit tests.
Change-Id: Ief680d1131104d28d9ec2850257bd84ff28fe5ad
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/StorageDomainManagementCommandBase.java
1 file changed, 1 insertion(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified
--
To view, visit http://gerrit.ovirt.org/29806
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ief680d1131104d28d9ec2850257bd84ff28fe5ad
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: core: ERROR_CANNOT_CHANGE_STORAGE_DOMAIN_FIELDS
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ERROR_CANNOT_CHANGE_STORAGE_DOMAIN_FIELDS
......................................................................
core: ERROR_CANNOT_CHANGE_STORAGE_DOMAIN_FIELDS
ERROR_CANNOT_CHANGE_STORAGE_DOMAIN_FIELDS' error message claims that
only a storage domain's name can be updated, but according to the code,
the name, description and comment can be updated.
This patch fixes this message accordingly.
Change-Id: Idf9049d0e47bcf3c96ccd73f70907dce2c47460b
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
4 files changed, 4 insertions(+), 4 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/29810
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Idf9049d0e47bcf3c96ccd73f70907dce2c47460b
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: webadmin: Fix exception related to display network warning
by lvernia@redhat.com
Lior Vernia has submitted this change and it was merged.
Change subject: webadmin: Fix exception related to display network warning
......................................................................
webadmin: Fix exception related to display network warning
ClassCastException, probably due to misunderstanding of the network
operations.
Change-Id: Iac63576d8e15bdae47ec0e08ae2b64395adc4765
Bug-Url: https://bugzilla.redhat.com/1078836
Signed-off-by: Lior Vernia <lvernia(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/network/NetworkOperation.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Alona Kaplan: Looks good to me, approved
Lior Vernia: Verified
--
To view, visit http://gerrit.ovirt.org/29821
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iac63576d8e15bdae47ec0e08ae2b64395adc4765
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: webadmin: Mention host's name in Setup Networks title
by lvernia@redhat.com
Lior Vernia has submitted this change and it was merged.
Change subject: webadmin: Mention host's name in Setup Networks title
......................................................................
webadmin: Mention host's name in Setup Networks title
Added the host name to the dialog's title, so that users will easily
be aware of which host's networks they're configuring.
Change-Id: Id3eaa163564846f2c24e1e86e49b7ec3879dcf85
Bug-Url: https://bugzilla.redhat.com/1114882
Signed-off-by: Lior Vernia <lvernia(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/HostInterfaceListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/HostSetupNetworksModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/networks/NetworkHostListModel.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/UIConstants.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/UIMessages.java
5 files changed, 10 insertions(+), 14 deletions(-)
Approvals:
Lior Vernia: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/29820
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id3eaa163564846f2c24e1e86e49b7ec3879dcf85
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[ovirt-engine-3.5]: aaa: Fixing Sync
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: aaa: Fixing Sync
......................................................................
aaa: Fixing Sync
Change-Id: I3a66a7c235f16ff26cac3a779de688c73d67f4a2
Topic: AAA
Signed-off-by: Yair Zaslavsky <yzaslavs(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/DbUserCacheManager.java
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/DirectoryEntryKey.java
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/SyncUsers.java
3 files changed, 145 insertions(+), 207 deletions(-)
Approvals:
Alon Bar-Lev: Looks good to me, but someone else must approve
Yair Zaslavsky: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/29915
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3a66a7c235f16ff26cac3a779de688c73d67f4a2
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months