Change in ovirt-engine[master]: restapi: Support link to multiple VMs from devices
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Support link to multiple VMs from devices
......................................................................
restapi: Support link to multiple VMs from devices
This patch adds a new "vms" element to the base type used for devices.
It is intended to gradually replace the existing "vm" element, as this
supports only one virtual machine, but devices like disks can be in use
by multiple VMs.
Change-Id: Ia08f6bc5f6c3998e77017f164b5bba237a3319da
Related-To: https://bugzilla.redhat.com/1132502
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/interface/definition/src/main/resources/api.xsd
1 file changed, 8 insertions(+), 1 deletion(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/34695
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia08f6bc5f6c3998e77017f164b5bba237a3319da
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 3 months
Change in ovirt-engine[master]: restapi: Add reference to VM to disks
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Add reference to VM to disks
......................................................................
restapi: Add reference to VM to disks
This patch modifies the top level disk resource so that it populates the
"vms" element with the references to the VMs that are using the disk:
GET /disks/{disk:id}
<disk id="...">
<name>mydisk</name>
<vms>
<vm id="..."/>
<vm id="..."/>
...
</vms>
</disk>
Change-Id: Iaae4d0b0787b5658eab038fd94a6126ce356dd0d
Bug-Url: https://bugzilla.redhat.com/1132502
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendDiskResource.java
1 file changed, 28 insertions(+), 0 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Allon Mureinik: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/34696
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iaae4d0b0787b5658eab038fd94a6126ce356dd0d
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 3 months
Change in ovirt-engine[master]: webadmin: MoveOrCopyDiskModel: postInitStorageDomains refact...
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: webadmin: MoveOrCopyDiskModel: postInitStorageDomains refactoring.
......................................................................
webadmin: MoveOrCopyDiskModel: postInitStorageDomains refactoring.
postInitStorageDomains function was using multiple filtering on the same
list of storage domains to create destination storage domain list for
each disk model in this model. Going through this list again and again
is redundant, thus this patch changes it to makes a single run on the
domains list and builds the destination array in one iteration.
Change-Id: I7538a341c3a7059b0a6ee369ca1a9b33648df456
Signed-off-by: Amit Aviram <aaviram(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/Linq.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/MoveOrCopyDiskModel.java
2 files changed, 56 insertions(+), 65 deletions(-)
Approvals:
Daniel Erez: Looks good to me, approved
Amit Aviram: Verified
--
To view, visit http://gerrit.ovirt.org/36555
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7538a341c3a7059b0a6ee369ca1a9b33648df456
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 3 months
Change in ovirt-engine[ovirt-engine-3.5]: core: Remove redundant threshold call
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Remove redundant threshold call
......................................................................
core: Remove redundant threshold call
While adding storage domains to a map in
ImagesHandler.fillImagesMapBasedOnTemplate(), there's a threshold check.
This check is redundant and buggy here.
Redundant because there are storage allocation checks in the system
now, which should be called in due time.
Buggy, since in case the threshold has been met, the threshold
validation fails, but with no error at the time of failure.
The map is not filled correctly, and we get another, unrelated error.
This patch removes the threshold validation and relies on it being
called when it should.
Change-Id: Ifb4357a19bc51ae5feb3c8e79ff36f3adacc327f
Bug-Url: https://bugzilla.redhat.com/1185613
Related-To: https://bugzilla.redhat.com/1179690
Signed-off-by: Vered Volansky <vvolansk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CommonVmPoolWithVmsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImagesHandler.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MoveOrCopyTemplateCommand.java
4 files changed, 7 insertions(+), 9 deletions(-)
Approvals:
Allon Mureinik: Looks good to me, approved
Vered Volansky: Verified
--
To view, visit http://gerrit.ovirt.org/37254
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifb4357a19bc51ae5feb3c8e79ff36f3adacc327f
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 3 months
Change in ovirt-engine[ovirt-engine-3.5]: core: ovf_store isn't added
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: ovf_store isn't added
......................................................................
core: ovf_store isn't added
When disk is added and there is no active user- currently
only for ovf_store disk, disk profile permission check causes
NPE.
Since user is null when command is invoked by the internally,
we can skip the permission check.
Bug-Url: https://bugzilla.redhat.com/1185615
Signed-off-by: Gilad Chaplik <gchaplik(a)redhat.com>
Change-Id: I0ab3247d0f80e2f5123aace3fac58bee2a8a7b8d
(cherry picked from commit 6015932ec838f79a2229dcf4ff4dfd5d57a1d7e3)
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/profiles/DiskProfileHelper.java
1 file changed, 2 insertions(+), 1 deletion(-)
Approvals:
Gilad Chaplik: Verified
Allon Mureinik: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/37269
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0ab3247d0f80e2f5123aace3fac58bee2a8a7b8d
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 3 months
Change in ovirt-engine[master]: core: Make VdsManager.lastUpdate publically accessible
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: core: Make VdsManager.lastUpdate publically accessible
......................................................................
core: Make VdsManager.lastUpdate publically accessible
Add public VdsManager.getLastUpdate() method to prevent passing
lastUpdate value through VdsEventListener to VdsNotRespondingTreatment.
Change-Id: Ie40f0aea7e5d968cfe919c1921684a2eb26176d1
Bug-Url: https://bugzilla.redhat.com/1182510
Signed-off-by: Martin Perina <mperina(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsEventListener.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsNotRespondingTreatmentCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/FenceVdsActionParameters.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/IVdsEventListener.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsManager.java
5 files changed, 34 insertions(+), 32 deletions(-)
Approvals:
Martin Peřina: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/36967
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie40f0aea7e5d968cfe919c1921684a2eb26176d1
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 3 months
Change in ovirt-engine[master]: core: Make SSH Soft Fencing part of Non Responding Treatment
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: core: Make SSH Soft Fencing part of Non Responding Treatment
......................................................................
core: Make SSH Soft Fencing part of Non Responding Treatment
Makes SSH Soft Fencing execution 1st step of Non Responding Treatment
execution.
Change-Id: I99770873470541bc7f6c3a7338f4bcc10f5e4fb3
Bug-Url: https://bugzilla.redhat.com/1182510
Signed-off-by: Martin Perina <mperina(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RestartVdsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/SshSoftFencingCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsEventListener.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsNotRespondingTreatmentCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/IVdsEventListener.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsManager.java
6 files changed, 78 insertions(+), 56 deletions(-)
Approvals:
Martin Peřina: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/36966
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I99770873470541bc7f6c3a7338f4bcc10f5e4fb3
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 3 months
Change in ovirt-engine[master]: core: Refactor VdsManager.isHostInGracePeriod() method
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: core: Refactor VdsManager.isHostInGracePeriod() method
......................................................................
core: Refactor VdsManager.isHostInGracePeriod() method
Makes VdsManager.isHostInGracePeriod() method public and refactor it
as a part of preparation to make SSH Soft Fencing part of Non
Responding Treatment.
Change-Id: Iddea2ae8e923012405e5cc15badebedc74625b09
Bug-Url: https://bugzilla.redhat.com/1182510
Signed-off-by: Martin Perina <mperina(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsManager.java
1 file changed, 24 insertions(+), 15 deletions(-)
Approvals:
Martin Peřina: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/36965
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iddea2ae8e923012405e5cc15badebedc74625b09
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 3 months
Change in ovirt-engine[ovirt-engine-3.5]: engine: Bump openstack-java-sdk version to 3.0.6
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: engine: Bump openstack-java-sdk version to 3.0.6
......................................................................
engine: Bump openstack-java-sdk version to 3.0.6
Version 3.0.6 supports connecting to the openstack Juno
identity service.
Change-Id: Ie462cd84893330d501be2f2cbb5e9c2003cd206c
Bug-Url: https://bugzilla.redhat.com/1177890
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M ovirt-engine.spec.in
M pom.xml
2 files changed, 2 insertions(+), 2 deletions(-)
Approvals:
Moti Asayag: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/37270
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie462cd84893330d501be2f2cbb5e9c2003cd206c
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Eyal Edri <eedri(a)redhat.com>
Gerrit-Reviewer: Federico Simoncelli <fsimonce(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 3 months
Change in ovirt-engine[master]: webadmin: Fix running concurrent GetImagesList calls
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: webadmin: Fix running concurrent GetImagesList calls
......................................................................
webadmin: Fix running concurrent GetImagesList calls
When navigating to the Images subtab of an ISO storage domain, the
method syncSearch is called. In case one makes another similar request,
e.g., by clicking on another ISO domain, the new request gets
blocked. In this case, the ISOs belonging to the first domain are
displayed for the second domain.
This patch enables concurrent requests to be executed without being
blocked, and thus makes it possible for the new request to override the
old images list with the new one.
Change-Id: Ib6df991f597b26c13395907e99dd03934123e9b7
Bug-Url: https://bugzilla.redhat.com/1129267
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageIsoListModel.java
1 file changed, 0 insertions(+), 5 deletions(-)
Approvals:
Daniel Erez: Looks good to me, approved
Allon Mureinik: Looks good to me, but someone else must approve
Freddy Rolland: Looks good to me, but someone else must approve
Idan Shaby: Verified
--
To view, visit http://gerrit.ovirt.org/37229
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib6df991f597b26c13395907e99dd03934123e9b7
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Candace Sheremeta <cshereme(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 3 months