Change in ovirt-engine[master]: gluster: Sync job for gluster volume snapshots
by kmayilsa@redhat.com
Kanagaraj M has submitted this change and it was merged.
Change subject: gluster: Sync job for gluster volume snapshots
......................................................................
gluster: Sync job for gluster volume snapshots
Sync job for gluster volume snapshots
Change-Id: I7b7bf79b72fc5680dab301b290e7aa860d5c714d
Signed-off-by: Shubhendu Tripathi <shtripat(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterJob.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterJobsManager.java
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterSnapshotSyncJob.java
A backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GlusterSnapshotSyncJobTest.java
A backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/gluster/GlusterSnapshotConfigInfo.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/gluster/GlusterSnapshotStatus.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/VdcBllErrors.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/VdcBllMessages.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/gluster/GlusterFeatureSupported.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/locks/LockingGroup.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/vdscommands/VDSCommandType.java
A backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/vdscommands/gluster/GlusterVolumeSnapshotVDSParameters.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/gluster/GlusterVolumeSnapshotDaoDbFacadeImpl.java
M backend/manager/modules/dal/src/main/resources/bundles/VdsmErrors.properties
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/gluster/AbstractGlusterBrokerCommand.java
A backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/gluster/GetGlusterVolumeSnapshotConfigInfoVDSCommand.java
A backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/gluster/GetGlusterVolumeSnapshotInfoVDSCommand.java
A backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/gluster/GlusterVolumeSnapshotConfigReturnForXmlRpc.java
A backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/gluster/GlusterVolumeSnapshotInfoReturnForXmlRpc.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/jsonrpc/JsonRpcVdsServer.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/IVdsServer.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsServerConnector.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsServerWrapper.java
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/VdsmErrors.java
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/VdsmErrors.properties
M packaging/dbscripts/gluster_volume_snapshot_sp.sql
26 files changed, 1,071 insertions(+), 6 deletions(-)
Approvals:
Shubhendu Tripathi: Verified
Yair Zaslavsky: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/35904
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7b7bf79b72fc5680dab301b290e7aa860d5c714d
Gerrit-PatchSet: 19
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Shubhendu Tripathi <shtripat(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Ramesh N <rnachimu(a)redhat.com>
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Shubhendu Tripathi <shtripat(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
9 years, 11 months
Change in ovirt-engine[master]: engine: Introduce queries for system errata
by masayag@redhat.com
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Introduce queries for system errata
......................................................................
engine: Introduce queries for system errata
The queries are used for fetching errata for the specific
ovirt-engine instance.
Change-Id: I8dd3e50a4ad1dd345d29a2ea1ea756c147d0e2b7
Bug-Url: https://bugzilla.redhat.com/1157377
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetErrataForSystemQuery.java
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetErratumByIdForSystemQuery.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/queries/VdcQueryType.java
3 files changed, 57 insertions(+), 0 deletions(-)
Approvals:
Moti Asayag: Verified
Yair Zaslavsky: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/37804
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8dd3e50a4ad1dd345d29a2ea1ea756c147d0e2b7
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
9 years, 11 months
Change in ovirt-engine[master]: engine: Add SystemProviderFinder
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: engine: Add SystemProviderFinder
......................................................................
engine: Add SystemProviderFinder
The SystemProviderFinder class is responsible for resolving
the system host name and query according to the resolved
value the existence of a matching content host on the katello
service.
Change-Id: I831f3c481259f70bcb4dd2d62f6b16a7b9eca96d
Bug-Url: https://bugzilla.redhat.com/1157377
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/host/provider/foreman/SystemProviderFinder.java
1 file changed, 55 insertions(+), 0 deletions(-)
Approvals:
Moti Asayag: Verified
Yair Zaslavsky: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/37803
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I831f3c481259f70bcb4dd2d62f6b16a7b9eca96d
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
9 years, 11 months
Change in ovirt-engine[master]: engine: Simplify api of content host
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: engine: Simplify api of content host
......................................................................
engine: Simplify api of content host
The provider should server the hosts, vms and the ovirt-engine
itself when query the Katello service for errata. Hence, it is
more reasonable to replace the VdsStatic with a plan string
that represents the host name.
Change-Id: If90053b9213aee1813f50646f3c933e46b1a0a25
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetErrataForHostQuery.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetErratumByIdForHostQuery.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/host/provider/HostProviderProxy.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/host/provider/foreman/ForemanHostProviderProxy.java
4 files changed, 14 insertions(+), 16 deletions(-)
Approvals:
Moti Asayag: Verified
Yair Zaslavsky: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/37802
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If90053b9213aee1813f50646f3c933e46b1a0a25
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
9 years, 11 months
Change in ovirt-engine[master]: engine: Make method for resolving a content host public
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: engine: Make method for resolving a content host public
......................................................................
engine: Make method for resolving a content host public
Increasing the visibility of the method would allow the
client to query a provider via its interface whether a
given host exists.
Change-Id: I622151ee9a586bf4181be4a80c7cd3b4b978dca4
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/host/provider/HostProviderProxy.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/host/provider/foreman/ForemanHostProviderProxy.java
2 files changed, 4 insertions(+), 0 deletions(-)
Approvals:
Moti Asayag: Verified
Yair Zaslavsky: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/37801
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I622151ee9a586bf4181be4a80c7cd3b4b978dca4
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
9 years, 11 months
Change in ovirt-engine[master]: restapi: wrong SDs on templates disks entities
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: restapi: wrong SDs on templates disks entities
......................................................................
restapi: wrong SDs on templates disks entities
Removed deprecated logic from 'BackendReadOnlyDisksResource -> list'
(used only by BackendTemplateDisksResource), which fetches
storage domains using GetStorageDomainsByVmTemplateId and adds
it to all disks in the collection. As a result, all disks contain
all storage domains IDs - a correct behavior pre-MSD (back when
we had a copy template action).
Change-Id: Ica6787d39fbdec49250d4a3a385c9027e288c24e
Bug-Url: https://bugzilla.redhat.com/1193079
Signed-off-by: Daniel Erez <derez(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendReadOnlyDisksResource.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendReadOnlyDisksResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendTemplateDisksResourceTest.java
3 files changed, 4 insertions(+), 75 deletions(-)
Approvals:
Juan Hernandez: Looks good to me, approved
Daniel Erez: Verified
Allon Mureinik: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/37820
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ica6787d39fbdec49250d4a3a385c9027e288c24e
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
9 years, 11 months
Change in ovirt-engine[master]: core: fixing users data insertion
by emesika@redhat.com
Eli Mesika has submitted this change and it was merged.
Change subject: core: fixing users data insertion
......................................................................
core: fixing users data insertion
Changed hex value in insert users script to a call to the PG decode
function since the hex value did not pass in PG 8.4.x on RHEL
Change-Id: I9b522fa1c47df034dce80243440a77fd364d7352
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1192436
Signed-off-by: emesika <emesika(a)redhat.com>
---
M packaging/dbscripts/data/00100_insert_users.sql
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Sandro Bonazzola: Looks good to me, but someone else must approve
Eli Mesika: Verified
Yair Zaslavsky: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/37829
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9b522fa1c47df034dce80243440a77fd364d7352
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: David Caro <dcaroest(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 11 months
Change in mom[master]: logging: fix the exception handler
by alitke@redhat.com
Adam Litke has submitted this change and it was merged.
Change subject: logging: fix the exception handler
......................................................................
logging: fix the exception handler
In the exception handler of the MOM class constructor, there
are two issues
- one, major, is about the name of the logging reference, which
wasn't updated. This will lead to MOM blow in the error (recovery!)
path.
- one, minor, is about the old way to log exceptions, using
the exc_info=True argument.
This patch fixes both.
Change-Id: I58741b7e430180c969f5596575e8b8461de49076
Signed-off-by: Francesco Romani <fromani(a)redhat.com>
Reviewed-on: http://gerrit.ovirt.org/37816
Reviewed-by: Adam Litke <alitke(a)redhat.com>
---
M mom/__init__.py
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Adam Litke: Looks good to me, approved
Francesco Romani: Verified
--
To view, visit http://gerrit.ovirt.org/37816
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I58741b7e430180c969f5596575e8b8461de49076
Gerrit-PatchSet: 2
Gerrit-Project: mom
Gerrit-Branch: master
Gerrit-Owner: Francesco Romani <fromani(a)redhat.com>
Gerrit-Reviewer: Adam Litke <alitke(a)redhat.com>
Gerrit-Reviewer: Francesco Romani <fromani(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
9 years, 11 months
Change in ovirt-node-plugin-vdsm[master]: engine_page: Management Server entry change
by dougsland@redhat.com
Douglas Schilling Landgraf has submitted this change and it was merged.
Change subject: engine_page: Management Server entry change
......................................................................
engine_page: Management Server entry change
This patch remove duplicate code and the need of having an
additional entry to users type the port of management server,
the new schema is:
oVirt Address ___________ so users will only type
the address of oVirt Engine, in case users have it in a different
port (then 443) can be users IP:PORT.
Change-Id: I2a659c2875ed23a27d47032a42a5ef3cf3fd48c0
Signed-off-by: Douglas Schilling Landgraf <dougsland(a)redhat.com>
---
M src/config.py.in
M src/engine_page.py
2 files changed, 69 insertions(+), 58 deletions(-)
Approvals:
Douglas Schilling Landgraf: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/37766
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2a659c2875ed23a27d47032a42a5ef3cf3fd48c0
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-node-plugin-vdsm
Gerrit-Branch: master
Gerrit-Owner: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Fabian Deutsch <fabiand(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
9 years, 11 months
Change in ovirt-engine[master]: packaging: Use CORS filter provided by its own package
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: packaging: Use CORS filter provided by its own package
......................................................................
packaging: Use CORS filter provided by its own package
This patch changes the RPM package so that instead of bundling the .jar
file of the eBay CORS filter it will use the one provided by the
"ebay-cors-filter" package.
Change-Id: I0214720724d998a91ea3c2a5b892c839dd70af62
Related-To: https://bugzilla.redhat.com/1181530
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M ovirt-engine.spec.in
1 file changed, 2 insertions(+), 0 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, approved
Juan Hernandez: Verified
--
To view, visit http://gerrit.ovirt.org/37370
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0214720724d998a91ea3c2a5b892c839dd70af62
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
9 years, 11 months