Change in ovirt-engine[ovirt-engine-4.1]: core: extract lun's discard logic to the LUNs class
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: extract lun's discard logic to the LUNs class
......................................................................
core: extract lun's discard logic to the LUNs class
This patch extracts duplicated code about discard support to two new
methods in Luns: supportsDiscard and hasDiscardZeroesTheDataSupport.
Change-Id: I521ce2f96f074418fce604a4e25ea388860215e1
Related-To: https://bugzilla.redhat.com/1436160
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/utils/BlockStorageDiscardFunctionalityHelper.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/storage/DiskVmElementValidator.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/storage/LUNs.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/AbstractDiskModel.java
4 files changed, 19 insertions(+), 26 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Idan Shaby: Verified
--
To view, visit https://gerrit.ovirt.org/74881
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I521ce2f96f074418fce604a4e25ea388860215e1
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: webadmin: make SanStorageModelBase.getAddedLuns reusable
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: make SanStorageModelBase.getAddedLuns reusable
......................................................................
webadmin: make SanStorageModelBase.getAddedLuns reusable
getAddedLuns used to return only the newly added luns, without the
included ones (those which were already selected before).
This patch adds a new method, getLuns, that receives parameters that
indicate which luns to return - the added and the included ones.
Change-Id: I67717bd3d9ec8c3332e94c0004f567e52294a264
Related-To: https://bugzilla.redhat.com/1436160
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/SanStorageModelBase.java
1 file changed, 13 insertions(+), 5 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Idan Shaby: Verified
--
To view, visit https://gerrit.ovirt.org/74880
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I67717bd3d9ec8c3332e94c0004f567e52294a264
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: webadmin: extract duplicated code in SanStorageModelBase
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: extract duplicated code in SanStorageModelBase
......................................................................
webadmin: extract duplicated code in SanStorageModelBase
Change-Id: I8a5a07b7566725bf76a01404cd1ede3d3db9474c
Related-To: https://bugzilla.redhat.com/1436160
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/SanStorageModelBase.java
1 file changed, 15 insertions(+), 14 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Idan Shaby: Verified
--
To view, visit https://gerrit.ovirt.org/74879
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8a5a07b7566725bf76a01404cd1ede3d3db9474c
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: core: Vm needs to fail running if custom compatibility versi...
by Code Review
>From Shahar Havivi <shavivi(a)redhat.com>:
Shahar Havivi has submitted this change and it was merged.
Change subject: core: Vm needs to fail running if custom compatibility version is not supported.
......................................................................
core: Vm needs to fail running if custom compatibility version is not supported.
Change-Id: I2cab1bd8f53c4d6105fe7a3be7bed825e8c23157
Bug-Url: https://bugzilla.redhat.com/1436577
Signed-off-by: Shahar Havivi <shaharh(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/EngineMessage.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/frontend/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
7 files changed, 15 insertions(+), 0 deletions(-)
Approvals:
Shahar Havivi: Verified
Jenkins CI: Passed CI tests
Arik Hadas: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/74815
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2cab1bd8f53c4d6105fe7a3be7bed825e8c23157
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-3.6]: core: New cluster has disabled overcommit by default (for re...
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: New cluster has disabled overcommit by default (for real now)
......................................................................
core: New cluster has disabled overcommit by default (for real now)
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1434013
Change-Id: I1e69f43fc5b3ed9d4a1757fb16c094edb2e14abd
Signed-off-by: Martin Sivak <msivak(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/ClusterValidator.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/UpdateVdsGroupCommandTest.java
2 files changed, 4 insertions(+), 4 deletions(-)
Approvals:
Denis Chaplygin: Looks good to me, but someone else must approve
Martin Sivák: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
Jenny Tokar: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/74826
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1e69f43fc5b3ed9d4a1757fb16c094edb2e14abd
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Denis Chaplygin <dchaplyg(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Jenny Tokar <jtokar(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
7 years, 8 months
Change in ovirt-engine[master]: webadmin: improve Discard After Delete UX
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: improve Discard After Delete UX
......................................................................
webadmin: improve Discard After Delete UX
When creating/editing a block storage domain, the user is not warned
when the value of Discard After Delete (DAD) is illegal (the storage
domain contains at least one lun that doesn't support discard).
Since the error comes from the backend, the user doesn't get the chance
to fix the configuration before the popup is closed.
This patch adds UI verifications for DAD to gain a better UX:
1. When enabling DAD, or when selecting a lun while DAD is already
enabled - if the configuration is illegal then a warning message is
shown above the view.
2. When clicking on "ok", DAD is validated so that if the configuration
is illegal then the DAD checkbox is highlighted and the operation is
blocked in the UI level.
Change-Id: I3024fb3ba46ed568cfa0d9d84c15c416da7e335f
Bug-Url: https://bugzilla.redhat.com/1436160
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/storage/SanStorageLunToTargetList.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/storage/SanStorageTargetToLunList.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/SanStorageModelBase.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageModel.java
4 files changed, 68 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved; Passed CI tests
Idan Shaby: Verified
--
To view, visit https://gerrit.ovirt.org/73851
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3024fb3ba46ed568cfa0d9d84c15c416da7e335f
Gerrit-PatchSet: 10
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: webadmin: extract duplicated code in SanStorageModelBase
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: extract duplicated code in SanStorageModelBase
......................................................................
webadmin: extract duplicated code in SanStorageModelBase
Change-Id: I8a5a07b7566725bf76a01404cd1ede3d3db9474c
Related-To: https://bugzilla.redhat.com/1436160
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/SanStorageModelBase.java
1 file changed, 15 insertions(+), 14 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, but someone else must approve
Idan Shaby: Verified
--
To view, visit https://gerrit.ovirt.org/74577
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8a5a07b7566725bf76a01404cd1ede3d3db9474c
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: webadmin: make SanStorageModelBase.getAddedLuns reusable
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: make SanStorageModelBase.getAddedLuns reusable
......................................................................
webadmin: make SanStorageModelBase.getAddedLuns reusable
getAddedLuns used to return only the newly added luns, without the
included ones (those which were already selected before).
This patch adds a new method, getLuns, that receives parameters that
indicate which luns to return - the added and the included ones.
Change-Id: I67717bd3d9ec8c3332e94c0004f567e52294a264
Related-To: https://bugzilla.redhat.com/1436160
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/SanStorageModelBase.java
1 file changed, 13 insertions(+), 5 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Idan Shaby: Verified
--
To view, visit https://gerrit.ovirt.org/74578
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I67717bd3d9ec8c3332e94c0004f567e52294a264
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: core: extract lun's discard logic to the LUNs class
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: extract lun's discard logic to the LUNs class
......................................................................
core: extract lun's discard logic to the LUNs class
This patch extracts duplicated code about discard support to two new
methods in Luns: supportsDiscard and hasDiscardZeroesTheDataSupport.
Change-Id: I521ce2f96f074418fce604a4e25ea388860215e1
Related-To: https://bugzilla.redhat.com/1436160
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/utils/BlockStorageDiscardFunctionalityHelper.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/storage/DiskVmElementValidator.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/storage/LUNs.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/AbstractDiskModel.java
4 files changed, 19 insertions(+), 26 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved; Passed CI tests
Idan Shaby: Verified
--
To view, visit https://gerrit.ovirt.org/74749
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I521ce2f96f074418fce604a4e25ea388860215e1
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-hosted-engine-ha[v2.1.z]: Fix :transition: comments to correctly visualize the FSM
by Code Review
>From Martin Sivák <msivak(a)redhat.com>:
Martin Sivák has submitted this change and it was merged.
Change subject: Fix :transition: comments to correctly visualize the FSM
......................................................................
Fix :transition: comments to correctly visualize the FSM
Change-Id: I249b2dffbfc57281acb73ea8df31149389a5a841
Signed-off-by: Andrej Krejcir <akrejcir(a)redhat.com>
---
M ovirt_hosted_engine_ha/agent/states.py
1 file changed, 8 insertions(+), 3 deletions(-)
Approvals:
Martin Sivák: Looks good to me, approved
Jenkins CI: Passed CI tests
Andrej Krejcir: Verified
--
To view, visit https://gerrit.ovirt.org/74871
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I249b2dffbfc57281acb73ea8df31149389a5a841
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: v2.1.z
Gerrit-Owner: Andrej Krejcir <akrejcir(a)redhat.com>
Gerrit-Reviewer: Andrej Krejcir <akrejcir(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
7 years, 8 months