Change in ovirt-engine[master]: core: @Singleton GlusterServiceSyncJob
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: @Singleton GlusterServiceSyncJob
......................................................................
core: @Singleton GlusterServiceSyncJob
Make the GlusterServiceSyncJob a @Singleton instead of an old fashion
singleton and inject it instead of explicitly calling getInstance()
Change-Id: I06d37749d93764db82cadb4fe404cda5c4937f7a
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterJobsManager.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterServiceSyncJob.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GlusterServiceSyncJobTest.java
3 files changed, 7 insertions(+), 11 deletions(-)
Approvals:
Denis Chaplygin: Looks good to me, but someone else must approve
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/72575
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I06d37749d93764db82cadb4fe404cda5c4937f7a
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Denis Chaplygin <dchaplyg(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: GlusterServiceSyncJob maps
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GlusterServiceSyncJob maps
......................................................................
core: GlusterServiceSyncJob maps
Anonymously implementing a HashMap just to place values in it is a bad
practice which both "spams" up the classloader with useless anonymous
classes and produces code that's hard to read.
This patch removes the instances of that practice and replaces them with
the better performing Collections.singletonMap where possible or with
an old fashioned HashMap with a series of put calls where it isn't.
Change-Id: Iae6a537076ab389888debe47fc7ed5313fc712b8
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterServiceSyncJob.java
1 file changed, 16 insertions(+), 25 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/73090
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iae6a537076ab389888debe47fc7ed5313fc712b8
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Denis Chaplygin <dchaplyg(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[ovirt-engine-4.1.1.z]: webadmin: Adjust select elements font color on a selected ta...
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Adjust select elements font color on a selected table row
......................................................................
webadmin: Adjust select elements font color on a selected table row
Currently a selected table row font color is set to white but in cases
where the table row contains a select element the white font on the
selected row background will cause it to look disabled, this patch changes
the color to still be black but lighter
Change-Id: Idba9502f71ae69171497aca6cd01d5cf8956ccc1
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
Bug-Url: https://bugzilla.redhat.com/1408134
---
M frontend/webadmin/modules/gwt-common/src/main/resources/org/ovirt/engine/ui/common/css/TabCellTable.css
1 file changed, 4 insertions(+), 0 deletions(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/73314
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Idba9502f71ae69171497aca6cd01d5cf8956ccc1
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1.1.z
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
7 years, 9 months
Change in ovirt-engine[master]: core: GlusterHooksSyncJob operators
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GlusterHooksSyncJob operators
......................................................................
core: GlusterHooksSyncJob operators
Replace "x = x | y" statements with easier to read shorthand "x |= y"
statements.
Change-Id: I6e55b9c56a0b48db572f9555b3a93077543fe30c
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterHookSyncJob.java
1 file changed, 3 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/72573
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6e55b9c56a0b48db572f9555b3a93077543fe30c
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Denis Chaplygin <dchaplyg(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[ovirt-engine-4.1]: webadmin: Adjust select elements font color on a selected ta...
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Adjust select elements font color on a selected table row
......................................................................
webadmin: Adjust select elements font color on a selected table row
Currently a selected table row font color is set to white but in cases
where the table row contains a select element the white font on the
selected row background will cause it to look disabled, this patch changes
the color to still be black but lighter
Change-Id: Idba9502f71ae69171497aca6cd01d5cf8956ccc1
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
Bug-Url: https://bugzilla.redhat.com/1408134
---
M frontend/webadmin/modules/gwt-common/src/main/resources/org/ovirt/engine/ui/common/css/TabCellTable.css
1 file changed, 4 insertions(+), 0 deletions(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved; Passed CI tests
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/73313
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Idba9502f71ae69171497aca6cd01d5cf8956ccc1
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
7 years, 9 months
Change in ovirt-engine[master]: webadmin: Adjust select elements font color on a selected ta...
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Adjust select elements font color on a selected table row
......................................................................
webadmin: Adjust select elements font color on a selected table row
Currently a selected table row font color is set to white but in cases
where the table row contains a select element the white font on the
selected row background will cause it to look disabled, this patch changes
the color to still be black but lighter
Change-Id: Idba9502f71ae69171497aca6cd01d5cf8956ccc1
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
Bug-Url: https://bugzilla.redhat.com/1408134
---
M frontend/webadmin/modules/gwt-common/src/main/resources/org/ovirt/engine/ui/common/css/TabCellTable.css
1 file changed, 4 insertions(+), 0 deletions(-)
Approvals:
Tal Nisan: Verified
Jenkins CI: Passed CI tests
Daniel Erez: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/73307
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Idba9502f71ae69171497aca6cd01d5cf8956ccc1
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine-sdk-ruby[master]: Update to model 4.2.6 and metamodel 1.2.2
by Code Review
>From Juan Hernandez <juan.hernandez(a)redhat.com>:
Juan Hernandez has submitted this change and it was merged.
Change subject: Update to model 4.2.6 and metamodel 1.2.2
......................................................................
Update to model 4.2.6 and metamodel 1.2.2
The more relevant changes in the new version of the model are the
following:
* Add `auto_storage_select` attribute to the `VmPool` type.
* Move `vnic_profile_mappings` and `reassign_bad_macs` from
the `import` operation to the `register` operation
* Add `all_content` parameter to snapshots services.
* Add `default_route` value to the `NetworkUsage` enum.
* Add IPv6 details to the `NicConfiguration` type.
* Add NFS 4.2 support.
The changes in the metamodel aren't relevant for the Ruby SDK, but it is
good practice to keep it updated to use the latest version.
Change-Id: Id97a0a939c0c18eb1134c02ee6f6b26058131bab
Related-To: https://bugzilla.redhat.com/1425731
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M pom.xml
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/73333
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id97a0a939c0c18eb1134c02ee6f6b26058131bab
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine-sdk-ruby
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: GlusterSyncJob singletonList
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GlusterSyncJob singletonList
......................................................................
core: GlusterSyncJob singletonList
Replace a call to Arrays.asList with a single argument with the
dedicated, better performing Collections.singletonList.
Change-Id: I63ca7b975f2686d1256a57946211519fafd4cbff
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterSyncJob.java
1 file changed, 1 insertion(+), 2 deletions(-)
Approvals:
Denis Chaplygin: Looks good to me, but someone else must approve
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/72571
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I63ca7b975f2686d1256a57946211519fafd4cbff
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Denis Chaplygin <dchaplyg(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: GlusterSyncJob maps
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GlusterSyncJob maps
......................................................................
core: GlusterSyncJob maps
Anonymously implementing a HashMap just to place values in it is a bad
practice which both "spams" up the classloader with useless anonymous
classes and produces code that's hard to read.
This patch removes the instances of that practice and replaces them with
the better performing Collections.singletonMap where possible or with
an old fashioned HashMap with a series of put calls where it isn't.
Change-Id: Iaf12e31554f2891458c1f39d729c177216502eb2
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterSyncJob.java
1 file changed, 22 insertions(+), 50 deletions(-)
Approvals:
Denis Chaplygin: Looks good to me, but someone else must approve
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/72570
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iaf12e31554f2891458c1f39d729c177216502eb2
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Denis Chaplygin <dchaplyg(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: Remove unused GlusterSyncJob#getVdsIps
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Remove unused GlusterSyncJob#getVdsIps
......................................................................
core: Remove unused GlusterSyncJob#getVdsIps
Change-Id: I5f5e4ab84f932f51cf015a7d4d39aa46ffbdc3fa
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterSyncJob.java
1 file changed, 0 insertions(+), 10 deletions(-)
Approvals:
Denis Chaplygin: Looks good to me, but someone else must approve
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/72569
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5f5e4ab84f932f51cf015a7d4d39aa46ffbdc3fa
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Denis Chaplygin <dchaplyg(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months