Change in ovirt-engine[master]: engine: Avoid redundant injection in HostUpgradeManager
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Avoid redundant injection in HostUpgradeManager
......................................................................
engine: Avoid redundant injection in HostUpgradeManager
Change-Id: I4a9ce7bced2322b543e97d136586aecfd0a274a6
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/host/HostUpgradeManager.java
1 file changed, 2 insertions(+), 3 deletions(-)
Approvals:
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/75260
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4a9ce7bced2322b543e97d136586aecfd0a274a6
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: engine: Avoid injection when creating an alert log
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Avoid injection when creating an alert log
......................................................................
engine: Avoid injection when creating an alert log
Change-Id: I9ee2e018bd6cffa6fbb5966b0aa4b820a15f7b39
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsCommand.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/AuditLogableBase.java
2 files changed, 10 insertions(+), 8 deletions(-)
Approvals:
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/75244
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9ee2e018bd6cffa6fbb5966b0aa4b820a15f7b39
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: utils: do not reject tasks
by Code Review
>From Piotr Kliczewski <piotr.kliczewski(a)gmail.com>:
Piotr Kliczewski has submitted this change and it was merged.
Change subject: utils: do not reject tasks
......................................................................
utils: do not reject tasks
The usage of RejectedExecutionHandler was not correct and and as a
result we used ThreadPoolExecutor.AbortPolicy which is default. Using
ThreadPoolExecutor.CallerRunsPolicy was intended and seems like good
idea so we need to make sure that we are going to use this policy.
Bug-Url: https://bugzilla.redhat.com/1438497
Change-Id: Icc4ed0b241b0961c49daa9ec29a905a0a15487f2
Signed-off-by: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
---
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/threadpool/ThreadPoolUtil.java
1 file changed, 2 insertions(+), 10 deletions(-)
Approvals:
Piotr Kliczewski: Verified
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/75138
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Icc4ed0b241b0961c49daa9ec29a905a0a15487f2
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: engine: Ensure snapshot deletion after geo-rep sync
by Code Review
>From Piotr Kliczewski <piotr.kliczewski(a)gmail.com>:
Piotr Kliczewski has submitted this change and it was merged.
Change subject: engine: Ensure snapshot deletion after geo-rep sync
......................................................................
engine: Ensure snapshot deletion after geo-rep sync
The temp snapshots created prior to geo-rep should only be
deleted once the geo-rep checkpoint completes.
setting parentParameters to ensure that
command is marked completed only when callback completes
Change-Id: I589bdf269c6d0b44a977a6b9f94de43072c49317
iBug-Url: https://bugzilla.redhat.com/1437865
Signed-off-by: Sahina Bose <sabose(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/dr/GlusterStorageSyncCommand.java
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Sahina Bose: Verified
Liron Aravot: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/75316
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I589bdf269c6d0b44a977a6b9f94de43072c49317
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: webadmin: Adjust DashboardDataServlet query cache handling
by Code Review
>From Piotr Kliczewski <piotr.kliczewski(a)gmail.com>:
Piotr Kliczewski has submitted this change and it was merged.
Change subject: webadmin: Adjust DashboardDataServlet query cache handling
......................................................................
webadmin: Adjust DashboardDataServlet query cache handling
Switch dashboard query cache from running at set intervals to waiting for
a set amount of time between the completion of one and the execution of
the next. Additionally, if background cache update is enabled (the default),
cache evistion isn't used. If the cache update is disabled, then cache
eviction is enabled - allowing the queries to be cached for at least a
short time.
Change-Id: I0d4cf7d1289232c7d869e47c72b6709a5caf8815
Bug-Url: https://bugzilla.redhat.com/1438962
Signed-off-by: Scott J Dickerson <sdickers(a)redhat.com>
---
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/server/dashboard/DashboardDataServlet.java
1 file changed, 19 insertions(+), 12 deletions(-)
Approvals:
Alexander Wels: Looks good to me, approved
Jenkins CI: Passed CI tests
Scott Dickerson: Verified
--
To view, visit https://gerrit.ovirt.org/75308
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0d4cf7d1289232c7d869e47c72b6709a5caf8815
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Scott Dickerson <sdickers(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Scott Dickerson <sdickers(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: core: Fix LunDao#removeAll
by Code Review
>From Piotr Kliczewski <piotr.kliczewski(a)gmail.com>:
Piotr Kliczewski has submitted this change and it was merged.
Change subject: core: Fix LunDao#removeAll
......................................................................
core: Fix LunDao#removeAll
The removeAll method uses the procedure defined by
setProcedureNameForRemove.
Since it was not called, the removeAll method tried to use the
standard method by naming convention ("deleteluns"), which, of
course, does not exist.
This patch adds the missing call to setProcedureNameForRemove in
LunDaoImpl, a test in LunDaoTest to assure the fix is correct, and
some fixture data to use in this test.
Change-Id: I7bb32324b2412f03d09277c91fd7dd9f9b32729e
Bug-Url: https://bugzilla.redhat.com/1439692
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/LunDaoImpl.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/FixturesTool.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/LunDaoTest.java
M backend/manager/modules/dal/src/test/resources/fixtures.xml
4 files changed, 33 insertions(+), 0 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/75307
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7bb32324b2412f03d09277c91fd7dd9f9b32729e
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: utils: do not reject tasks
by Code Review
>From Martin Peřina <mperina(a)redhat.com>:
Martin Peřina has submitted this change and it was merged.
Change subject: utils: do not reject tasks
......................................................................
utils: do not reject tasks
The usage of RejectedExecutionHandler was not correct and and as a
result we used ThreadPoolExecutor.AbortPolicy which is default. Using
ThreadPoolExecutor.CallerRunsPolicy was intended and seems like good
idea so we need to make sure that we are going to use this policy.
Bug-Url: https://bugzilla.redhat.com/1438497
Change-Id: Icc4ed0b241b0961c49daa9ec29a905a0a15487f2
Signed-off-by: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
---
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/threadpool/ThreadPoolUtil.java
1 file changed, 2 insertions(+), 10 deletions(-)
Approvals:
Piotr Kliczewski: Verified
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
Moti Asayag: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/75229
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Icc4ed0b241b0961c49daa9ec29a905a0a15487f2
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: aaa: Empty credentials warning message not localized
by Code Review
>From Martin Peřina <mperina(a)redhat.com>:
Martin Peřina has submitted this change and it was merged.
Change subject: aaa: Empty credentials warning message not localized
......................................................................
aaa: Empty credentials warning message not localized
Invalid credential messages should
be localized.
Change-Id: Ibf1111ce7b87bf6c3412dd45cd67a94ed1df99c9
Bug-Url: https://bugzilla.redhat.com/1417839
Signed-off-by: Ravi Nori <rnori(a)redhat.com>
---
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/InteractiveAuthServlet.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/InteractiveBasicAuthServlet.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OAuthTokenServlet.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/utils/Credentials.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/utils/NonInteractiveAuth.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/utils/SsoConstants.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/utils/SsoUtils.java
M backend/manager/modules/enginesso/src/main/resources/AppMessages.properties
8 files changed, 45 insertions(+), 17 deletions(-)
Approvals:
Martin Peřina: Looks good to me, approved
Ravi Nori: Verified
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/75094
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibf1111ce7b87bf6c3412dd45cd67a94ed1df99c9
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: webadmin: Linq#where signature
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: Linq#where signature
......................................................................
webadmin: Linq#where signature
As Linq#where returns a List anyway, this patch makes that fact
explicit in its return value. This achieves two purposes:
1. It makes the code easier to understand. E.g., a careless reader
could assume that if a HashSet is passed to where, a HashSet would
be returned.
2. It allows cleaning up the code and saving redundant Linq#toList
calls, which may slightly improve performance.
Change-Id: I5e351743e655e980a3947ba4292a05ff220ba75d
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/Linq.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/dataprovider/AsyncDataProvider.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/ImportStorageModelBehavior.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageModelBehavior.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/userportal/AbstractUserPortalListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/SnapshotModel.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/host/panels/ItemInfoPopup.java
7 files changed, 16 insertions(+), 18 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/75160
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5e351743e655e980a3947ba4292a05ff220ba75d
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: webadmin: Inline Linq#findAllStorageDomainsBySharedStatus
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: Inline Linq#findAllStorageDomainsBySharedStatus
......................................................................
webadmin: Inline Linq#findAllStorageDomainsBySharedStatus
Linq#findAllStorageDomainsBySharedStatus is only used in one place,
StorageListModel, on a list that is verified to have a single item in
it. As such, it's a poor fit for a general-purpose class like Linq.
This patch removes the aforementioned method and rewrites its logic
in a simple and straight forward way directly in StorageListModel.
Change-Id: I5787aa990e66584d2a125ff7a0c9f40da4a6fcf8
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/Linq.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageListModel.java
2 files changed, 1 insertion(+), 12 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/75178
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5787aa990e66584d2a125ff7a0c9f40da4a6fcf8
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months