Change in ovirt-engine[master]: core: Fix LunDao#removeAll
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Fix LunDao#removeAll
......................................................................
core: Fix LunDao#removeAll
The removeAll method uses the procedure defined by
setProcedureNameForRemove.
Since it was not called, the removeAll method tried to use the
standard method by naming convention ("deleteluns"), which, of
course, does not exist.
This patch adds the missing call to setProcedureNameForRemove in
LunDaoImpl, a test in LunDaoTest to assure the fix is correct, and
some fixture data to use in this test.
Change-Id: I7bb32324b2412f03d09277c91fd7dd9f9b32729e
Bug-Url: https://bugzilla.redhat.com/1439692
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/LunDaoImpl.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/FixturesTool.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/LunDaoTest.java
M backend/manager/modules/dal/src/test/resources/fixtures.xml
4 files changed, 35 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/75302
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7bb32324b2412f03d09277c91fd7dd9f9b32729e
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: core: LunDaoTest: use existing FixturesTool IDs
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: LunDaoTest: use existing FixturesTool IDs
......................................................................
core: LunDaoTest: use existing FixturesTool IDs
Change-Id: I826431915d61cb355cae445d80aee6ded88ff67d
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/LunDaoTest.java
1 file changed, 2 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/75300
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I826431915d61cb355cae445d80aee6ded88ff67d
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: core: LunDaoTest to extend BaseGenericDaoTestCase
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: LunDaoTest to extend BaseGenericDaoTestCase
......................................................................
core: LunDaoTest to extend BaseGenericDaoTestCase
Reuse the tests from BaseGenericDaoTestCase instead of the copy-paste
implementations that currently exist in the test.
Change-Id: I4b25996019b6cc4372a86babd6effd72cffe825f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/LunDaoTest.java
1 file changed, 24 insertions(+), 69 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/75301
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4b25996019b6cc4372a86babd6effd72cffe825f
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: core: Remove boiler-plate LunDaoImpl methods
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Remove boiler-plate LunDaoImpl methods
......................................................................
core: Remove boiler-plate LunDaoImpl methods
Remove boiler-plate implementation in LunDaoImpl and reuse the
generic implementations inherited from the base class.
Change-Id: Ib46334481524eee52ebb72eb953f74af7881e4c0
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/LunDaoImpl.java
1 file changed, 0 insertions(+), 57 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/75303
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib46334481524eee52ebb72eb953f74af7881e4c0
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in otopi[otopi-1.6]: plugins: hostname.py: Do not install/update iproute
by Code Review
>From Yedidyah Bar David <didi(a)redhat.com>:
Yedidyah Bar David has submitted this change and it was merged.
Change subject: plugins: hostname.py: Do not install/update iproute
......................................................................
plugins: hostname.py: Do not install/update iproute
This plugin is not really mandatory for anything, it's mainly useful for
debugging. Do not do here an intrusive action (installing or updating a
package) that is not really needed. If we do find it installed, which is
quite common, keep existing functionality.
Change-Id: I45ca3152342e5e93a837cae033ee27196f0dc949
Bug-Url: https://bugzilla.redhat.com/1405838
Signed-off-by: Yedidyah Bar David <didi(a)redhat.com>
(cherry picked from commit 0166f14bf830ac18ad4675179a56d13edbfeff27)
---
M src/plugins/otopi/network/hostname.py
1 file changed, 9 insertions(+), 7 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Yedidyah Bar David: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/75238
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I45ca3152342e5e93a837cae033ee27196f0dc949
Gerrit-PatchSet: 1
Gerrit-Project: otopi
Gerrit-Branch: otopi-1.6
Gerrit-Owner: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: core: Refactor setQcowComapt to use diskImage
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: Refactor setQcowComapt to use diskImage
......................................................................
core: Refactor setQcowComapt to use diskImage
Change-Id: I948795c43e699427238ae71e7cab3188ed13f310
Bug-Url: https://bugzilla.redhat.com/1438252
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/image/BaseImagesCommand.java
1 file changed, 6 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/75211
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I948795c43e699427238ae71e7cab3188ed13f310
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: core: Add try catch block on teardown in images handler
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: Add try catch block on teardown in images handler
......................................................................
core: Add try catch block on teardown in images handler
Add try/catch block when calling teardown for image.
The engine can still use the data fetched from VDSM even if
the teardown fails to execute.
Change-Id: I439334241f3156492d17e76dbfb4f2d33109367a
Bug-Url: https://bugzilla.redhat.com/1438252
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/image/ImagesHandler.java
1 file changed, 5 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/75214
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I439334241f3156492d17e76dbfb4f2d33109367a
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: core: Remove redundant init of QCOW compat in import
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: Remove redundant init of QCOW compat in import
......................................................................
core: Remove redundant init of QCOW compat in import
Since setQcowCompat is now being done in copyImageGroup, there is no
need for setting qcow compat in import command.
Change-Id: I6628061ad8ff7b53d73e31300c0d883f871f1f25
Bug-Url: https://bugzilla.redhat.com/1438252
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ImportVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ImportVmTemplateCommand.java
2 files changed, 0 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/75213
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6628061ad8ff7b53d73e31300c0d883f871f1f25
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: core: Support qcow2 compat on live move
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: Support qcow2 compat on live move
......................................................................
core: Support qcow2 compat on live move
Set qcow2 compat version on live move.
Change-Id: Ic89dce0263180ac85179642b6add63fffaceb62a
Bug-Url: https://bugzilla.redhat.com/1438252
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/lsm/LiveMigrateDiskCommand.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/75215
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic89dce0263180ac85179642b6add63fffaceb62a
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: core: Set qcow compat for snapshots on copy or move
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: Set qcow compat for snapshots on copy or move
......................................................................
core: Set qcow compat for snapshots on copy or move
Set the qcow compat for disk's snapshots on copy or move disk.
Change-Id: Ia1146362e3ebbdd13085449029d8d635cf09e1bb
Bug-Url: https://bugzilla.redhat.com/1438252
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/image/BaseImagesCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/image/CopyImageGroupCommand.java
2 files changed, 31 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/75212
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia1146362e3ebbdd13085449029d8d635cf09e1bb
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months