Change in ovirt-hosted-engine-setup[ovirt-hosted-engine-setup-2.1]: upgrade: fix appliance version check
by Code Review
>From Sandro Bonazzola <sbonazzo(a)redhat.com>:
Sandro Bonazzola has submitted this change and it was merged.
Change subject: upgrade: fix appliance version check
......................................................................
upgrade: fix appliance version check
Fix appliance version check in the eventuality that appliance
version contain more than two values separated by a '.'.
Change-Id: Iee926cb6784cfc04ef41d945457972fdc98f1bef
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1464866
Signed-off-by: Simone Tiraboschi <stirabos(a)redhat.com>
---
M src/plugins/gr-he-upgradeappliance/engine/misc.py
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/78571
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iee926cb6784cfc04ef41d945457972fdc98f1bef
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-hosted-engine-setup
Gerrit-Branch: ovirt-hosted-engine-setup-2.1
Gerrit-Owner: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Ido Rosenzwig <irosenzw(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Rafael Martins <rafael(a)rafaelmartins.eng.br>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: core: Allow to migrate a paused VM with Post-copy policy
by Code Review
>From Arik Hadas <ahadas(a)redhat.com>:
Arik Hadas has submitted this change and it was merged.
Change subject: core: Allow to migrate a paused VM with Post-copy policy
......................................................................
core: Allow to migrate a paused VM with Post-copy policy
Libvirt does not allow to migrate a VM in Paused state with post-copy
migration. If migration policy of a cluster contains a "postcopy"
action, every attempt to migrate a paused VM fails because libvirt
returns an error, not allowing migration to start. On the other side,
the current Post-copy migration policy uses post-copy only as last
resort, when a regular migration stalls. It is unlikely that migration
will be stalling when migrating a paused VM, so it is safe to use a
Post-copy policy with it.
Libvirt bug have been open for this issue:
https://bugzilla.redhat.com/show_bug.cgi?id=1464792
This patch introduces a workaround: MigrateVmCommand will filter a
"postcopy" action out of the effective migration policy, if the VM is in
Paused state. This helps to avoid libvirt error and allows to migrate
such a VM in a cluster with Post-copy migration policy.
Change-Id: I5fcaf057f3d3443d5d0dd30e542a8e159acc5bd4
Signed-off-by: Shmuel Melamud <smelamud(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmCommand.java
1 file changed, 23 insertions(+), 1 deletion(-)
Approvals:
Jenkins CI: Passed CI tests
Shmuel Leib Melamud: Verified
Arik Hadas: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/78308
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5fcaf057f3d3443d5d0dd30e542a8e159acc5bd4
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Michal Skrivanek <michal.skrivanek(a)redhat.com>
Gerrit-Reviewer: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: aaa: Rename error to error_description and error_code to error
by Code Review
>From Martin Peřina <mperina(a)redhat.com>:
Martin Peřina has submitted this change and it was merged.
Change subject: aaa: Rename error to error_description and error_code to error
......................................................................
aaa: Rename error to error_description and error_code to error
Rename error to error_description
and error_code to error for both
OAuth and OpenId code in SSO.
Change Welcome servlet code to
reflect the changes.
Change-Id: I2437e07fb8dc1c2897002b5887c1c2d1f7ee4561
Bug-Url: https://bugzilla.redhat.com/1416491
Signed-off-by: Ravi Nori <rnori(a)redhat.com>
---
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OpenIdUserInfoServlet.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/utils/SsoConstants.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/utils/SsoUtils.java
M backend/manager/modules/welcome/src/main/java/org/ovirt/engine/core/LoginServlet.java
M backend/manager/modules/welcome/src/main/java/org/ovirt/engine/core/LogoutServlet.java
M backend/manager/modules/welcome/src/main/java/org/ovirt/engine/core/OAuthCallbackServlet.java
M backend/manager/modules/welcome/src/main/java/org/ovirt/engine/core/WelcomeServlet.java
M backend/manager/modules/welcome/src/main/java/org/ovirt/engine/core/WelcomeUtils.java
M backend/manager/modules/welcome/src/main/webapp/WEB-INF/ovirt-engine.jsp
9 files changed, 42 insertions(+), 34 deletions(-)
Approvals:
Martin Peřina: Looks good to me, approved
Ravi Nori: Verified
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/78256
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2437e07fb8dc1c2897002b5887c1c2d1f7ee4561
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Ondra Machacek <omachace(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: aaa: Add OpenId support
by Code Review
>From Martin Peřina <mperina(a)redhat.com>:
Martin Peřina has submitted this change and it was merged.
Change subject: aaa: Add OpenId support
......................................................................
aaa: Add OpenId support
Add support for openid discovery,
jwks endpoint, userinfo servlet and
support for prompt and display request
parameters.
Change-Id: I1bf7c53e2ee8b0b42dfaaf50594811f74a20ae53
Bug-Url: https://bugzilla.redhat.com/1416491
Signed-off-by: Ravi Nori <rnori(a)redhat.com>
---
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/InteractiveNextAuthServlet.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OAuthAuthorizeServlet.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OAuthTokenServlet.java
A backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OpenIdAuthorizeServlet.java
A backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OpenIdConfigurationServlet.java
A backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OpenIdJwksServlet.java
A backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OpenIdUserInfoServlet.java
A backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OpenIdUtils.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/utils/SsoConstants.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/utils/SsoSession.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/utils/SsoUtils.java
M backend/manager/modules/enginesso/src/main/webapp/WEB-INF/web.xml
12 files changed, 558 insertions(+), 97 deletions(-)
Approvals:
Martin Peřina: Looks good to me, approved
Ravi Nori: Verified
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/76053
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1bf7c53e2ee8b0b42dfaaf50594811f74a20ae53
Gerrit-PatchSet: 10
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Ondra Machacek <omachace(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: aaa: Add OpenId Token end point
by Code Review
>From Martin Peřina <mperina(a)redhat.com>:
Martin Peřina has submitted this change and it was merged.
Change subject: aaa: Add OpenId Token end point
......................................................................
aaa: Add OpenId Token end point
Add OpenId Connect token endpoint and
remove OpenId connect logic from OAuth
token endpoint.
The OAuth auth code can be used only once
to get the token. A second attempt should
throw an error.
Change-Id: Ic00c6567308108d2eaa3743f7c890be01e26faa0
Bug-Url: https://bugzilla.redhat.com/1416491
Signed-off-by: Ravi Nori <rnori(a)redhat.com>
---
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OAuthAuthorizeServlet.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OAuthTokenServlet.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OpenIdAuthorizeServlet.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OpenIdConfigurationServlet.java
A backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OpenIdTokenServlet.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/servlets/OpenIdUserInfoServlet.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/utils/SsoConstants.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/utils/SsoContext.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/utils/SsoSession.java
M backend/manager/modules/enginesso/src/main/java/org/ovirt/engine/core/sso/utils/SsoUtils.java
M backend/manager/modules/enginesso/src/main/webapp/WEB-INF/web.xml
11 files changed, 320 insertions(+), 112 deletions(-)
Approvals:
Martin Peřina: Looks good to me, approved
Ravi Nori: Verified
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/78257
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic00c6567308108d2eaa3743f7c890be01e26faa0
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Ondra Machacek <omachace(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: webadmin: StorageIsoListModel - use ArrayList#sort
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: StorageIsoListModel - use ArrayList#sort
......................................................................
webadmin: StorageIsoListModel - use ArrayList#sort
Use the better performing ArrayList#sort instead of the general
purpose Collections#sort when sorting the list of RepoImages.
Change-Id: Ic926f8036ebb4602eb769417b4ab4e496012dcd4
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageIsoListModel.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/78611
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic926f8036ebb4602eb769417b4ab4e496012dcd4
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: webadmin: StorageIsoListModel type inference
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: StorageIsoListModel type inference
......................................................................
webadmin: StorageIsoListModel type inference
Change-Id: Ic49cc03dc49c13e271f92c2a7a5a11720934139f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageIsoListModel.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/78610
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic49cc03dc49c13e271f92c2a7a5a11720934139f
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: webadmin: StorageIsoListModel#getSelectedItems casts
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: StorageIsoListModel#getSelectedItems casts
......................................................................
webadmin: StorageIsoListModel#getSelectedItems casts
Remove redundant casts of getSelectedItems to ArrayLists which are
not needed for the class' functionality and do nothing but confuse
the reader.
Change-Id: Id24e6752dbcb20af76050f2935023a5aa0197f4e
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageIsoListModel.java
1 file changed, 4 insertions(+), 6 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/78612
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id24e6752dbcb20af76050f2935023a5aa0197f4e
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[ovirt-engine-4.1]: webadmin: make each disk appear on its own separate line
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: make each disk appear on its own separate line
......................................................................
webadmin: make each disk appear on its own separate line
Currently when multiple disks are selected to be moved,
the disks allocation dialog makes some of the disk's fields appear
in the previous row instead.
Fixed by wrapping each disk with a bootstrap row.
Before screenshot: http://i.imgur.com/ucne2s4.png
After screenshot: http://i.imgur.com/q9ZIWKD.png
Change-Id: I86981b1538f08e728842dcc974ebfb45bd2aea83
Bug-Url: https://bugzilla.redhat.com/1436766
Signed-off-by: Benny Zlotnik <bzlotnik(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/storage/DisksAllocationItemView.ui.xml
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/storage/DisksAllocationView.ui.xml
2 files changed, 44 insertions(+), 26 deletions(-)
Approvals:
Benny Zlotnik: Verified
Alexander Wels: Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/77750
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I86981b1538f08e728842dcc974ebfb45bd2aea83
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Benny Zlotnik <bzlotnik(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Benny Zlotnik <bzlotnik(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-log-collector[master]: inventory: Add validation for inactive storage domains
by Code Review
>From Douglas Schilling Landgraf <dougsland(a)redhat.com>:
Douglas Schilling Landgraf has submitted this change and it was merged.
Change subject: inventory: Add validation for inactive storage domains
......................................................................
inventory: Add validation for inactive storage domains
Change-Id: Ic123c502d650d9bd3e0d4e82afcb3d06c7e90ac5
---
M src/inventory_report/Makefile.am
M src/inventory_report/produceReport/pre-upgrade-checks
M src/inventory_report/produceReport/produceReport.sh
A src/inventory_report/produceReport/sqls/storage_domains_query_get_failing_domains.sql
4 files changed, 17 insertions(+), 0 deletions(-)
Approvals:
Douglas Schilling Landgraf: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/78595
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic123c502d650d9bd3e0d4e82afcb3d06c7e90ac5
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-log-collector
Gerrit-Branch: master
Gerrit-Owner: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months