Change in ovirt-engine[master]: core: CINDERStorageHelper generics
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/79536 )
Change subject: core: CINDERStorageHelper generics
......................................................................
core: CINDERStorageHelper generics
Use the generic Provider<?> instead of a raw type.
Change-Id: Ifd87239c6694f382a34444c109016ad6535a306f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/CINDERStorageHelper.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Freddy Rolland: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/79536
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifd87239c6694f382a34444c109016ad6535a306f
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: core: FCPStorageHelper collections
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/79538 )
Change subject: core: FCPStorageHelper collections
......................................................................
core: FCPStorageHelper collections
Use the optimized Collections#singletonList method for wrapping a
single-item collection instead of the general purpose Arrays#asList.
Change-Id: I50070db6c4c3b35d69e3bc96246516e2bf63b1b4
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/FCPStorageHelper.java
1 file changed, 1 insertion(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/79538
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I50070db6c4c3b35d69e3bc96246516e2bf63b1b4
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: core: CINDERStorageHelper#registerLibvirtSercrets args
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/79537 )
Change subject: core: CINDERStorageHelper#registerLibvirtSercrets args
......................................................................
core: CINDERStorageHelper#registerLibvirtSercrets args
Inline a constant argument to make the code cleaner and easier to
follow.
Change-Id: I1b1fb3d0b4e55cc05461d4b3f71a72515b94c918
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/CINDERStorageHelper.java
1 file changed, 3 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Freddy Rolland: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/79537
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1b1fb3d0b4e55cc05461d4b3f71a72515b94c918
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: core: ISCSIStorageHelper#filterConnectionsUsedByOthers
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/79539 )
Change subject: core: ISCSIStorageHelper#filterConnectionsUsedByOthers
......................................................................
core: ISCSIStorageHelper#filterConnectionsUsedByOthers
Clear conditional logic so that lunId.isEmpty() is only checked once.
While the performance improvement is negligible, this change cleans
up the code and makes it much easier to read and maintain.
Change-Id: I29c87e251d6cc9ca55fa3fd2caae7d83c135405e
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/ISCSIStorageHelper.java
1 file changed, 5 insertions(+), 8 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/79539
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I29c87e251d6cc9ca55fa3fd2caae7d83c135405e
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: core: Multi-type IStorageHelpers
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/79521 )
Change subject: core: Multi-type IStorageHelpers
......................................................................
core: Multi-type IStorageHelpers
Now that the IStorageHelpers no longer rely on naming conventions, a
single class can handle multiple types - specifically, all the
"simple" file types.
Change-Id: I04cb927be4377b5d878ba971b29872ce2099be0e
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/CINDERStorageHelper.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/FCPStorageHelper.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/FileStorageHelper.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/GLUSTERFSStorageHelper.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/ISCSIStorageHelper.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/IStorageHelper.java
D backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/LOCALFSStorageHelper.java
D backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/NFSStorageHelper.java
D backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/POSIXFSStorageHelper.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/StorageHelperDirector.java
10 files changed, 34 insertions(+), 58 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/79521
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I04cb927be4377b5d878ba971b29872ce2099be0e
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: core: Relocate filterConnectionsByStorageType
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/79523 )
Change subject: core: Relocate filterConnectionsByStorageType
......................................................................
core: Relocate filterConnectionsByStorageType
Move filterConnectionsByStorageType to the only place it's used,
AbstractDiskVmCommand.
To align with the production code, StorageHelperBaseTest (which only
contains tests for this method) was removed, and a new
AbstractDiskVmCommandTest was introduced.
Change-Id: Iff01f5bcfe626c199b09dfff6a749aac292f5c2b
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/StorageHelperBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/AbstractDiskVmCommand.java
R backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/disk/AbstractDiskVmCommandTest.java
3 files changed, 11 insertions(+), 14 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/79523
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iff01f5bcfe626c199b09dfff6a749aac292f5c2b
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: core: Relocate getRedundantVolumesToDeleteAfterCommitSnapshot
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/79526 )
Change subject: core: Relocate getRedundantVolumesToDeleteAfterCommitSnapshot
......................................................................
core: Relocate getRedundantVolumesToDeleteAfterCommitSnapshot
Moved the method from CINDERStorageHelper, where it makes little
sense, to the only place it's used, RestoreAllSnapshotsCommand.
Change-Id: Iebb3bdc6cff4509b4cfe56cc4497fbc751d67e32
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/RestoreAllSnapshotsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/CINDERStorageHelper.java
2 files changed, 26 insertions(+), 29 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Freddy Rolland: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/79526
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iebb3bdc6cff4509b4cfe56cc4497fbc751d67e32
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: core: CINDERStorageHelper#isLibrbdAvailable modifiers
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/79527 )
Change subject: core: CINDERStorageHelper#isLibrbdAvailable modifiers
......................................................................
core: CINDERStorageHelper#isLibrbdAvailable modifiers
Make isLibrbdAvailable private, as it is an internal helper method,
not a part of the class' public contract.
Change-Id: I2115b9f9769050998d6e3a7945d8ada19c8ebfe3
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/CINDERStorageHelper.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Freddy Rolland: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/79527
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2115b9f9769050998d6e3a7945d8ada19c8ebfe3
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: core: GLUSTERFSStorageHelper addMessageToAuditLog call
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/79522 )
Change subject: core: GLUSTERFSStorageHelper addMessageToAuditLog call
......................................................................
core: GLUSTERFSStorageHelper addMessageToAuditLog call
Remove redundant static qualification of this call.
Change-Id: Ie28f15008fb61e38e1aac3b83dc353306f98e86e
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/GLUSTERFSStorageHelper.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/79522
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie28f15008fb61e38e1aac3b83dc353306f98e86e
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Denis Chaplygin <dchaplyg(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months
Change in ovirt-engine[master]: core: Remove AbstractDiskVmCommand#filterConnectionsByStorag...
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/79524 )
Change subject: core: Remove AbstractDiskVmCommand#filterConnectionsByStorageType
......................................................................
core: Remove AbstractDiskVmCommand#filterConnectionsByStorageType
Grouping the lun's connections by their storage type is redundant, as
the connections themselves are not used.
The only part of the result of the method used is the types
themselves, which can be extracted much more easily.
Change-Id: If69cf06d13332200a222c1b1af77ef20ffe592b6
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/AbstractDiskVmCommand.java
D backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/disk/AbstractDiskVmCommandTest.java
2 files changed, 4 insertions(+), 104 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/79524
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If69cf06d13332200a222c1b1af77ef20ffe592b6
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 6 months